VOLKSWAGEN POLO questions and answers

VOLKSWAGEN Polo

Ask and answer questions on a variety of VOLKSWAGEN POLO models. Help and advice on everything VOLKSWAGEN POLO. Feel free to ask and answer as many VOLKSWAGEN-related questions as you wish.

Ask a question now

Buy used imageBuy new / nearly new imageContract hire image

Search the questions and answers section:

Below are the latest VOLKSWAGEN POLO questions submitted by visitors to RoadTestReports.co.uk. To supply an answer, simply click on the "Answer this question" link underneath each question. Alternatively, if you want to ask a question, please use this simple form. Please try to make the question as detailed as possible, with all the information necessary for a comprehensive answer included. Please do not use "text speech" or type everything in CAPS LOCK.

Thokozani, South Africa

Volkswagen Polo

My polo have a problem of a steering so if you guys can help me what must I do I am using a polo 5 also known as bhujho 2007 model 1.4 engine,my steering is a power one

Submitted: 29/07/2014 18:49:41 | ID: 100564

Answer this question

Martn, South Africa

Volkswagen Polo

Hi guys. I`m driving a VW Polo 2003 1.6 and my water usage is increasing. Please help or tell me what the problem could be?

Answers

The radiator of the interior heater is most probably leaking. this appears to be a standard thing on the polo as they get older. Check if the carpets are getting wet. The older engines 2002 and older has a flange at the back of the engine with an O ring which also tends to leak. If you live in an area where you don't really use the heater, it is going to be much cheaper to by-pass the heater. To replace the heater radiator is apparently a costly affair. The older polo (2002 and older) appears to have a pan under the radiator which catches the leaking water and channels it out to the engine compartment. The newer models (poorer designed vehicles) uses the interior floor pan for that purpose. Hennie from South Africa

The radiator of the interior heater is most probably leaking. this appears to be a standard thing on the polo as they get older. Check if the carpets are getting wet. The older engines 2002 and older has a flange at the back of the engine with an O ring which also tends to leak. If you live in an area where you don't really use the heater, it is going to be much cheaper to by-pass the heater. To replace the heater radiator is apparently a costly affair. The older polo (2002 and older) appears to have a pan under the radiator which catches the leaking water and channels it out to the engine compartment. The newer models (poorer designed vehicles) uses the interior floor pan for that purpose. Hennie from South Africa

Submitted: 28/07/2014 05:14:13 | ID: 100471

Answer this question

shaun, South Africa

Volkswagen Polo

Hi there, I`m hoping someone can help. I am experiencing a problem with my 2010 Polo Vivo for the past 3 months. As I drive the headlights and instrument cluster blacks out for a few seconds and comes back on. The car also jerks and the epc light comes on and then goes off. I have taken it to many VW workshops and none seem to be able to pick up the problem.

Submitted: 26/07/2014 05:12:02 | ID: 100362

Answer this question

helen jones, Swansea

Volkswagen Polo

my water tank ran a bit low and it overheated will it damage the engine and will it run smoothly if driven long distance.

Submitted: 25/07/2014 00:02:05 | ID: 100312

Answer this question

J-N-Juste, Mauritius

Volkswagen Polo

Sir, I would like to know about how many types of manual gear-boxes we have on Polo from 1994-2000 and their relay linkages, and possible a schematic diagram of the above relay linkages, please

Submitted: 20/07/2014 13:35:00 | ID: 100044

Answer this question

rachael fairhurst, Nottinghamshire

Volkswagen Polo

I have got a 99 Polo Estate and I need to know what oil to put in please? Thank you

Submitted: 18/07/2014 15:12:49 | ID: 99920

Answer this question

saul, South Africa

Volkswagen Polo

Hi, every time when I drive slowly I hear a click sound on the pedal, even when I turn my steering. Please can anyone help? It`s a Polo 1.6 comf 2009

Submitted: 18/07/2014 13:59:26 | ID: 99919

Answer this question

Ishmael Theletsane, South Africa

Volkswagen Polo

When I bought my car I could press the key and hold to open or close windows and now it doesn't work. Why?

Submitted: 16/07/2014 17:33:54 | ID: 99799

Answer this question

marcus, South Africa

Volkswagen Polo

I get a continuous beep when I apply my brakes. What could it be?

Submitted: 16/07/2014 16:49:39 | ID: 99795

Answer this question

Bryan, Ireland

Volkswagen Polo

Hi, I have a 2002 VW Polo comfortline, 1.2 litre. I bought it a few weeks ago (it passed MOT a few days beforehand). I have only driven it about once a week for short drives around 2-5 miles and it's eating petrol, at least I think it is? A few days ago I topped it up by 10 euros at 1.59 a litre. I then drove it home which was about 2 miles and the petrol needle dropped a little bit, just a little, but I thought I`d get 100km from 10 euros and if the needle is dropping after 2 miles it doesn't look great. I have no insurance so I can't take it for a proper drive, so I'm panicking there is something wrong with it? Is this normal for a Polo? It only has 69,000 miles on the clock. Thanks in advance!

Submitted: 16/07/2014 16:49:18 | ID: 99794

Answer this question

mbulelo, South Africa

Volkswagen Polo

The kilometers on the speedo cluster are staying on. Can anybody explain?

Submitted: 16/07/2014 13:34:04 | ID: 99776

Answer this question

kiewiet, South Africa

Volkswagen Polo

My vw polo 2008 comfortline horn goes off without stoping, when I switched the ignition on. What could be the problem ?

Submitted: 16/07/2014 12:02:28 | ID: 99774

Answer this question

gaurav, India

Volkswagen Polo

My VW Polo car will not start at running after one hour

Submitted: 15/07/2014 14:30:33 | ID: 99715

Answer this question

Beverly Gluckman, Israel

Volkswagen Polo

I have a Comfortline Polo 2005 which has done 90,000 km. I have been told that I need to replace the gearbox at a cost of the equivalent of $2,350. Should I have to replace the gearbox after only 90,000 km. Does the price sound reasonable? Thanks.

Submitted: 15/07/2014 11:49:16 | ID: 99710

Answer this question

Craigthomson, City of Glasgow

Volkswagen Polo

Hi there. I have a Polo 2008 plate and all of a sudden my handbrake light has came on and will not go off, resulting in a constant beeping noise when I am driving. Any ideas what this could be caused by or how to fix this problem please? Thanks, Craig

Submitted: 11/07/2014 14:27:42 | ID: 99452

Answer this question

TANGO, South Africa

Volkswagen Polo

I replaced leads and plugs but my car still jerks and has limited power. Any suggestions?

Answers

Hey, my Polo is giving me the same problem. How much did you pay for your plugs? enzo from South Africa

Most probably the ignition coil needs to be replaced Marina from South Africa

Most probably the ignition coil needs to be replaced Marina from South Africa

Most probably the ignition coil needs to be replaced Marina from South Africa

Submitted: 11/07/2014 11:09:55 | ID: 99439

Answer this question

teboho molo, South Africa

Volkswagen Polo

Hi. I'm driving a VW Polo Playa 2001 model hatch fuel injector 1.4. My car`s problem is that the heat gauge always goes to the highest level even after 5 minutes when I'm driving. Sometimes it switches itself off. What could the problem be? The fan however is working fine.

Submitted: 11/07/2014 03:34:59 | ID: 99417

Answer this question

Hassiem, Cornwall

Volkswagen Polo

Good Day A strange knocking sound comes from the Heater Box just behind the centre console.I have actually taken off parts of the front panels to get to the box,and when I'm driving I could feel the something knocking inside the box.I do have a Polo 1.4 2004 model.

Submitted: 09/07/2014 09:58:57 | ID: 99308

Answer this question

lynette, South Africa

Volkswagen Polo

My cars battery light is not appearing on my dash. The alternator had ja problem which was fixed. The light still doesn't appear. What could be the problem

Submitted: 08/07/2014 11:01:10 | ID: 99220

Answer this question

aneesa, South Africa

Volkswagen Polo

I have a vw polo bby engine type 1.4 petrol,when srarting the car would perform well for the 1st 10 mins than after warming it would not rav over 1500 rpms than Epc lite appears on cluster,than car would almost switch off,we changed trottle body,map sensor,what could be the problem,or what to look for.

Submitted: 07/07/2014 21:59:04 | ID: 99187

Answer this question

Sandile, South Africa

Volkswagen Polo

I just overhauled the engine, did block skimming, vavles and changed plugs, water pump and oil filter. then I drove it 1 day after that it jerked, then I checked all the spark plug wires and timing everything is fine, so I changed again the plugs, then now everytime I shift to 2nd and 3rd gears it jerks before it takes power after taking power it stops jerking and still it jerks while on normal rev count (1000). what should be done to stop this problem? plz advise. polo classic 1.6 1998!

Submitted: 07/07/2014 16:05:43 | ID: 99150

Answer this question

aseza, South Africa

Volkswagen Polo

am not getting a positive current on my fuel pump plug....making my fuel pump not to function

Submitted: 07/07/2014 15:54:27 | ID: 99149

Answer this question

Liam Powell, Oxfordshire

Volkswagen Polo

I went to start my car this morning, and it started fine, went into gear okay and reversed onto my drive wear fine, but nothing on the dashboard worked. The rev count, speedometer, clock, mile counter, nothing worked at all. Does anyone know what might cause this?

Submitted: 07/07/2014 09:54:48 | ID: 99121

Answer this question

saj, United Arab Emirates

Volkswagen Polo

suddenly my car engine is making shakes and rpm jumping

Submitted: 07/07/2014 09:17:32 | ID: 99116

Answer this question

kholwi, South Africa

Volkswagen Polo

My car doesn`t want to start in the morning. Can anyone suggest what I can do please?

Submitted: 03/07/2014 11:16:36 | ID: 98887

Answer this question

robby, South Africa

Volkswagen Polo

Hi,I'm driving a 2005 Polo 1.4 (with the 4 round headlights). My problem is my abs light comes on while driving and today my handbrake light started to flash? Could these be linked to each other? Any advice please?

Submitted: 03/07/2014 09:53:40 | ID: 98884

Answer this question

demaine, South Africa

Volkswagen Polo

My car doesn't want to swing at all, but when I use a spanner by starter it starts. What can it be?

Submitted: 03/07/2014 07:48:17 | ID: 98882

Answer this question

Juliana Schaaf, Namibia

Volkswagen Polo

Please be so kind and help me, how can I manually remove a key code from a Polo 9n or BBY 1.4 engine? Please help

Submitted: 01/07/2014 17:40:17 | ID: 98811

Answer this question

khulekani, South Africa

Volkswagen Polo

Oil is coming from the plugs?

Submitted: 01/07/2014 07:20:43 | ID: 98778

Answer this question

xolisa, South Africa

Volkswagen Polo

My 2004 Polo Classic`s petrol gauge is moving anti clockwise. At first it was not moving at all from empty. When I changed the cluster it started moving anti clockwise. What could be the problem? When it's full it shows empty and when it's empty it shows a full tank.

Submitted: 30/06/2014 12:28:38 | ID: 98726

Answer this question

vongani, South Africa

Volkswagen Polo

My car is a Polo Vivo 1.4 hatch....petrol not diesel..

Submitted: 29/06/2014 08:42:19 | ID: 98664

Answer this question

vongani, South Africa

Volkswagen Polo

hi ,i have this problem with my polo vivo 2013 1.4 hatch,..when start it ,it thosent wanna start fisrt time..,when i try it again it will start,but with a funny sound on the engine..like is fighting then after few second therrs this sound .bum bum bum just few second..then it come to a normal sound. what makes this car to do this....?

Submitted: 29/06/2014 08:39:06 | ID: 98663

Answer this question

Maxwelle, South Africa

Volkswagen Polo

Polo Classic 1.6i 97 model. Just overall the motor does not have any power. When driving long distances it cuts off the engine. When you disconnect the airflow meter it takes power. I want to know what causes this?

Answers

Is your MAP sensor still sharp? Please check it nkhumeleni from South Africa

Submitted: 26/06/2014 16:16:15 | ID: 98516

Answer this question

Gaythree Singh, South Africa

Volkswagen Polo

When the heat gauge reaches the half mark, the car keeps switching off when lower gear is engaged. It starts immediately again when the key is turned. Quite fustrating when in traffic where a lower gear is used. Any suggestions?

Submitted: 26/06/2014 11:00:18 | ID: 98484

Answer this question

Gaythree Singh, South Africa

Volkswagen Polo

Hello I'm driving a Polo 1.4 2003... When the heat gauge reaches the half way mark the car keeps switching off... It starts immediately... Is there anyone who had this problem or could advise me to what could be the problem as many mechanics don't know. Thank you

Submitted: 25/06/2014 18:15:46 | ID: 98445

Answer this question

Riaan, South Africa

Volkswagen Polo

Hi to all VDub lovers I bought myself a Polo Classic 2002 1.6i. There was a cone filter fitted which I removed to put the original airbox back on. The car was recently serviced, spark plugs etc. The car was still heavy on fuel so I decided to get it diagnosed. When I did the diagnose at the first mechanic he said there is nothing wrong, only the vacuum pipe needs to be replaced. There was NO change in die fuel consumption. I took the car to a second guy who used the same program to diagnose the car and got the problem. The throttle body was faulty. I replaced the throttle body and did calibration. Then they tuned my valve timing and ignition timing and also the Co2 emissions because it was very high ( not a standard exhaust ) Now they told me the last to check is injector dirt. I somehow can understand that because the car backfires a bit ( a sign of over fuel with fuel injection) Today she gives met 8km on a liter, with almost no foot on the accelerater. Can someone PLEASE give me some ideas for the possible problem? Kind regards. #Yolo.Polo

Submitted: 25/06/2014 10:59:00 | ID: 98418

Answer this question

Noel Wentworth, South Africa

Volkswagen Polo

My VW Polo has just done 200,000km and is still in good condition as I regularly have it serviced. I have on a few occasions experienced the following problem and today it happened again. On start-up the car clicks over and starts, but as soon as I put it into gear I need to press the accelerator to increase revs so that the car doesn't cut out. As soon as I take my foot off the petrol it cuts out and I have to turn the key to re-start. At each stop the same thing happens. I got to the garage (approx. 2 kms away) and the car revved very high when I stopped, but when the mechanic came to check the problem everything was back to normal. Any ideas?

Submitted: 23/06/2014 10:06:03 | ID: 98273

Answer this question

ishmael, South Africa

Volkswagen Polo

Hi I am driving a polo vivo 2011 model. I want to know why sometimes when I am driving to gear 3 and 4 sometimes I struggle to put them in. This started recently b4 I could put them easily like other gears. I have driving the car for 4yrs from brand new. Pls assist me.

Submitted: 22/06/2014 06:20:55 | ID: 98211

Answer this question

cameron, South Africa

Volkswagen Polo

Hi, I have a 1998 model Polo Playa and the problem I'm having is the oil light flashing and beeping. Oil level is fine and it only does this about a minute after I start my car and it doesn't stop until the car is switched off. Can you please tell me what the problem is? Thanks, Camz

Submitted: 17/06/2014 11:28:45 | ID: 97884

Answer this question

irshaad, South Africa

Volkswagen Polo

I have a 2001 Poo Playa millenium edition. There is a black box in the bonnet on top of the battery whic has 3 fuses in it and has some wires in it and a metal strip which connects on to the positive terminal. Please can someone tell me what that fuse box is for and what does that control?

Answers

hoezit bro, that black box controls the current to your starter, the fans inorder for them to function, the alternator... basically if that box is damaged or the wires inside are to be cut your ride won't charge or the above won't work. i had a problem were one of the wires was burnt and the alternator didn't charge, fan did not work, lights dim and not lighting properly so please take good care of that box. it's very very important for the functionning of the car. mine is a polo play 2001 model. nkhumeleni from South Africa

hoezit bro, that black box controls the current to your starter, the fans inorder for them to function, the alternator... basically if that box is damaged or the wires inside are to be cut your ride won't charge or the above won't work. i had a problem were one of the wires was burnt and the alternator didn't charge, fan did not work, lights dim and not lighting properly so please take good care of that box. it's very very important for the functionning of the car. mine is a polo play 2001 model. nkhumeleni from South Africa

Submitted: 17/06/2014 02:42:43 | ID: 97855

Answer this question