VOLKSWAGEN CRAFTER questions and answers

Ask and answer questions on a variety of VOLKSWAGEN CRAFTER models. Help and advice on everything VOLKSWAGEN CRAFTER. Feel free to ask and answer as many VOLKSWAGEN-related questions as you wish.

Ask a question now


Search the questions and answers section:

Below are the latest VOLKSWAGEN CRAFTER questions submitted by visitors to RoadTestReports.co.uk. To supply an answer, simply click on the "Answer this question" link underneath each question. Alternatively, if you want to ask a question, please use this simple form. Please try to make the question as detailed as possible, with all the information necessary for a comprehensive answer included. Please do not use "text speech" or type everything in CAPS LOCK.

steve, Greater Manchester

Volkswagen Crafter

Hi all, I'm having a problem with my internal lights. The overhead cab lights will not turn off, I have now had to remove the bulbs ( map lights are not on but will not turn on). The cargo lights will now only turn on by the switch at the lights, they no longer turn on when I open the doors

Submitted: 07/12/2016 20:43:14 | ID: 137232

Answer this question

Moses, Greater London

Volkswagen Crafter

Blue smoke spewing out at start up. No engine warning light

Submitted: 05/12/2016 16:36:48 | ID: 137186

Answer this question

Robert Samuels, South Yorkshire

Volkswagen Crafter

Hello, I had a problem with a flat battery in my VW Crafter , the AA resolved problem of the battery and found the following fault code System Engine control 1-76k/ Diesel EDC 17CP20 status :P20OAO - Adbule purging valve Error message : open circuit error static 1.45 hours with active mil, how can this fault be resolved

Submitted: 16/11/2016 11:33:02 | ID: 136729

Answer this question

Moses, Greater London

Volkswagen Crafter

My van is a VW crafter cr50 an ex police riot van, 10 seats. Evidence of recent service. 109000 miles on the clock, obviously 1 owner. The problem is immediately you start it, blue smoke begins to flow out, like it's puffing on cannabis!!! I took on the road recently and it was a bad embarrassment! Many cars gave me a gap at my rear! No engine EML showing. Can anyone help? Please? It's just sitting there drinking my monthly road tax and insurance. Cheers

Submitted: 13/11/2016 08:51:36 | ID: 136660

Answer this question

Beppe, Australia

Volkswagen Crafter

How to change gearbox oil on shiftmatic

Submitted: 12/11/2016 01:24:04 | ID: 136628

Answer this question

Mas, Surrey

Volkswagen Crafter

Hi, hope you can help me. About 4 mnth ago eml cane on, problem reading faulty glow plug no 4 and 2, replaced thise. 2 days kater eml back again with glow plug no 1, so decided to replace all of them to stop having problem. Here i have 5 new glow plugs, day later eml back again with same fault as before, same time oil cooler started tonleak oil, replaced seals and it was good for a lottle while, howeven eml light still on. No problems with power of fuel consumption. Oil just started to leak again at the same spot,. I was just wondering where could it get such high preasure, it only leaks for first minute on cold start and then its fine? Thanks

Answers

Sounds like the oil pressure bypass may be partly blocked whilst the oil is still cool and more dense. I have same problem. Reg Moore from Australia

Submitted: 30/10/2016 21:46:36 | ID: 136370

Answer this question

Vicky, South Africa

Volkswagen Crafter

My 2.5 VW crafter BJK engine runs smooth on a level surface road but drops which reaches a hill. I have changed turbos but still does the same. What could be the problem

Submitted: 29/10/2016 20:59:45 | ID: 136345

Answer this question

Gary Collis, Australia

Volkswagen Crafter

We have a water circulation problem after renewing the coolant. Was OK before but now overheats and does not circulate back to the bottle. We have tried topping up down every hose and forced it through under pressure. Cannot find any air lock or any information on the net on filling procedures or anyone having this problem before. About to fit a thermostat. This is a couriers van so needs to be on the road ASAP. Hope someone can shed some light, thanks

Submitted: 27/10/2016 03:10:01 | ID: 136279

Answer this question

Sandy Adams, Aberdeenshire

Volkswagen Crafter

Help please! Back door and side door will not unlock/open.

Answers

Hi pal not sure what year is of ya van mines a 63 plate on dash below radio /heater controls mine has a symbol showing a van pic try press this should lock all van or just back an side doors or try on key hope this helps Lee from Aberdeenshire

Submitted: 19/10/2016 09:38:17 | ID: 136062

Answer this question

Peter Pole, New Zealand

Volkswagen Crafter

Hi, Im wanting to change and repair my Volkswagen Crafter but i want to do it myself can you please help me with that? I dont really sure about the model Type but its 2008 on my van, I can send you an email of a photo of my van if yous email me into regards to weakness. Kind Regards Peter Pole

Answers

What type of transmission and what do you want to know? Reg Moore from Australia

Submitted: 15/09/2016 02:38:44 | ID: 135181

Answer this question

Eddie, Hartlepool

Volkswagen Crafter

Hi guys.looking to fit a fridge to my crafter and I need to connect one of the wires to the alternator run light. Not sure which one it is. There are two wires comminh out of the alternator. B!UE and black and blue and white.could test for voltage after start but finding it difficult to connect test wires. Any ideas please.

Submitted: 02/09/2016 13:49:54 | ID: 134853

Answer this question

Steven Kerans, Greater Manchester

Volkswagen Crafter

Steven Kerans, Greater Manchester Volkswagen Crafter Hi guys. Had my Cafter 2ltr tdi 109ps 2012 for few months now.... had done 140,000 mlies with full history and one courier owner . Ive had the timing belt done recently together with both rear wheel bearings as there was a hum . Drove van away ... van now developed unpleasant vibration through body and up through seat ... had both rear wheels balanced no change.... vibration kicks in around 36mph and increases through 40mph where its most noticeable then fades out around 55 to 60mph... runs lovely there after like it used to... any ideas... ? i know the mechanic had both half shafts out to replace both bearings.... which wasn't an easy job and they used force to make good the new bearings using a copper hammer and a press ... which the copper hammer was used to take it on another 1.5mm ... on one side ... my questioin is this - is it possible to have damaged the half shafts resulting in this weird vibration.... prop shaft has been checked and all UJ's seem fine .... no obvious damage there... what else could it be if unrelated to recent work or am i correct in my assumptions??? Has done 1000 mile trip to France with the auxilary belt deciding to fray and split much to the surprise of myself and my mechanic ... it was replaced in France but this weird vibration remained and has only got worse.... could it be belt related ???? Any response would be much appreciated as i don't know what to do other than take it back to mechanic but they are as baffled as me ... Steve

Submitted: 31/08/2016 18:38:11 | ID: 134796

Answer this question

Steven Kerans, Greater Manchester

Volkswagen Crafter

Hi guys. Had my Cafter 2ltr tdi 2012 for few months now.... had done 140,000 mlies with full history and one courier owner . Ive had the timing belt done recently together with both rear wheel bearings as there was a hum . Drove van away ... van now developed unpleasant vibration through body and up through seat ... had both rear wheels balanced no change.... vibration kicks in around 36mph and increases through 40mph where its most noticeable then fades out around 55 to 60mph... runs lovely there after like it used to... any ideas... ? i know the mechanic had both half shafts out to replace both bearings.... which wasn't an easy job and they used force to make good the new bearings using a copper hammer and a press ... which the copper hammer was used to take it on another 1.5mm ... on one side ... my questioin is this - is it possible to have damaged the half shafts resulting in this weird vibration.... prop shaft has been checked and all UJ's seem fine .... no obvious damage there... what else could it be if unrelated to recent work or am i correct in my assumptions??? Has done 1000 mile trip to France with the auxilary belt deciding to fray and split much to the surprise of myself and my mechanic ... it was replaced in France but this weird vibration remained and has only got worse.... could it be belt related ???? Any response would be much appreciated as i don't know what to do other than take it back to mechanic but they are as baffled as me ... Steve

Answers

Hi, did you find out what the vibration was? I've got the same after changing clutch, suspecting they unbalanced the shaft somehow... Tnx Jack from Bedfordshire

Submitted: 31/08/2016 18:30:06 | ID: 134795

Answer this question

Jacky Watter, Yorkshire

Volkswagen Crafter

Positive connector for battery under the bonnet, do I just connect the jump leads to that and a engine/body earth? Will that charge the battery and jump start it?

Answers

The positive under the red plastic by the air filter connects direct to the battery under the floor. The negative is on the LH inner mudguard. You can jump start or charge battery from these. Reg Moore from Australia

Submitted: 26/08/2016 08:35:55 | ID: 134656

Answer this question

justin hall, Worcestershire

Volkswagen Crafter

I've just had a service on my crafter 2014. The wing mirror indicator went so I replaced the bulb but it still flashes like a disco any ideas on how to reset it.

Submitted: 29/07/2016 08:36:39 | ID: 133934

Answer this question

Ruairi Walsh, Luton

Volkswagen Crafter

I have VW Crafter 07. The van can run perfect for a week, then just won’t start. all ignition lights come Key is read and steering lock releases. But when I turn the final turn to start nothing. Sometimes if I lock and unlock the van it starts But last night it was 3 hours before it started. Some time I hear a click from the fuse area and it starts. Sometimes after starting the wiper and indicator won’t work for a few minutes and then start.

Answers

hi, from reading your post sounds like u may have a relay problem, being in the motor trade I have seen what weird things happen when a relay sticks open/closed when it shouldn't. I suggest getting it a vehicle electrician to check relays/fuse board when the fault is present and hopefully it is a relay cheap fix approx. £15 alex johnson from West Midlands

If you have shiftmatic transmission, a minimum hydraulic pressure of 39 bar is required in the system to operate clutch and gears. When you unlock the driver door and close it, if the pressure isn't up, the pump should start allowing you to select neutral . This will be the relay you hear in the passenger footwell, rhd vehicles. This relay starts the hydraulic magneti marelli pump to build up pressure. These pumps are notoriously unreliable and expensive. You should be able to hear it whirr for a few moments if working. Sometimes a heavy tap may get it working, best bet is to replace it. When it fails, it will not show up on fault codes. If it fails completely, you will be stuck wherever. The pump is located on the lower LHS of gearbox. You can replace it yourself if you have a few mechanical skills and a bottle of the special full synthetic oil used to top up the system via the gearbox breather on the RHS of gbox and the rear 5mm Allen bolt for fluid level at the lower rhs of gbox. There is a lot of literature available on this on the net including things I have mentioned. The gearbox is manual with computer controlled hydraulic shifting and clutch with lots of sensors and can be very reliable or extremely unreliable and a good candidate for a match. The mechanics who work on these in Aus know fa about them and continually guess and fit new stuff at owners expense to "fix". I would never touch another VW but unfortunately spent so much now and got it almost correct by doing my own work, I will persevere a bit further. Reg Moore from Australia

Submitted: 22/07/2016 08:09:12 | ID: 133716

Answer this question

Ruairi Walsh, Luton

Volkswagen Crafter

I have VW Crafter 07. The van can run perfect for a week, then just won’t start. all ignition lights come Key is read and streeing lock releases. But when I turn the final turn to start nothing. Sometimes if I lock and unlock the van it starts But last night it was 3 hours before it started. Some time I hear a click from the fuse area and it starts. Sometimes after starting the wiper and indicator won’t work for a few minutes and then start.

Submitted: 22/07/2016 07:54:46 | ID: 133715

Answer this question

Karen, Dorset

Volkswagen Crafter

Hi. Just bought a 2012 crafter. Fuel light on dashboard is saying high, checked oil level with dipstick which shows okay. Drove it 100 miles light came on. Stopped for 15 mins light went off drove another 50 miles light came back on ,now on permanent . Any ideas ?

Answers

Sorry meant to say oil light on dashboard !! Karen from Dorset

hi, if you have checked the oil level and it is okay then I would start to look at the oil level sensor. this device is normally fitted to the base of the sump or the side and measures the oil level as well as the oil quality. has the van recently been serviced , if not I would suggest an oil and filter change and set the oil level to 1/2 way to 3/4 and then test again. this is the cheapest option first and will not hurt as all engines need a good oil quality. hope this helps alex johnson from West Midlands

Thank you for your advice Alex, the van has been serviced in the last month, I think it is more than likely to be a faulty sensor, as the oil level is okay when I check Regards Karen Karen from Dorset

Submitted: 10/07/2016 22:49:39 | ID: 133422

Answer this question

Paul King, Northamptonshire

Volkswagen Crafter

I have high crank case pressure. It has done 97k miles and runs well. It has just started to lose a little power low down. When you take the oil filler off the top there is high pressure. It has started using oil over the last 3 weeks. Can anyone help?

Answers

My Crafter had 99000 miles and the same problem, none of the 5 garages could offer any better advise than get rid, engine clapped. you can pump your f----g tyres up with that, part chop it. After talking to a parts company they confirmed my thoughts that the breather could be blocked. On top of the engine there it is, you fill the oil through it and the other half is the breather or Oil Separator as it is called. £75, 15 mins to fit it and Bingo No pleasure. I can now take the filler top off when running with no umbrella. Nothing. Hope this helps. Paul King from Northamptonshire

Submitted: 10/07/2016 20:09:49 | ID: 133416

Answer this question

Brian, Australia

Volkswagen Crafter

Hi I have a 2007 80 kW 2.5 tdi had a over fuel problem du to bad fuel replaced hp fuel pump injectors goes ok until you take your foot complety off the throttle too slowdown it will then go to limp mode let it coast out off gear or clutch in for about 30 seconds cums good exhaust sensors test ok but I think this is where the problem could be has anyone had same type of trouble

Submitted: 29/06/2016 12:02:10 | ID: 133090

Answer this question

Tony Beswick , Blackpool

Volkswagen Crafter

Hi guys, I'm trying to jump start my crafter but don't know where to connect the earth lead, can anyone help pls Tony

Answers

Hi Tony got one myself a think on right hand stood in front of van there's a silver bolt on inner wing you could put ya jump leads on this or anywhere on engine fro negative and straight in front of you on engine is a red cap to left of air box push in and turn this will reveal a place to put your positive for battery to jump start hope this helps mines a 63plate cheers lee Lee from Aberdeenshire

Submitted: 16/06/2016 22:17:15 | ID: 132738

Answer this question

Mark, Northumberland

Volkswagen Crafter

Where is the oil pressure switch located on vw crafter van diesel , oil filter is a insert one on the near side towards the back of engine , had 3 mechanics looking for it and none of us can see it any where please help

Submitted: 14/06/2016 21:56:49 | ID: 132678

Answer this question

Jim, Kent

Volkswagen Crafter

Why does my grafter va n use so much engine oil

Submitted: 14/06/2016 02:29:52 | ID: 132635

Answer this question

Andy, Merseyside

Volkswagen Crafter

Hi I have a 2014 Lwb crafter I have just had it serviced and they have reset the service light but the inspection light has stayed on anyone help please

Submitted: 31/05/2016 18:27:45 | ID: 132190

Answer this question

Shane, Australia

Volkswagen Crafter

My 2007 crafter 2.5deisel intermittently cuts out while driving.. All dash lights come on. Any ideas why please?

Submitted: 23/05/2016 23:23:40 | ID: 131929

Answer this question

Kevin, City of Derby

Volkswagen Crafter

Hi had a tow bar fitted to my crafter today but it's put the traction control light on and it's deactivated it what could cause this please

Submitted: 21/05/2016 15:47:47 | ID: 131821

Answer this question

kelly, Essex

Volkswagen Crafter

hello all wonder if anyone can help me, what sort of psi reading should I be able to see on live data for fuel rail pressure an also what high and low pressure set points are (ckba engine I think egr cooler above exhaust not in throttle body) if that helps

Submitted: 19/05/2016 22:38:17 | ID: 131720

Answer this question

ROGER YOUNG, Somerset

Volkswagen Crafter

Hi Do you know why I have water build up in the drivers side door pillar at the bottom by accelerator thanks Roger

Submitted: 18/05/2016 18:22:55 | ID: 131669

Answer this question

Adrian, South Yorkshire

Volkswagen Crafter

F warning, no start, no coms with engine ecu? Then Starting after left with ignition on for a prelim he'd period.

Submitted: 14/05/2016 13:17:52 | ID: 131509

Answer this question

charlie, Hartlepool

Volkswagen Crafter

hi ive just bought a crafter that im going too turn in too day van runs great but ive noticed theres no odometer milage read out just little red blips but its displaying the milage im doing any ideas cheers

Submitted: 10/05/2016 20:46:08 | ID: 131396

Answer this question

Martin goddard, Swindon

Volkswagen Crafter

Battery went flat on my van change battery now Key fob won't work Open my newly found start

Submitted: 06/05/2016 12:36:32 | ID: 131214

Answer this question

john, Durham

Volkswagen Crafter

where is the oil filter situated on the engine? kind regards

Submitted: 01/05/2016 15:31:19 | ID: 131037

Answer this question

Marc, West Yorkshire

Volkswagen Crafter

Does anyone know we're the fuse is for the interior lights in the rear of the van?

Submitted: 28/04/2016 09:28:38 | ID: 130913

Answer this question

Joe, Hampshire

Volkswagen Crafter

My 07 shift matic crafter won't select reverse or 5th and also the driverside courtesy light doesn't switch off. Is there a connection with these faults. No one over here will touch an auto crafter ??

Submitted: 25/04/2016 22:51:52 | ID: 130816

Answer this question

John, Devon

Volkswagen Crafter

Sometimes my glow plug light doesn't come on and this seems to stop the van from starting ... any ideas?

Submitted: 24/04/2016 22:14:17 | ID: 130774

Answer this question

Kevin Clay, Shropshire

Volkswagen Crafter

how do you change the thermostat on a vw crafter

Submitted: 23/04/2016 07:59:53 | ID: 130711

Answer this question

Kevin Clay, Shropshire

Volkswagen Crafter

My 07 Crafter is over heating tryed most things including new water pump but still the same i think the thermostat will be next but can you tell me where it is located and how to change.

Submitted: 23/04/2016 07:57:28 | ID: 130710

Answer this question

Tony, Cumbria

Volkswagen Crafter

Hi I've got a 57 plate crafter, the interior front roof lights with sensors don't work but has power to white plug.rear door llight works, I've checked fuses by bonnet release and under drivers seat ????? I've replaced with another light with sensors on and still no joy

Submitted: 17/04/2016 17:48:44 | ID: 130509

Answer this question

burt, Kent

Volkswagen Crafter

Got water buiding up in drvers side step footwell does anyone have any ideas where it could be coming in from thanks

Answers

I found that water build up in the actual door pillar where it's coming in from is a mystery, so I have drilled a hole to drain the water out . Good luck ROGER YOUNG from Somerset

possibly the door seal.. not necessarily the rubber part, but the bit that clamps onto the bodywork.. remove it and squeeze the two sides together to make a tighter fit.. apply a small bead of silicone to the vehicle before pushing the seal back in place carefully. R Evans from Caerphilly

Submitted: 15/04/2016 18:07:34 | ID: 130424

Answer this question

burt, Kent

Volkswagen Crafter

Got a leak water building up in drvers door step any ideas where coming in from

Submitted: 15/04/2016 18:04:33 | ID: 130423

Answer this question