VOLKSWAGEN CRAFTER questions and answers

Ask and answer questions on a variety of VOLKSWAGEN CRAFTER models. Help and advice on everything VOLKSWAGEN CRAFTER. Feel free to ask and answer as many VOLKSWAGEN-related questions as you wish.

Ask a question now


Search the questions and answers section:

Below are the latest VOLKSWAGEN CRAFTER questions submitted by visitors to RoadTestReports.co.uk. To supply an answer, simply click on the "Answer this question" link underneath each question. Alternatively, if you want to ask a question, please use this simple form. Please try to make the question as detailed as possible, with all the information necessary for a comprehensive answer included. Please do not use "text speech" or type everything in CAPS LOCK.

Peter Pole, New Zealand

Volkswagen Crafter

Hi, Im wanting to change and repair my Volkswagen Crafter but i want to do it myself can you please help me with that? I dont really sure about the model Type but its 2008 on my van, I can send you an email of a photo of my van if yous email me into regards to weakness. Kind Regards Peter Pole

Submitted: 15/09/2016 02:38:44 | ID: 135181

Answer this question

Eddie, Hartlepool

Volkswagen Crafter

Hi guys.looking to fit a fridge to my crafter and I need to connect one of the wires to the alternator run light. Not sure which one it is. There are two wires comminh out of the alternator. B!UE and black and blue and white.could test for voltage after start but finding it difficult to connect test wires. Any ideas please.

Submitted: 02/09/2016 13:49:54 | ID: 134853

Answer this question

Steven Kerans, Greater Manchester

Volkswagen Crafter

Steven Kerans, Greater Manchester Volkswagen Crafter Hi guys. Had my Cafter 2ltr tdi 109ps 2012 for few months now.... had done 140,000 mlies with full history and one courier owner . Ive had the timing belt done recently together with both rear wheel bearings as there was a hum . Drove van away ... van now developed unpleasant vibration through body and up through seat ... had both rear wheels balanced no change.... vibration kicks in around 36mph and increases through 40mph where its most noticeable then fades out around 55 to 60mph... runs lovely there after like it used to... any ideas... ? i know the mechanic had both half shafts out to replace both bearings.... which wasn't an easy job and they used force to make good the new bearings using a copper hammer and a press ... which the copper hammer was used to take it on another 1.5mm ... on one side ... my questioin is this - is it possible to have damaged the half shafts resulting in this weird vibration.... prop shaft has been checked and all UJ's seem fine .... no obvious damage there... what else could it be if unrelated to recent work or am i correct in my assumptions??? Has done 1000 mile trip to France with the auxilary belt deciding to fray and split much to the surprise of myself and my mechanic ... it was replaced in France but this weird vibration remained and has only got worse.... could it be belt related ???? Any response would be much appreciated as i don't know what to do other than take it back to mechanic but they are as baffled as me ... Steve

Submitted: 31/08/2016 18:38:11 | ID: 134796

Answer this question

Steven Kerans, Greater Manchester

Volkswagen Crafter

Hi guys. Had my Cafter 2ltr tdi 2012 for few months now.... had done 140,000 mlies with full history and one courier owner . Ive had the timing belt done recently together with both rear wheel bearings as there was a hum . Drove van away ... van now developed unpleasant vibration through body and up through seat ... had both rear wheels balanced no change.... vibration kicks in around 36mph and increases through 40mph where its most noticeable then fades out around 55 to 60mph... runs lovely there after like it used to... any ideas... ? i know the mechanic had both half shafts out to replace both bearings.... which wasn't an easy job and they used force to make good the new bearings using a copper hammer and a press ... which the copper hammer was used to take it on another 1.5mm ... on one side ... my questioin is this - is it possible to have damaged the half shafts resulting in this weird vibration.... prop shaft has been checked and all UJ's seem fine .... no obvious damage there... what else could it be if unrelated to recent work or am i correct in my assumptions??? Has done 1000 mile trip to France with the auxilary belt deciding to fray and split much to the surprise of myself and my mechanic ... it was replaced in France but this weird vibration remained and has only got worse.... could it be belt related ???? Any response would be much appreciated as i don't know what to do other than take it back to mechanic but they are as baffled as me ... Steve

Submitted: 31/08/2016 18:30:06 | ID: 134795

Answer this question

Jacky Watter, Yorkshire

Volkswagen Crafter

Positive connector for battery under the bonnet, do I just connect the jump leads to that and a engine/body earth? Will that charge the battery and jump start it?

Submitted: 26/08/2016 08:35:55 | ID: 134656

Answer this question

justin hall, Worcestershire

Volkswagen Crafter

I've just had a service on my crafter 2014. The wing mirror indicator went so I replaced the bulb but it still flashes like a disco any ideas on how to reset it.

Submitted: 29/07/2016 08:36:39 | ID: 133934

Answer this question

Ruairi Walsh, Luton

Volkswagen Crafter

I have VW Crafter 07. The van can run perfect for a week, then just won’t start. all ignition lights come Key is read and steering lock releases. But when I turn the final turn to start nothing. Sometimes if I lock and unlock the van it starts But last night it was 3 hours before it started. Some time I hear a click from the fuse area and it starts. Sometimes after starting the wiper and indicator won’t work for a few minutes and then start.

Answers

hi, from reading your post sounds like u may have a relay problem, being in the motor trade I have seen what weird things happen when a relay sticks open/closed when it shouldn't. I suggest getting it a vehicle electrician to check relays/fuse board when the fault is present and hopefully it is a relay cheap fix approx. £15 alex johnson from West Midlands

Submitted: 22/07/2016 08:09:12 | ID: 133716

Answer this question

Ruairi Walsh, Luton

Volkswagen Crafter

I have VW Crafter 07. The van can run perfect for a week, then just won’t start. all ignition lights come Key is read and streeing lock releases. But when I turn the final turn to start nothing. Sometimes if I lock and unlock the van it starts But last night it was 3 hours before it started. Some time I hear a click from the fuse area and it starts. Sometimes after starting the wiper and indicator won’t work for a few minutes and then start.

Submitted: 22/07/2016 07:54:46 | ID: 133715

Answer this question

Karen, Dorset

Volkswagen Crafter

Hi. Just bought a 2012 crafter. Fuel light on dashboard is saying high, checked oil level with dipstick which shows okay. Drove it 100 miles light came on. Stopped for 15 mins light went off drove another 50 miles light came back on ,now on permanent . Any ideas ?

Answers

Sorry meant to say oil light on dashboard !! Karen from Dorset

hi, if you have checked the oil level and it is okay then I would start to look at the oil level sensor. this device is normally fitted to the base of the sump or the side and measures the oil level as well as the oil quality. has the van recently been serviced , if not I would suggest an oil and filter change and set the oil level to 1/2 way to 3/4 and then test again. this is the cheapest option first and will not hurt as all engines need a good oil quality. hope this helps alex johnson from West Midlands

Thank you for your advice Alex, the van has been serviced in the last month, I think it is more than likely to be a faulty sensor, as the oil level is okay when I check Regards Karen Karen from Dorset

Submitted: 10/07/2016 22:49:39 | ID: 133422

Answer this question

Paul King, Northamptonshire

Volkswagen Crafter

I have high crank case pressure. It has done 97k miles and runs well. It has just started to lose a little power low down. When you take the oil filler off the top there is high pressure. It has started using oil over the last 3 weeks. Can anyone help?

Submitted: 10/07/2016 20:09:49 | ID: 133416

Answer this question

Brian, Australia

Volkswagen Crafter

Hi I have a 2007 80 kW 2.5 tdi had a over fuel problem du to bad fuel replaced hp fuel pump injectors goes ok until you take your foot complety off the throttle too slowdown it will then go to limp mode let it coast out off gear or clutch in for about 30 seconds cums good exhaust sensors test ok but I think this is where the problem could be has anyone had same type of trouble

Submitted: 29/06/2016 12:02:10 | ID: 133090

Answer this question

Tony Beswick , Blackpool

Volkswagen Crafter

Hi guys, I'm trying to jump start my crafter but don't know where to connect the earth lead, can anyone help pls Tony

Submitted: 16/06/2016 22:17:15 | ID: 132738

Answer this question

Mark, Northumberland

Volkswagen Crafter

Where is the oil pressure switch located on vw crafter van diesel , oil filter is a insert one on the near side towards the back of engine , had 3 mechanics looking for it and none of us can see it any where please help

Submitted: 14/06/2016 21:56:49 | ID: 132678

Answer this question

Jim, Kent

Volkswagen Crafter

Why does my grafter va n use so much engine oil

Submitted: 14/06/2016 02:29:52 | ID: 132635

Answer this question

Andy, Merseyside

Volkswagen Crafter

Hi I have a 2014 Lwb crafter I have just had it serviced and they have reset the service light but the inspection light has stayed on anyone help please

Submitted: 31/05/2016 18:27:45 | ID: 132190

Answer this question

Shane, Australia

Volkswagen Crafter

My 2007 crafter 2.5deisel intermittently cuts out while driving.. All dash lights come on. Any ideas why please?

Submitted: 23/05/2016 23:23:40 | ID: 131929

Answer this question

Kevin, City of Derby

Volkswagen Crafter

Hi had a tow bar fitted to my crafter today but it's put the traction control light on and it's deactivated it what could cause this please

Submitted: 21/05/2016 15:47:47 | ID: 131821

Answer this question

kelly, Essex

Volkswagen Crafter

hello all wonder if anyone can help me, what sort of psi reading should I be able to see on live data for fuel rail pressure an also what high and low pressure set points are (ckba engine I think egr cooler above exhaust not in throttle body) if that helps

Submitted: 19/05/2016 22:38:17 | ID: 131720

Answer this question

ROGER YOUNG, Somerset

Volkswagen Crafter

Hi Do you know why I have water build up in the drivers side door pillar at the bottom by accelerator thanks Roger

Submitted: 18/05/2016 18:22:55 | ID: 131669

Answer this question

Adrian, South Yorkshire

Volkswagen Crafter

F warning, no start, no coms with engine ecu? Then Starting after left with ignition on for a prelim he'd period.

Submitted: 14/05/2016 13:17:52 | ID: 131509

Answer this question

charlie, Hartlepool

Volkswagen Crafter

hi ive just bought a crafter that im going too turn in too day van runs great but ive noticed theres no odometer milage read out just little red blips but its displaying the milage im doing any ideas cheers

Submitted: 10/05/2016 20:46:08 | ID: 131396

Answer this question

Martin goddard, Swindon

Volkswagen Crafter

Battery went flat on my van change battery now Key fob won't work Open my newly found start

Submitted: 06/05/2016 12:36:32 | ID: 131214

Answer this question

john, Durham

Volkswagen Crafter

where is the oil filter situated on the engine? kind regards

Submitted: 01/05/2016 15:31:19 | ID: 131037

Answer this question

Marc, West Yorkshire

Volkswagen Crafter

Does anyone know we're the fuse is for the interior lights in the rear of the van?

Submitted: 28/04/2016 09:28:38 | ID: 130913

Answer this question

Joe, Hampshire

Volkswagen Crafter

My 07 shift matic crafter won't select reverse or 5th and also the driverside courtesy light doesn't switch off. Is there a connection with these faults. No one over here will touch an auto crafter ??

Submitted: 25/04/2016 22:51:52 | ID: 130816

Answer this question

John, Devon

Volkswagen Crafter

Sometimes my glow plug light doesn't come on and this seems to stop the van from starting ... any ideas?

Submitted: 24/04/2016 22:14:17 | ID: 130774

Answer this question

Kevin Clay, Shropshire

Volkswagen Crafter

how do you change the thermostat on a vw crafter

Submitted: 23/04/2016 07:59:53 | ID: 130711

Answer this question

Kevin Clay, Shropshire

Volkswagen Crafter

My 07 Crafter is over heating tryed most things including new water pump but still the same i think the thermostat will be next but can you tell me where it is located and how to change.

Submitted: 23/04/2016 07:57:28 | ID: 130710

Answer this question

Tony, Cumbria

Volkswagen Crafter

Hi I've got a 57 plate crafter, the interior front roof lights with sensors don't work but has power to white plug.rear door llight works, I've checked fuses by bonnet release and under drivers seat ????? I've replaced with another light with sensors on and still no joy

Submitted: 17/04/2016 17:48:44 | ID: 130509

Answer this question

burt, Kent

Volkswagen Crafter

Got water buiding up in drvers side step footwell does anyone have any ideas where it could be coming in from thanks

Answers

I found that water build up in the actual door pillar where it's coming in from is a mystery, so I have drilled a hole to drain the water out . Good luck ROGER YOUNG from Somerset

possibly the door seal.. not necessarily the rubber part, but the bit that clamps onto the bodywork.. remove it and squeeze the two sides together to make a tighter fit.. apply a small bead of silicone to the vehicle before pushing the seal back in place carefully. R Evans from Caerphilly

Submitted: 15/04/2016 18:07:34 | ID: 130424

Answer this question

burt, Kent

Volkswagen Crafter

Got a leak water building up in drvers door step any ideas where coming in from

Submitted: 15/04/2016 18:04:33 | ID: 130423

Answer this question

Mick Mc Kenna, County Tyrone

Volkswagen Crafter

Does the Electronic steering column lock control unit need reprogrammeing after fitting ?

Submitted: 13/04/2016 18:20:17 | ID: 130348

Answer this question

Gareth Morgan, Cardiff

Volkswagen Crafter

Hi ... After driving my Volkswagen Crafter van 57 plate, for approx. 5 - 10 miles, I experience total of excelaration and have to pull over, let the van cool down, after 5mins start off again and excelaration has returned to normal, Can anyone advise what is wrong ??? Thank You

Submitted: 03/04/2016 15:20:47 | ID: 129890

Answer this question

masia, Hertfordshire

Volkswagen Crafter

Hello, can someone please help!! I have vw crafter 2012, the van starts perfectly when it is cold and runs very well. When the engine warms up and I try to start up, it STARTS but dies immediately. I have to wait 5-10min to start it up again (sometimes it takes 15 times to get it running - starts and dies...). The engine will run all day without problem unless I switch it off. I have taken it to vw but they want to change 'half of the engine' quoted £4500. Many thanks for any help.

Answers

I had the same problem an it was the egr valve what needed to be changed Pedro from Blackpool

Submitted: 28/03/2016 17:19:19 | ID: 129582

Answer this question

rich, City of York

Volkswagen Crafter

started to have quite bad vibration from rear of van, could it be a prop bearing?

Answers

Rich, it possibly could be prop bearing but a worn prop bearing on a crafter will give similar characteristics to that on a Sprinter (same base vehicle).. on the sprinter you get a periodic judder every now and then like as if you're going over the rumble strips on the side of motorway .. the painted lane departure warning. R Evans from Caerphilly

Submitted: 16/03/2016 21:31:39 | ID: 129107

Answer this question

Amar, Australia

Volkswagen Crafter

Hi there, can some one please advise me how to replace alternator on vw crafter diesel 2009 As I can't take 1 bolt out its behind water pump. Tia

Answers

Hi there Just had same problem with mines You need to remove the small idle pulley that's to the left of the water pump pulley It's a torx bolt that holds the wheel on This will allow you to get in with a 13mm spanner to the bolt and remove without hitting pulley on way out John John from North Lanarkshire

Submitted: 21/02/2016 14:48:43 | ID: 127964

Answer this question

Gran Holdsworth , Gloucestershire

Volkswagen Crafter

Fuel light comes on ruff gest how many miles left in tank

Answers

Abt 40 R Evans from Caerphilly

Submitted: 11/02/2016 21:37:42 | ID: 127464

Answer this question

Alan, Highland

Volkswagen Crafter

The comfort/body ecu has packed in on the van but I can't access back to get my tools out is there a way to bypass it thanks

Submitted: 06/02/2016 17:45:15 | ID: 127217

Answer this question

Simon, West Midlands

Volkswagen Crafter

Hi, Could anybody tell me why the Crafters have no back step? We are a Parcel delivery company and we have Drivers who think the height can make a an of issue. Thanks

Answers

I suspect this is one for the designers, mate R Evans from Caerphilly

Submitted: 05/02/2016 16:32:23 | ID: 127178

Answer this question

Kim, Staffordshire

Volkswagen Crafter

Hi all, We have a crafter that has issues with its brakes, as in they were very unresponsive and the van even rolled on a hill when it was fully loaded. After being told it needed new brake discs and pads on the rear wheels and handbrake shoes by 2 separate garages, i put my hand in my pocket and paid out, but i'm still no further forward. The braking is now spongy and the disc brakes are burning hot to the point they are nearly glowing after just a few miles. The fuel consumption is drastically different from how it was before, i'm using nearly twice as much fuel. I'm told it hasn't got a load bearing sensor so it cant be that either. The braking system feels like its sticking on but i'm told its not. Any advice would be much appreciated

Submitted: 04/02/2016 11:42:22 | ID: 127119

Answer this question