VAUXHALL ZAFIRA questions and answers

VAUXHALL Zafira

Ask and answer questions on a variety of VAUXHALL ZAFIRA models. Help and advice on everything VAUXHALL ZAFIRA. Feel free to ask and answer as many VAUXHALL-related questions as you wish.

Ask a question now

Buy used imageBuy new / nearly new imageContract hire image

Search the questions and answers section:

Below are the latest VAUXHALL ZAFIRA questions submitted by visitors to RoadTestReports.co.uk. To supply an answer, simply click on the "Answer this question" link underneath each question. Alternatively, if you want to ask a question, please use this simple form. Please try to make the question as detailed as possible, with all the information necessary for a comprehensive answer included. Please do not use "text speech" or type everything in CAPS LOCK.

Davd, West Dunbartonshire

Vauxhall Zafira

hi there, i drive a 2000 1.8 zafira A and im having a few wiring issues if any one can help. The thing is my fog lights are no longer working so i thought id have a look, as you do. So i turned my dash lights on and checked through my light switches and all worked fine but when i tried switching the fogs off and on my dash lights flickered and dimmed and my engine fan switched on lol, im not even sure how they would be on the same circuit. If anyone could shed some light on this or point me in the right direction to finding the issue id very much appreciate it thanks

Submitted: 01/08/2015 18:16:08 | ID: 119216

Answer this question

Patrick, Devon

Vauxhall Zafira

Hi all, Can anybody shed any light on my problem?i have an 07 Zafira 1.8i 16v Design.i would like to know how to turn the info display(range 330 miles)off?. Many thanks Patrick.

Submitted: 28/07/2015 22:42:31 | ID: 119058

Answer this question

Donna, Wiltshire

Vauxhall Zafira

I have a 57 plate 1.6 petrol life model. The dam engine management light keeps coming on With fuel trim lean! It's been in 3 different garages including a Vauxhall main dealership and still nonethe wiser! Had a O2 sensor & maf sensors changed and still the light keeps coming back on. It's been checked for leaks, cracks you name it and no one can find anything wrong. Any ideas? As a last result they want to change the cat, but it could be a waste of £600+ anyoMe else had problems like this? It drives completely fine, unless it goes into idle mode after the light comes on. Finding annoying and costly to the pocket!

Submitted: 28/07/2015 15:23:07 | ID: 119030

Answer this question

Kevin walsh, Surrey

Vauxhall Zafira

I just brought a vauxhall zafira 1.8 16v comfort petrol 51 plate There was no lights on the dash and the oil was a bit low the people topped it up and the old was quite thick and gloppy I put a engine flush in it after doing about 200 miles because was a little ruff and let it idle with the flush for about half hour when I went to turn it off to change the oil I saw there was 2 lights on the one with the car and spanner and the one with the car and two skid marks on it I've now changed the oil and it took 4 litres to fill but the lights went off when I went to drive they came back on I did disconnect the battery again and tried again same thing happened it's not got it's full power starts to struggle about 4000 rpm dose anyone have any advise at all pls thank you

Submitted: 25/07/2015 17:05:53 | ID: 118893

Answer this question

Jamie, West Midlands

Vauxhall Zafira

I have a Vauxhall Zafira 1.6 petrol, 06 plate and when i turn the radio up loud the spanner and battery lights come on and the speedo cuts out for a few seconds, the crank shaft sensor and radio has been changed and collected it back this afternoon and it happened again? Is it a loose speedo wire, loose wire on a speaker tripping the speedo out or is something vibrating on something to make this happen? please help me.

Submitted: 22/07/2015 21:15:59 | ID: 118782

Answer this question

Sally, Essex

Vauxhall Zafira

em ..bought 2 nd hand 04 petrol 7 seater, for size etc. management light comes on then limp mode, took it to local garage they done coils n plug things, but got light again (oil fine)not back in limp mode but over revving now and could basically drive on it's own no peddle down..don't want to blow it up ? any advise pretty please Sally x

Submitted: 18/07/2015 19:41:58 | ID: 118610

Answer this question

nigel smalling, Somerset

Vauxhall Zafira

i brought a second hand vauxhall zafira 1.6 comfort v reg 7 seats today i drove it back home from devon to yeovil somerset drove fine when i got back i went for drive locally with my partner and noticed that the engine is a little noisy sounds a bit ruff dont know why but sound reminds me of a honda engine when i arrived back from devon my partner said she heard me pull into drive and thought car sounded a bit like a motor bike is this normal apart from this car runs fine just want to know if this is normal thank you for taking time to read this and any advice is much appreciated

Submitted: 18/07/2015 18:23:59 | ID: 118609

Answer this question

kerry, Hampshire

Vauxhall Zafira

how to change the radiator on 2000 elegance is it easy

Submitted: 13/07/2015 07:15:40 | ID: 118395

Answer this question

pat, Falkirk

Vauxhall Zafira

How do you remove electric plug on power steering pump . I have removed 3 torex screws . Tried to seperaye . But wont .

Submitted: 09/07/2015 19:28:27 | ID: 118272

Answer this question

Graham, West Yorkshire

Vauxhall Zafira

Hi All, tonight I plugged in my trailer and it blew the indicator / hazzard fuses 15a Disconnected changed the fuse, but now all my indicators flash in hazard mode when turning either left or right..... Any ideas ??

Answers

Who ever installed the towbar and electrics has done it wrong.thats why it doesnt know what its doing my mate had same problem.mate had mixed up a few wires when installing it. ben smith from North Yorkshire

Submitted: 08/07/2015 23:12:00 | ID: 118232

Answer this question

Jeremy, Bridgend

Vauxhall Zafira

I have a 1.7 Disiel 2013 Zarfira ECOflec when I tow I am getting an intermedate Vibration in the rear that id very loud and sounds like a plastic panel toucj=hing some thing. Has anyone go a solution Thanks

Answers

Hi i have same noises only occur when towing i have gone through everything i can think of then someone mentioned front wheel arch cover i found aceess hole for front lights was not shut properly and when pushed made the exact same noise and as noise carries it sounded in the rear of car Paul from Powys

Hi i have same noises only occur when towing i have gone through everything i can think of then someone mentioned front wheel arch cover i found aceess hole for front lights was not shut properly and when pushed made the exact same noise and as noise carries it sounded in the rear of car Paul from Powys

stop towing with car john from Armagh

stop towing with car john from Armagh

Submitted: 08/07/2015 19:39:50 | ID: 118221

Answer this question

gary, Kent

Vauxhall Zafira

can anyone please help me. im wanting to jump into the rear speakers in the doors so i can run a sub speaker but i dont know what colours the speaker wires...ive been looking on the internet now for nearly 2 weeks and not found anything that could tell me.i have not a clue were to find this out and ive no idea how to get to the wires to link into...could anybody please help. many thanks in advance

Answers

Two options. Either remove a rear speaker and this will in turn reveal the wires to the speaker, or , if you can remove the radio , sometimes there is a wire colour code on the radio itself. This may only refer to the wires coming from the radio but you should be able to follow the wires through the connector to discover the colours in the cars loom. hope this helps. Pete from Kent

Submitted: 07/07/2015 13:31:25 | ID: 118156

Answer this question

Charlie, Hampshire

Vauxhall Zafira

Why does oil leak into all 16 valves compression test perfect airways clear any ideas thank you Charlie

Submitted: 03/07/2015 11:11:19 | ID: 117988

Answer this question

Lol O'farrell, Lancashire

Vauxhall Zafira

Rear near side window inoperable

Answers

Hello. I have a y reg zafira and none of the electrics worked in the rear doors. I found the problem lied with the wires that come from the car body , to the plug that connects to the door. The wires are inside a rubber tube. I unpluged the wires from the door and then carefully cut down the length of the tube to expose the wires. When i opened the tube, i found several wires were broken as if they had been cut. After soldering them together again and insulating them, all the electrics came back to life. . Prob solved. I can imagine that you have the same issue and advise checking these wires. This issue occures because the wires are bent back and forth over a period of time with the door opening and closing, and eventually they snap ! Hope this helps you. Pete from Kent

Hello. I have a y reg zafira and none of the electrics worked in the rear doors. I found the problem lied with the wires that come from the car body , to the plug that connects to the door. The wires are inside a rubber tube. I unpluged the wires from the door and then carefully cut down the length of the tube to expose the wires. When i opened the tube, i found several wires were broken as if they had been cut. After soldering them together again and insulating them, all the electrics came back to life. . Prob solved. I can imagine that you have the same issue and advise checking these wires. This issue occures because the wires are bent back and forth over a period of time with the door opening and closing, and eventually they snap ! Hope this helps you. Pete from Kent

P.s. sorry about double answer entry. . . dont know how that occured ! Pete from Kent

Submitted: 29/06/2015 11:31:23 | ID: 117828

Answer this question

Tim, West Yorkshire

Vauxhall Zafira

Hi, I have an 04, automatic petrol Zafira. For the last few months every now and again the car will simply stall and cut out, or it goes into limp mode. It can happen in mid drive, when slowing down at lights or to turn left etc. when this happens, the car will not restart (although all the dash lights come on and it turns over) so I have to wait for for a few minutes (3-5) and then the car will restart. There is nothing I've noticed to narrow down the fault ie, first thing on a morning, cold weather, long journeys,etc. it's just random and dangerous if it stalls in the wrong place. The light that remains on the dash after is the traction control (triangle, car with skid marks) and sometimes the car with the spanner in it. The lights do eventually go off themselves but only after the car has been left parked up for some considerable time. I've had it in to vauxhall for a diagnostic who said it needed a new ECU (at a cost of £615.) but didn't give me any more details. Another independent garage (with tech 2 computer) said all the codes were correct but couldn't isolate the fault. Simply saying the engine wasn't communicating with the gearbox. One thing that did happen was that whilst it was in the garage and stalled, when the car did start again, the EML was actually flickering on my dash board which seemed to indicate that the fault could be electrical??? Another thing to add is that in February, my local garage changed the head and gasket and when they put it back together there was a problem with it starting properly so the garage had to take it (the head) back off and fix one of the valves that wasn't seated correctly. Don't know if that is relevant but the problem with stalling wasn't there before this happened - maybe it's just coincidence. It seems that no one is sure what the actual problem is - can anyone help or give me some pointers please. Thanks. Tim

Submitted: 28/06/2015 21:52:38 | ID: 117817

Answer this question

peter rush, Dorset

Vauxhall Zafira

My temperature gauge climbs to half way then falls back to zero. Also it is loosing water and needs topping up every 40 miles or so. I can only think this water is somehow getting into the footwell which is sometimes quite sodden. Apart from this the car pulls beautifully and has just been serviced. I just had a new temperature gauge fitted but this new one is behaving like the replaced one, so I don't think the problem lies there. Any help to resolve this curious situation would be hugely welcomed. Thanks, Peter R

Answers

Hello Peter. From what you are discribing, it sounds like you may have a leak in the heater matrix. . maybe a loose pipe connection ? With regards to the temp gauge , it could be a faulty temperature sensor which is located on the side of the radiator. Hope this helps. Pete from Kent

Submitted: 24/06/2015 12:10:07 | ID: 117634

Answer this question

Chris, Hampshire

Vauxhall Zafira

Could you tell me how do you check transmission oil on a 04 zafire automatic

Submitted: 15/06/2015 14:49:29 | ID: 117236

Answer this question

sarah, Essex

Vauxhall Zafira

I have a zafira 1.9tdi 57plate its done 89800 miles its all of a sudden become totally gutless instead of the usual foot down going like a rocket. I've booked it in for a full service oil and air filter change will this make a difference or could there be something else?

Submitted: 14/06/2015 09:40:59 | ID: 117174

Answer this question

colin, Middlesbrough

Vauxhall Zafira

my 2010 zafira elite window off side rear works down on the master switch but not up.. works ok from local position on door..any ideas Col

Submitted: 11/06/2015 21:08:49 | ID: 117097

Answer this question

Peter hardy , South Yorkshire

Vauxhall Zafira

Climate and monitor not working Zafira 1.9 cdti 55reg

Submitted: 09/06/2015 01:13:51 | ID: 116981

Answer this question

andy, Kent

Vauxhall Zafira

Hi all, I have a 06 plate Zafia 1.6 lite. When I push the climate control/snowflake button for cold air I seem to have a significant loss of power and accelaertaion particularly in first.. Any ideas?

Submitted: 05/06/2015 21:42:13 | ID: 116853

Answer this question

Tony, City of Glasgow

Vauxhall Zafira

My engine seemed to be very hot after each journey. I had it checked out and was advised by garage that my radiator was not heating and the cause was a faulty thermostat. However my warning light was not coming on to say that engine was overheating. I had a new thermostat installed, however my engine still feels as if it is getting very hot, although warning light is not illuminated to say overheating. I also noted that the water level in radiator extension tank is slightly losing water after each 20 and over mile journey. Any ideas on solution would be appreciated.

Submitted: 04/06/2015 14:09:28 | ID: 116800

Answer this question

Linda bell, Greater Manchester

Vauxhall Zafira

1.8 zafira design petrol 2012. ...I need to be able to leave tail gate open whilst locking car doors when parked up with dogs in the car. The number plate lights appear to be staying on and thus this will drain my battery. Please advise on how I can do this. Urgent...going to a dog show tomorrow. Grateful for a reply. Today

Submitted: 03/06/2015 12:56:25 | ID: 116757

Answer this question

Emma, Lincolnshire

Vauxhall Zafira

My engine management light keeps coming on, had both lambda sensors changed but still came on. I noticed that my temperature gauge increases when stationery and this is when the light normally comes on. I drove it all the way back from Yorkshire and the temperature gauge never moved, could this be causing the problem?

Answers

Just replace thermostat,comes with temp sender swich.simple job,on my 2004 zaf,for a Muppet me! p j house from Hampshire

Submitted: 31/05/2015 21:43:04 | ID: 116669

Answer this question

sheena, Lincolnshire

Vauxhall Zafira

hi i have just had my rod ends and wishboruns replaced and now have a clanging/knocking sound when driving over uneven roads its really loud and feels like its coming from under front drivers side can any1 help thankyou

Answers

It could be your droplinks. sean from Northamptonshire

Hi. I know this sounds crazy , but i have had the same experience. I checked all the suspension joints etc. and found nothing wrong, so i investigated other areas and found that i had a broken front engine mount. If your suspension/ hubs etc are all ok , might be worth checking other areas as i did. You'd be suprised how a knocking sound can come from somewhere totaly unrelated to what you might think and yet sound and feel like its coming from the wheels ! Hope this helps. Pete from Kent

Submitted: 31/05/2015 13:03:33 | ID: 116652

Answer this question

Peter hardy , South Yorkshire

Vauxhall Zafira

Trying to locate the relay for climate control,No mention in car manuel or Haines

Submitted: 29/05/2015 08:44:14 | ID: 116582

Answer this question

BRYN M JONES, Derbyshire

Vauxhall Zafira

do the brakes on my zafira 1.8 sri (2008) have to be bled under pressure ????

Submitted: 28/05/2015 17:21:18 | ID: 116565

Answer this question

Hugh Morrison, Antrim

Vauxhall Zafira

I get a bang when I go from drive to reverse sometimes as its changeing when driving it is coming from ofside front

Submitted: 23/05/2015 18:13:07 | ID: 116387

Answer this question

kiley, Essex

Vauxhall Zafira

Im having trouble getting my car into gear when its running i can get it into gear when its not running can you help please thankyou

Submitted: 20/05/2015 09:59:29 | ID: 116251

Answer this question

michael hoyle, West Yorkshire

Vauxhall Zafira

hi in the past couple of days when i start my car revs are at 1200 at idle speed, i drive the car for about 10 miles and the car is still idleing at 1200 rpm, it only drops to between 700 and 800 rpm when i put my a/c on, could you please help me in diagnosing the problem, thanks michael

Submitted: 16/05/2015 19:42:34 | ID: 116112

Answer this question

Aaron Williams, West Midlands

Vauxhall Zafira

I have 02 zafira with a couple of issues... car starts but revs to 2000 revs for about 5 second's with the oil light flickering but after that it barely holds tick off and and lights go off apart from the engine management please help

Submitted: 16/05/2015 15:15:45 | ID: 116100

Answer this question

Janet, Kent

Vauxhall Zafira

I have a 2001 petrol (automatic) engine won't start all dashboard lights stayed on when the key is removed . When turning the ignition key it feels like it's not connecting just seems to swivel in the lock any ideas

Submitted: 16/05/2015 06:48:46 | ID: 116086

Answer this question

sarah coe, Berkshire

Vauxhall Zafira

Hi, I have a Vauxhall Zafira comfort 7 seater 1.6 with the engine management light on. I was told there are 2 lambda sensors on it, we changed the front one but how expensive is the back one and could it fail emissions test because of the sensor? thank you

Submitted: 12/05/2015 14:16:11 | ID: 115939

Answer this question

Peter hardy , South Yorkshire

Vauxhall Zafira

Climate control has stopped working and monitor and the radio still works but does not turn off with the ignition?

Submitted: 11/05/2015 02:54:03 | ID: 115864

Answer this question

steve, Yorkshire

Vauxhall Zafira

2008 running too lean, what causes this & how can I solve it..?

Submitted: 09/05/2015 18:17:25 | ID: 115807

Answer this question

Paul, Essex

Vauxhall Zafira

Hello there, I've had a slight whining noise coming from under the bonnet while I sit stationary at the traffic lights and if I turn my steering wheel and hold it in that position the noise will go away. I've had no lights come on the dash indicating any problems. I guessed the noise has something to do with the power steering fluid pump? Anyway, last weekend while driving the power steering went and now it`s like trying to drive an articulated lorry. The AA came out to look at it and he said maybe the power steering fluid is low as the dipstick looked quite low. I bought some fluid and topped it right up but this hasn't made much difference. Do you think it could it be the pump or even the steering rack and are they expensive to replace and have fitted?

Submitted: 06/05/2015 11:14:50 | ID: 115628

Answer this question

Graeme, Essex

Vauxhall Zafira

Hi there, I wonder if you can help? My petrol 1.6 2009 Zafira is jolting under acceleration, the car is regularly serviced and I have done the pedal test which is coming up with no errors. The car has recently had a diagnostic test for a thermostat issue I had and the garage never mentioned about any other problems. Do you have any ideas?

Answers

Coil pack nasser from West Midlands

Submitted: 04/05/2015 22:51:39 | ID: 115579

Answer this question

Mike, Ireland

Vauxhall Zafira

Got a problem with my 06 1.9 diesel Zafira, it was losing power so I took it to main dealer cost me 492 euros to clear dpf sensor. The car was going fine, 3 weeks later it`s taken a lot of water, next thing I know the car is full of steam coming from the engine. I pulled over to check it and bang, all water is gone and the car won`t start anymore. Any suggestions please?

Submitted: 04/05/2015 20:55:38 | ID: 115577

Answer this question

nigel carpenter, Cornwall

Vauxhall Zafira

Hi, my central door locking has packed up today. I need to put fuel in to get home but the flap is locked. Can I override it? Please help

Submitted: 04/05/2015 18:27:35 | ID: 115569

Answer this question

sunday mathew, Ghana

Vauxhall Zafira

Black smoke

Submitted: 22/04/2015 19:03:02 | ID: 115069

Answer this question