VAUXHALL ZAFIRA questions and answers

Ask and answer questions on a variety of VAUXHALL ZAFIRA models. Help and advice on everything VAUXHALL ZAFIRA. Feel free to ask and answer as many VAUXHALL-related questions as you wish.

Ask a question now

Contract hire image

Search the questions and answers section:

Below are the latest VAUXHALL ZAFIRA questions submitted by visitors to RoadTestReports.co.uk. To supply an answer, simply click on the "Answer this question" link underneath each question. Alternatively, if you want to ask a question, please use this simple form. Please try to make the question as detailed as possible, with all the information necessary for a comprehensive answer included. Please do not use "text speech" or type everything in CAPS LOCK.

carla alls, Cumbria

Vauxhall Zafira

I have the car in range but now it's come up with !!!Range!!! What does this mean?

Submitted: 03/02/2016 20:50:24 | ID: 127102

Answer this question

Michelle Tynan, Norfolk

Vauxhall Zafira

Please can you tell me what type of Cambelt does my car have and can you let me know when will have hav eto change it.

Submitted: 31/01/2016 16:04:06 | ID: 126955

Answer this question

lynne manghra, West Yorkshire

Vauxhall Zafira

Hi, I have my engine block light on my dash constantly on, on my 53plate 1.9 petrol zafira. Can you give me an idea what it means please, someone mentioned changing my erg valve but im not sure. My mot is due soon so need this light off for then. Thankyou.

Answers

Lynne, the engine management light can come on due to a number of reasons and yes, a faulty EGR valve could be one.. but to have it properly diagnosed you'll need to have it into a garage with a diagnostic computer or you could be wasting money buying parts that may be fine. What the light means is that the ECU or brain of the car has been sent a signal (or no signal at all) from a component and the 'brain' is not happy.. and believes there is a fault.. and illuminates the engine light to advise the driver.. should get it checked sooner than later or potentially face a nasty surprise ! R Evans from Caerphilly

Submitted: 31/01/2016 15:34:37 | ID: 126954

Answer this question

Sue, Lancashire

Vauxhall Zafira

Hello I m just writing about my Zafira model. I recently had the car mot at my local garage and noticed my handbrake light has been on the time whilst driving and my breaks feel like they have no pressure. New front breaks front and back during the mot. Just wondering if it could a leak some where? Many thanks Robert

Answers

Your brakes will take a few miles to bed in.. during this time you may feel that they are not gripping properly.. but you must drive the car gently and no harsh braking or you may overheat the new disks and glaze the pads.. rendering them pretty useless. the handbrake light is usually activate at the lever.. if they, the garage, loosened the handbrake cable tension they may have disturbed the switch... with regards to a leak.. yes that is possible too and you should NOT drive it if you do suspect a leak.. not until you've had it checked.. or you may face brake failure... and crash.. however, depending on how the garage operate.. it is possible that there may be air in the system and the brakes may need to be bled.... THE LEAK IS MORE CRITICAL !! R Evans from Caerphilly

Submitted: 31/01/2016 13:39:41 | ID: 126948

Answer this question

akbar hussain, Greater London

Vauxhall Zafira

hi there whenever i start the vehicle when engine is cold its shaking and sometime cuts off.and after a minute or so it goes back to a normal status(smoothly running).so my kind request to you to help with this thanks

Submitted: 28/01/2016 19:24:21 | ID: 126830

Answer this question

linda murray, Midlothian

Vauxhall Zafira

My zafira when stationary for a couple of mins(5 tops) has started to make a tapping noise from underneath also the heater though blowing air is not heating up

Submitted: 28/01/2016 12:52:54 | ID: 126814

Answer this question

Paul farrant, Essex

Vauxhall Zafira

Hello my Safire 1.8 53 reg. Is being a pig in the mornings or if not ran for a while. It starts first time. But if I go to drive off it pulls away slowly and seems to be struggling to move. Sometime the idle moves up and down. Once it has warmed up a bit it seems fine although a little under powered. A bit sluggish if you know what I mean. Any ideas please?

Submitted: 27/01/2016 20:01:13 | ID: 126793

Answer this question

Alec, Buckinghamshire

Vauxhall Zafira

Where is the ECU located on my 56 plate 1.6 Zafira

Answers

In the centre of the facia clipped to the heater distribution housing. sean from Northamptonshire

Submitted: 22/01/2016 17:06:54 | ID: 126534

Answer this question

Dave Hulme, England

Vauxhall Zafira

Hi been having problems with the rear brakes on this car Vauxhall zafira 1.6 2002 the problem i had was could hear a scraping noise from drivers side rear brake drum ,ok thought right shoes wearing so had both replaced at local garage , On there inspection yeah shoe where worn so thought problem solved but no I still have the noise plus now get the ABS light coming on as well which after a bit of driving and restarting car will go off but as soon as i brake will come back Now to add more to it the rear drivers side drum was HOT when i got back from a short run to shop talking to my son he thinks the problem lies with the drum and it needs new ones as the old one maybe out of shape warped he said anyone else any ideas driving me mad with ABS light coming on and off Thanks Dave

Submitted: 17/01/2016 14:47:32 | ID: 126296

Answer this question

Simon Maxwell, Greater Manchester

Vauxhall Zafira

The heater takes a long time to get warm, can it be adjusted to heat up quicker ?

Answers

if your thermostat is sticking closed then it could be the cause, but you'd prob notice the engine temp getting higher than it should if this was so.. otherwise it is probably how it should be. R Evans from Caerphilly

Submitted: 16/01/2016 16:53:30 | ID: 126261

Answer this question

alan payne , East Sussex

Vauxhall Zafira

when I turn the ignition on when cold in morning there is a clicking noise from under the dash in area of drivers side and stops after about 20 seconds and is fine for the rest of the day, this only happens when car is cold , any idears

Submitted: 15/01/2016 11:06:39 | ID: 126164

Answer this question

Sonia, Kent

Vauxhall Zafira

NEED A LITTLE HELP IF POSSIBLE PLEASE. MY DAD HAS A 52 PLATE ZAFIRA AUTO. HE WAS ABOUT TO GO OUT TO BUY A NEW BATTERY AS THE CAR ISNT STARTING UNLESS ITS JUMP STARTED WHICH EVEN THEN, ITS STRUGGLING TO START. HE HAD A LEAK FROM THE RADIATOR A WHILE AGO WHICH WAS CAUSING QUICK LOSS OF WATER. HOWEVER, I BROUGHT SOME BARS LEAK AS A TEMPERARY FIXTURE TILL HE COULD AFFORD GETTING THE RADIATOR FIXED OR REPLACED. THE BARS LEAK DID WORK AND THERE HAS BEEN NO LEAK SINCE. YESTERDAY WHILE OUT HIS CAR BROKE DOWN AND HE NOTICED THE WATER WAS COMPLETELY GONE. HE ONLY DRIVES VERY SHORT DISTANCES AND THERE WAS WATER IN IT BEFORE HE DROVE IT YESTERDAY. COULD THE SHORT DISTANCE HE DROVE YESTERDAY HAVE CAUSED A MORE SERIOUS PROBLEM LIKE HEAD GASKET FOR THE PROBLEM HE HAS? DOESNT MAKE SENCE WHY ITS NOT STARTING AT ALL. TURNING OVER JUST NOT STARTING. JUST AFTER SOME ADVICE BEFORE HE SPENDS MONEY ON A NEW BATTERY IF THATS NOT THE PROBLEM. THANKS SONIA

Submitted: 13/01/2016 18:43:46 | ID: 126065

Answer this question

Andrew, Carmarthenshire

Vauxhall Zafira

The light in my boot comes on when I'm driving and the warning tone is say that there is a door open any ideas what it could be thanks

Submitted: 11/01/2016 12:07:45 | ID: 125905

Answer this question

stephen, Kent

Vauxhall Zafira

i have a W plate Zafira Elegance. Automatic It has been running well.. untill today it has stopped accelerating. Think it is Limp mode. as im driving the Egine Managment light come on.. lets me still drive.. but after bout 20 mins it starts slowing down and shudders alot. then unlike today.. it just shut off. Tried restarting it.. and wud start but no acceleration. Took me 15 mins to let it cool down then it let me drive it for 2 miles to back home. Any Ideas Please?? Have been advised by a neighbour it cud be the clutch springs. Possilbly also the clutch/gearbox.

Answers

Stepehn, the clutch springs would not cause EML to light. but could give drive problems.. with EML lit you'll need to get it hooked up to a diagnostic computer. R Evans from Caerphilly

Will do.. thanks mate. Fingers crossed it summit small rather than large costing steve from Kent

Will do.. thanks mate. Fingers crossed it summit small rather than large costing steve from Kent

Hi there, sounds like the same thing that has happened with my 1.4 Ford Fiesta. I know it is a completely different car but exact same problem. Just before Xmas I sent my ECU for a diagnostics test which came back that apparently there was a circuit corruption. So sent it off once again for repair and £310 later still doesn't work. AA were called out today and after having it put on the computer it is showing ECU error. It all works fine when the car is on for 15 minutes but when started from cold it's just in limp mode and only giving 2 revs. Definitely have the ECU checked and don't let anyone BS you to con money out of you! If that's all fine maybe have throttle housing checked. Sonia from Kent

Hi there, sounds like the same thing that has happened with my 1.4 Ford Fiesta. I know it is a completely different car but exact same problem. Just before Xmas I sent my ECU for a diagnostics test which came back that apparently there was a circuit corruption. So sent it off once again for repair and £310 later still doesn't work. AA were called out today and after having it put on the computer it is showing ECU error. It all works fine when the car is on for 15 minutes but when started from cold it's just in limp mode and only giving 2 revs. Definitely have the ECU checked and don't let anyone BS you to con money out of you! If that's all fine maybe have throttle housing checked. Sonia from Kent

Submitted: 07/01/2016 12:04:29 | ID: 125691

Answer this question

Peter, Aberdeenshire

Vauxhall Zafira

I have been told that my vauxhall zafira has a burst exhaust flexi pipe (front). My car is just over 3 years old. Is this common and how much should it cost to replace?

Answers

Peter, have a look on fleabay for pipe price guide.. but that is 'fit-it-yourself' price. A garage will be more expensive, but they fit it too). Frontpipes include a flexi connection to compensate for the movement and vibrations of the engine when driving.. they can take a bit of a bashing and are under constant movement, but there is a wire meshing around them to stiffen the flexi pipe.. but.. they go!!.. Three years does seem a little bit soon to go, but these days, car parts are not built to last... and exhaust parts are consumable. Take it to an exhaust centre.. cost you around a ton, fitted. R Evans from Caerphilly

Submitted: 06/01/2016 20:55:44 | ID: 125662

Answer this question

Anthony, Blaenau Gwent

Vauxhall Zafira

My 1999 -2000 zarfira 1.8 petrol is spluttering n seems like it trying to clear when I brought the car was told it needs a ne oxygen sensors could this be the problem thanks in advance

Answers

Anthony, might be the problem.. the oxygen sensors (or lambda sensors) send messages to the car's computer about the percentage of oxygen in the exhaust fumes.. if they are not working, then the 'brain' doesn't know accurately how much oxygen is there.. it uses a wide range of sensor inputs to calculate and compensate fuel delivery to make the best fuel-air mixture.. if it's not getting all the sensor inputs.. it can't make a correct judgement and your car may be suffering overfuelling or fuel starvation. Long term it could cause other problems so if you know it needs new O2 sensors, get them done and run it for a while.. see how it goes. On fleabay, they're in the region of £25.. but then you have to get them fitted and they can be a t**t to remove sometimes. R Evans from Caerphilly

Submitted: 06/01/2016 20:42:56 | ID: 125660

Answer this question

Nick Nikolov, Greater London

Vauxhall Zafira

Hi , I would like to ask your . How the Zafira B Heater Motor Resistor affect the heater element of the Lambda Sensor? Kind regards, Nick

Answers

Nick, it doesn't affect it.. the heater motor resistor allows the regulation of heater blower speeds.. for passenger heating comfort.. the lambda sensor is fitted into the exhaust system and monitors the percentage of oxygen in the exhaust and uses that reading to work out whether the vehicle is burning fuel efficiently R Evans from Caerphilly

Submitted: 05/01/2016 09:41:12 | ID: 125579

Answer this question

abid mirza, Greater London

Vauxhall Zafira

I was driving home after shopping when I put the brakes to park, the car stalled and engine cut out. I tried to start it again but it didn't start so i pushed the car by the curb and noticed the oil leaking leaving the oil tank completely empty.The car had been serviced only 3 months ago. Can anyone please help me and tell what the problem might be? thanks

Submitted: 01/01/2016 23:45:24 | ID: 125405

Answer this question

alex, Dublin

Vauxhall Zafira

hi,my 04 zafira had problem with first gear go slow about 20 to 30 secs before it start to run. Thank you.

Submitted: 26/12/2015 16:15:03 | ID: 125163

Answer this question

Wemimo Ogundiwin, City of Glasgow

Vauxhall Zafira

I have a 2013 Vauxhall zafira tourer turbo 1.6 petrol. I picked it up from the dealer Feb this year, I am the second owner, 3 days after picking the car up I noticed that when I start the car up its gives a clunking noise, as if two metals knocking against each other, I never bothered about it but I have always mentioned this noise to the man at the sales department and he said to me it's not a problem. Few weeks after then I took the car to a car wash and just as I was about to leave I started the car and same noise again, the guy at the car wash said to me have I noticed the noise my car gave and he advised I take it back to the dealer being a new car why the noise. The noise seems to be coming from under the bonnet. I have taken it to Arnold Clark for diagonistics but nothing was detected. The sound only come on every time I start the engine up and at times randomly. Do anyone have any idea what this could be, the sound is really loud.

Submitted: 19/12/2015 10:09:06 | ID: 124872

Answer this question

Gail Westney, South Yorkshire

Vauxhall Zafira

My sri Vauxhall zafira 2006 is making a loud humming noise and I smell burning. The car then ticks loudly when ignition is turned off. There is no loss of power or any warning lights on. What is this please.

Answers

If it's a diesel it probably needs a "regen". I knew nothing about this when I bought mine and it cost me over £100 to get it sorted when it went in to limp mode. I now carry a length of wood and use it to press the accelerator pedal down if I don't fancy driving 20 miles to clear it. john puddephatt from Devon

Submitted: 07/12/2015 18:41:00 | ID: 124445

Answer this question

Naomi, Northamptonshire

Vauxhall Zafira

My radio and temprature light on the dash board is completely black and. Not lighting up. The radio works does anybody know what could be wrong

Submitted: 02/12/2015 22:41:18 | ID: 124297

Answer this question

mick Hutchcox, West Midlands

Vauxhall Zafira

any ideas as to why when i turn anything electrical on in my car all the indicator lights come on they dont flash they come on and stay static.when i turn on the ignition they go off.stop the engine they come back on again Any ideas please

Submitted: 30/11/2015 21:43:51 | ID: 124224

Answer this question

tony brown, Galway

Vauxhall Zafira

What is the winding down whine audible for about 5 seconds when I switch off my 1.6l petrol engine? it sounds as though it's in the engine compartment but I could be wrong. It's like an electric motor winding down perhaps a fan or pump. TIA.

Submitted: 27/11/2015 22:50:40 | ID: 124096

Answer this question

Kam, Berkshire

Vauxhall Zafira

Hello, I have 1.8 petrol zafira A .. does it come with cam belt or chain. thanks, Kam

Answers

Hello. I am not a mechanic but recently changed my engine and it was a 02 reg. That was a cam belt. 3 small bolts in top 1/2 of casing - take them out and you can take plastic off and see. Other than that easiest way is normally ring a parts supplier for a quote on new kit and quote registration. They will confirm either. Vivian Howell Williams from Torfaen

Submitted: 27/11/2015 14:09:33 | ID: 124074

Answer this question

Colin, Tyne and Wear

Vauxhall Zafira

Zafira B engine management light came on, on my way down the country and carried on driving it only to find the MPG was significantly better. Back at base checked the system with an Autel code reader to show P0171 error code "System Too Lean Bank 1", which I presume is the 1st oxy sensor! I usually get around 400 miles from the tank and now I am heading to close on 500!!! Is the software in need of a remap or was I always running too rich? Is this another software glitch like the VW? No degrading of performance and light still on, if I get 25% better consumption, the light stays on!!.

Submitted: 24/11/2015 12:58:49 | ID: 123931

Answer this question

Jo, West Yorkshire

Vauxhall Zafira

The handbrake light keeps coming on and beeping when I turn the steering wheel to the left at junctions

Submitted: 20/11/2015 20:49:37 | ID: 123744

Answer this question

Stephen jacobs, Merseyside

Vauxhall Zafira

I have a new Vauxhall zafria toura 15 plate and the engine shakes when idle it is a load of rubbish!

Submitted: 17/11/2015 17:32:33 | ID: 123630

Answer this question

Clare, Surrey

Vauxhall Zafira

Is my car a. B type and due for a recall inspection?

Submitted: 11/11/2015 00:32:04 | ID: 123386

Answer this question

roger, Kent

Vauxhall Zafira

vauxhall zafira MK1 2004 ignition barrel broke the other night key just rolls in barrel RAC had to hot wire so i could get home RAC told me once home disconnect battery so all done ,I need a new one Barrel VAUXHALL got parts all done RAC told me how to start it ie hot wire BUT now warning light is now flashing engine turns but won't start IMMOBILIZER ON how can I get it started to get to garage?

Submitted: 07/11/2015 16:03:05 | ID: 123253

Answer this question

mark, Lincolnshire

Vauxhall Zafira

Why does my handbrake light come on when I corner left I have a 1.6 energy 2004 any tips

Answers

It could be that your brake fluid level is low. sean from Northamptonshire

Submitted: 01/11/2015 01:39:10 | ID: 122963

Answer this question

Bruce, City of Glasgow

Vauxhall Zafira

Hi all can anyone help I have a Vauxhall zafira club mk1 1.8 16v I can't seem to locate the agr valve it's not at the side of the rocker cover were most are located their is nothing their at all just the throttle body at the top of rocker cover . many thanks Bruce .

Submitted: 29/10/2015 10:03:53 | ID: 122845

Answer this question

Darna Williams , Lancashire

Vauxhall Zafira

My engine recently blew it's difficult to get hold of a reconditioned z16xe1 will a z16xep be OK to be fitted in my o8 plate

Submitted: 28/10/2015 18:57:38 | ID: 122829

Answer this question

Christopher Sale, Lancashire

Vauxhall Zafira

Hi I have had the car now for about a year and never any probs with starting car, idles, okay and does not cut out, but twice now this year filled up night before with petrol, turned card round on drive just on a bit of a slope so could fill boot with suitcases,left over night come to start car in morning when ready to go and battery completely flat! just happened again t/day? and when jump starts car no probs whatsoever starts up first time, last time it happened was 6 month ago, I though I might have left radio on or something but brother say's they turn off automatic on zafira's after half hour anyway! so that is not the prob,, I have the had compartment in the front of the car pretty full but the compartment shuts fine, was wondering if light could stay on that or something or could it be I'm not checking if the boots been shut proper! but now that it has happened again I am getting paranoid as I am at a complete loss as to what it can be, just had jump start again t/day started up first time again and no probs? and running fine again! Any Suggestions please. Tinks

Submitted: 24/10/2015 18:04:01 | ID: 122679

Answer this question

holly, South Yorkshire

Vauxhall Zafira

I've recently bought my zaifra comfort and a few times when I put it into first gear it goes into reverse! Why does it do thus as u supposed to lift the gear stick and put it into reverse so y does it slip in on its own it's so dangerous setting off finking u goin forward but end up backward .

Submitted: 24/10/2015 16:18:22 | ID: 122676

Answer this question

calderwood, Antrim

Vauxhall Zafira

Should my Zaire life 1.8 5 door be checked because of the possible fire hazard

Answers

yes if its a b model and has manual air con go on vauxhall page they have pictures to compere 05 to 15 transit tone from West Midlands

Submitted: 24/10/2015 09:59:00 | ID: 122655

Answer this question

Adam baker, Hampshire

Vauxhall Zafira

I'm wondering if anyone can help my wife has just called me saying that her zafira is making an air noise on the front passenger side bottom of the engine, it's had a new exhaust system and turbo hoses recently and now this. Any ideas would be gratefully appreciated

Submitted: 23/10/2015 19:27:02 | ID: 122642

Answer this question

calderwood, Antrim

Vauxhall Zafira

Should this model be inspected for the fire problem

Submitted: 23/10/2015 16:51:02 | ID: 122638

Answer this question

raych Smyth, Cambridgeshire

Vauxhall Zafira

I have a 2007 Vauxhall Zafira (life) 1.6 - engine maintenance light been on for forever has been into many garages at least 6 locally and all keep putting car on diagnostics - charging for this -resetting the fault codes - that just come back on again. The fault codes are coming in as fuel trim lean, heat sensor fault and also fault unknown. Often a rancid smell in car - new clutch 7 months ago. Sometimes smell a burning smell... the revs per minute are jumping and quite extreme even when car in neutral and foot not on gas.... any advice anyone?? I took to the local dealer who suggested there was carbon build up in the ports and valves leading to the manifold( thought this would be the case on diesel _ not petrol) ... having just watched watch dog tonight and carting around 5 young children... I was wondering if this was something I should be worried about or not... surely if there was a genuine problem with Vauxhall zaphiras - bursting into flames -they would recall them all???

Answers

hi there, i have same problem with my vauxhall zafira life 1.6 2009 which i just bought it today and while driving back to my home the engine management light came on, but on the way to my home i had to stop for refueling and then house shopping and noticed soon after i start the car engine management light turns off it self like it turns off as if there is nothing wrong and after five seconds it comes back on & stays on. but car drives fine but some time idle go's up & down!! what i believe is, i think i should check vaccume system (vaccume pipes) and clean them properly also get the EGR valve cleaned as well then try dissconnecting the battery terminal (red one with + sign or both) for 30 minutes or more then reconnect it with battery (by doing this it will re set the whole system it self) then try starting the engine and see if light comes back on or not, if it dose then try diagnose the problem and see what code comes on, useually in petrol engines its either plug wires or plugs or coil pack or all three at same time but (in all 3 conditions car should missfire), if the idle go's up n down then make sure check the EGR valve and air vaccume system and may be any sensors. shouldn't be any thing else( worst case senario if it missfire badly then it could be any of the cilynder head valves) hope it may help you rishi from Middlesex

hi there, i have same problem with my vauxhall zafira life 1.6 2009 which i just bought it today and while driving back to my home the engine management light came on, but on the way to my home i had to stop for refueling and then house shopping and noticed soon after i start the car engine management light turns off it self like it turns off as if there is nothing wrong and after five seconds it comes back on & stays on. but car drives fine but some time idle go's up & down!! what i believe is, i think i should check vaccume system (vaccume pipes) and clean them properly also get the EGR valve cleaned as well then try dissconnecting the battery terminal (red one with + sign or both) for 30 minutes or more then reconnect it with battery (by doing this it will re set the whole system it self) then try starting the engine and see if light comes back on or not, if it dose then try diagnose the problem and see what code comes on, useually in petrol engines its either plug wires or plugs or coil pack or all three at same time but (in all 3 conditions car should missfire), if the idle go's up n down then make sure check the EGR valve and air vaccume system and may be any sensors. shouldn't be any thing else( worst case senario if it missfire badly then it could be any of the cilynder head valves) hope it may help you rishi from Middlesex

Submitted: 22/10/2015 22:22:08 | ID: 122611

Answer this question

adrian beck, West Yorkshire

Vauxhall Zafira

no noise from front parking sensors or indicators rear sensors ok

Submitted: 19/10/2015 14:25:16 | ID: 122479

Answer this question