NISSAN PRIMERA questions and answers

Ask and answer questions on a variety of NISSAN PRIMERA models. Help and advice on everything NISSAN PRIMERA. Feel free to ask and answer as many NISSAN-related questions as you wish.

Ask a question now


Search the questions and answers section:

Below are the latest NISSAN PRIMERA questions submitted by visitors to RoadTestReports.co.uk. To supply an answer, simply click on the "Answer this question" link underneath each question. Alternatively, if you want to ask a question, please use this simple form. Please try to make the question as detailed as possible, with all the information necessary for a comprehensive answer included. Please do not use "text speech" or type everything in CAPS LOCK.

Martin mweeka , Zambia

Nissan Primera

I have a Nissan premera sr20de engine cannot accelerate after 10minutes from starting it. What is the problem

Submitted: 04/12/2016 20:29:30 | ID: 137166

Answer this question

Tomas, Latvia

Nissan Primera

Are there someone answers the questions?

Submitted: 22/11/2016 12:39:42 | ID: 136868

Answer this question

strutty, East Riding of Yorkshire

Nissan Primera

can i change heater/radio panel without lossing my radio code

Submitted: 12/11/2016 14:17:40 | ID: 136638

Answer this question

jean mwando, City Of Leicester

Nissan Primera

Dear sir ive got my nissan primera diesel 2004 the ABS light is on also the speed clock is not working

Submitted: 15/10/2016 21:31:52 | ID: 135982

Answer this question

Maria Prince, Buckinghamshire

Nissan Primera

I have a problem with my Nissan Primera 2004. The car shakes a lot sometimes, especially when I drive slow and the same time the engine light is on. When it happened last year the mechanic changed the spark plugs and that was OK for sometime. But again after six months the engine light reappeared. Now when the car shakes the engine light blinks but it never goes. Do you have any idea what the cause is?

Answers

could you send answer to me, I have same issues Edet Asuquo from Nigeria

Submitted: 15/10/2016 13:28:35 | ID: 135965

Answer this question

togi, New Zealand

Nissan Primera

When I parked for about 5hrs and the front wheels are turned fully on either side then it seems lock up when you start drive and by increased your accelerator then you can hear a bang under the car or it looks like something is release or open. Then I drive for about 15minutes then go back home and parked and turned everything off then I can hear some noise like burning comes from the wheels. Would you please help me and what to do. Thanks

Submitted: 11/10/2016 08:02:34 | ID: 135858

Answer this question

bob, Cumbria

Nissan Primera

how do I replace crankshaft sensor

Submitted: 19/09/2016 12:31:11 | ID: 135282

Answer this question

Daphne Howard, New Zealand

Nissan Primera

I have a 2007 Nissan Primera SX Hatchback p12 UK model. Can you please tell me what other models have the same left rear tail light cluster part?

Submitted: 06/09/2016 07:51:24 | ID: 134955

Answer this question

IDAMKWE, Berkshire

Nissan Primera

I noticed when I drive my car it will just stop and and will give hard start then will later drive for a while and stop again. But the drive is smooth it doesn't Jean nor misfire. Please I really need help.

Submitted: 28/08/2016 14:26:50 | ID: 134720

Answer this question

micheal, Torfaen

Nissan Primera

hi i am wondering if i can connect my phone to my nissan primera sx via bluetooth and if so can someone please help me to connect it manny thanks micheal

Submitted: 24/08/2016 18:06:39 | ID: 134619

Answer this question

Asaah Eric Tamunang, Cameroon

Nissan Primera

Dear Sir, I own a Nissan primera 1.9 dci , 2004 model hatch back. After changing the clutch master slave cylinder in the gear box , the yellow engine sign appeared then suddenly the computer board ceased to work showing me a message " SECURE" . Please advise for corrections. I have taken out the battery and reconnect but no change.

Submitted: 19/08/2016 06:00:26 | ID: 134468

Answer this question

George, Laois

Nissan Primera

how do i remove window motor off

Submitted: 15/08/2016 17:02:45 | ID: 134375

Answer this question

Rashi, Barbados

Nissan Primera

A new timing chain tensioner was recently put in but when the car was started there was a knocking sound and then it shut down completely and hasn't restarted since. I have been told that the engine has seized up! What could/would have caused this?

Submitted: 06/08/2016 13:12:59 | ID: 134142

Answer this question

Peter, New Zealand

Nissan Primera

My Nissan Primera P11 has developed a fault in the transmission. Starts off and wont change gear (Limp Mode?) Stop and turn off ignition, restart and operates as normal. Next start, same fault. Any help please.

Submitted: 05/08/2016 06:15:59 | ID: 134122

Answer this question

Cheyne, New Zealand

Nissan Primera

Hi there my nissan primera station wagon 2003 makes a rattling noise when cold and put in gear (auto) in neutral or park it's fine no rattling but in gear it rattles only for a minute or so the car has Done160,000 kms been regularly serviced I have just purchased any ideas I'd be very greatful.

Submitted: 01/08/2016 08:06:46 | ID: 134017

Answer this question

Brian, Greater London

Nissan Primera

Hi I bought this Nissan primer 2002 automatic from a dealer 1 month ago we test drive it for about half and hour every thing seemed okay until it was bin delivered to me on the m 25 at at a longer time the abs light came on I ask the dealer y this came on he said it must be a sensor next day it was off day they took it back check it and said everything is OK yesterday we went to Hastings it came on again and when coming back it came on again can someone please tell what to do please

Submitted: 29/07/2016 17:44:26 | ID: 133945

Answer this question

Gibson Hore, Papua New Guinea

Nissan Primera

My car is a SR20 engine ,in which the gear D drive doesn't come on '' on dashboard and when driving gears don't shift automatically as they should but goes high when you accelerate .What could be the problem.

Submitted: 18/07/2016 01:36:14 | ID: 133605

Answer this question

michael kumi, Ghana

Nissan Primera

My Nissan primera 2003 model has a slow start wen I try to spark it and also slow acceleration when I try to speed. What might be de problem and possible solution

Submitted: 17/07/2016 23:18:48 | ID: 133603

Answer this question

Samuel Beattie, North Lanarkshire

Nissan Primera

What amount of oil & type goes into the Gearbox as I have replaced the Clutch Assembly also instructions on how to Drain and Fill the Gearbox Primera P11

Submitted: 11/07/2016 13:36:58 | ID: 133429

Answer this question

Paul, Nigeria

Nissan Primera

My car consumes a lot of fuel. In fact, used 110 liters of fuel for a 400km distance last week. I gave the car to my mechanic and he damaged so many things and replaced them with odd ones. 1. The sensor accelerator that came with the car was damaged and he replaced it with cable. 2. He is also changed the vehicle brainbox and replaced it with a model of BrainBox that has free code when he lost the key to the car. Most time, when I start the car in the morning, black smoke usually comes out from the exhaust. Please kindly assist me with useful information as I am fed with the vehicle's excessive consumption of fuel. Thanks.

Submitted: 04/07/2016 06:25:03 | ID: 133228

Answer this question

UCHE NNAMDI, Nigeria

Nissan Primera

I am about to get this model of vehicle in the next 4 months because of the Navigation facilities I want to know: 1. The best transmission fluid for it and the cost ,since it is a CVT, and not the regula AT 2. If the Navigation equipment can have it programmed for Nigeria 3. If the parts are readily available in Nigeria, and Warri in Particular where I live 4. The durability of the car compared to its contemporaries like Audi , Golf ,Passat, Carina e, Avensis wagons. 5. The range of price for a very clean used one with leather seat I will appreciate a detailed response as soon as possible. Regards, Uche Nnamdi

Submitted: 30/06/2016 22:18:51 | ID: 133155

Answer this question

keyvan kolahi, Denmark

Nissan Primera

Hi there I want to replace my car standard seat to leather power seat and I have problem with different type connector between 2002 power seat and 2006 standard seat .In standard seat I have 3 wire blue,brown and satelite sensor black wire,and in power seat I have 2 wire (yellow/ red and yellow green). the brown and blue wire in standard seat are connected from airbag control unit to the airbag side cortain moudle but in power seat have different harness. Is anybody knows how can I replace the power seat? by the way I have nissan primera p12 electronic manual program but I couldn't found anywhere figur of my car airbag wiring. Thanks keyvan,copenhagen Denmark

Submitted: 19/06/2016 20:18:00 | ID: 132807

Answer this question

Eludu David , Nigeria

Nissan Primera

Good Morning Sir/Madam, I am David by name and a Nigerian. I bought a Nissan primera 1999 model hatchback, only to discover that the automatic gear box does not change when I accelerate the car thereby stressing the engine the more. My question now, is that what can I do to resolve the issue. Some persons are advising me to work the gear box while others are telling me to replace the gear box with a new one. Please advise. Thank you.

Submitted: 19/06/2016 00:30:18 | ID: 132782

Answer this question

Geoff hughes, Lancashire

Nissan Primera

Just bought new sat nag upgrade disc everything comes on but the map do I need to do anything

Submitted: 15/06/2016 19:36:33 | ID: 132704

Answer this question

Reginald Ward, Surrey

Nissan Primera

Windows except drivers,stopped operating.fuses appear OK

Submitted: 04/06/2016 23:27:35 | ID: 132364

Answer this question

Keith James, Rhondda Cynon Taf

Nissan Primera

Changed the cat converter, when it is in neutral plenty of power, when you put it in 1st gear to pull away hardly any power and almost stalls, will not climb any hills, just loses power, flummoxed

Submitted: 03/06/2016 18:56:30 | ID: 132337

Answer this question

Aaron, Cheshire

Nissan Primera

Hi, my car keep displaying "SECURE" and stops my satnav and music. Any advice please. Thanks .

Answers

This often happens when the battery in the fob is low and needs changing. if you have a setup that allows you to drive the car with keys in your pocket, sometimes you need to use the key in the ignition... try using the key in the ignition and see if it works.. if it does then it's prob battery in the fob.. it happens on my x-trail R Evans from Caerphilly

Submitted: 02/06/2016 15:10:11 | ID: 132287

Answer this question

Koki Jones, Swaziland

Nissan Primera

The panel screen goes blank and no audio, all indications eg temperature, aircon controls, radio etc do not show. After many days of driving everything comes back. But now it's been fully blank for almost 4 weeks; blank not even music via flash disk plays. Audio fuse is intact. Any help please?

Submitted: 29/05/2016 21:06:32 | ID: 132150

Answer this question

Sowah Gideon, Ghana

Nissan Primera

There is a noise under the boot whenever i apply rough road.

Submitted: 26/05/2016 09:30:18 | ID: 132048

Answer this question

energy, Kent

Nissan Primera

1. my car is making a vibrating, rattling sound from the timing belt side of the bonnet 2. a friend 'tightened' the timing bolt recently and car has begun showing a fault sign with airbag on the display Help!

Submitted: 25/05/2016 22:45:06 | ID: 132041

Answer this question

Philomena Sherlock, East Sussex

Nissan Primera

Took my car to the garage for a air con, fan check. It came back with a cd stuck behind the unit and makes a noise every time I start the car. Garage say they didn't do it! Any one got any ideas on how to take the panel off around the player to have a look please.?

Submitted: 23/05/2016 13:24:55 | ID: 131905

Answer this question

Ibrahim, Nigeria

Nissan Primera

My engine of Nissan primera 2002model does not raise fully. what are possible causes and the solutions

Submitted: 20/05/2016 21:23:55 | ID: 131788

Answer this question

Ibrahim, Nigeria

Nissan Primera

My engine of Nissan primera 2002model does not raise fully. what is possible causes and the solutions?

Submitted: 20/05/2016 21:11:07 | ID: 131787

Answer this question

anton muller, South Africa

Nissan Primera

I am trying to replace the gearbox oil.I have managed to drain the oil. The filler plug on the side is very tight.I have tried a 3/8 square spanner,the hole is 1mm bigger than the 3/8. I am scared of damaging the hole.Any suggestions?

Answers

I wouldn't risk using that, they are prone to being super tight, I broke 3 tools that were the perfect size trying to open them. Still never got the filler undone, only other way to get the oil in is through the top, on top is a plastic piece with 1 bolt in I believe, it's awkward as hell but undo the bolt, carefully pry around the edge till the cap pops off then fill it from there, best of luck Marc from Kent

Submitted: 09/05/2016 16:41:29 | ID: 131344

Answer this question

Edward Missick, Bahamas, The

Nissan Primera

I parked my car and when i return the car would not start. there no lights none of the electrical system is coming on, all fuses are good and the battery is good. i played with the start switch a few times and the dash lit up for a few seconds and went back off . What could be the cause of this ?

Submitted: 04/05/2016 06:55:59 | ID: 131151

Answer this question

Tammie, Buckinghamshire

Nissan Primera

Hi for some reason my speedometer, petrol gauge and temperature not working help please

Submitted: 02/05/2016 10:58:36 | ID: 131062

Answer this question

jon, West Midlands

Nissan Primera

P12 1.8 primere 56 reg. Using lots of oil 1litre every 650 miles no smoke drives fine. Then misfire cars juddering. Compression test shows. 175 175 150 70. How do I fix it?

Answers

I'm only guessing, I'm having a similar problem. The seal behind the flywheel could be leaking oil in to the bell housing and splashing the clutch with oil, so your misfire could be intermittent clutch slip. See if it misfires whilst in neutral. Let me know how you get on and if you get a better answe Marc from Kent

Submitted: 25/04/2016 20:13:24 | ID: 130810

Answer this question

gerald, Antrim

Nissan Primera

Spark plugs melted and car is running terrible cant get up a hill can you tell me the cause of this and is it fixable

Submitted: 24/04/2016 17:59:29 | ID: 130768

Answer this question

Joel de Oliveira, Portugal

Nissan Primera

Hi guys, my car has been parked for long and the battery died and had to be replaced.. Now i can't ut the alarm functioning, and i don't know if that's related or not, but the central door locking it's laso not functioning well.. Can somebody help me please? Thank you

Submitted: 21/04/2016 14:01:57 | ID: 130658

Answer this question

Marty, Aberdeenshire

Nissan Primera

Hi! I have a Nissan Primera P10 2.0i SLX (SR20De, 92kW) and for some reason the driver's window does not work at all, anymore. It used to work normally earlier, then it started to work from time to time. I had to move up and down continuously the switch for it to work on either way, but now it doesn't move at all. When I use the switch, I can hear a "knock" sound under the door panel, which is probably the window relay or something like that, so the problem cannot be with the switch. Could the cconnections be just burnt so it doesn't work anymore at all? I think that could be fixed, if I just solder all the connections to the switch and relay...

Answers

I actually managed to get this work by myself :D The faulty one was the window power amplifier/relay/whatever it is called. It had some poor solderings in it, so I re-soldered the pins that were going to the connector, and now it works like a charm! Marty from Aberdeenshire

I actually managed to get this work by myself :D The faulty one was the window power amplifier/relay/whatever it is called. It had some poor solderings in it, so I re-soldered the pins that were going to the connector, and now it works like a charm! Marty from Aberdeenshire

I actually managed to get this work by myself :D The faulty one was the window power amplifier/relay/whatever it is called. It had some poor solderings in it, so I re-soldered the pins that were going to the connector, and now it works like a charm! Marty from Aberdeenshire

Submitted: 21/04/2016 09:20:06 | ID: 130645

Answer this question