MITSUBISHI L200 questions and answers

Ask and answer questions on a variety of MITSUBISHI L200 models. Help and advice on everything MITSUBISHI L200. Feel free to ask and answer as many MITSUBISHI-related questions as you wish.

Ask a question now

Contract hire image

Search the questions and answers section:

Below are the latest MITSUBISHI L200 questions submitted by visitors to RoadTestReports.co.uk. To supply an answer, simply click on the "Answer this question" link underneath each question. Alternatively, if you want to ask a question, please use this simple form. Please try to make the question as detailed as possible, with all the information necessary for a comprehensive answer included. Please do not use "text speech" or type everything in CAPS LOCK.

Tommy mccresdie, Dumfries and Galloway

Mitsubishi L200

I have an l200 warrior 2010 plate I had a whirring noise from front and when I slow down its gets louder I thought it would be the drive shaft but it's not that as renewed the passenger side one. All my tyres are fine all on right way I am so puzzled what it could be getting to the point where I don't want to drive it as think I could cause more damage

Submitted: 09/02/2016 20:14:06 | ID: 127348

Answer this question

Robert Mcelwee, Perthshire

Mitsubishi L200

I have a Mitsubishi L200 Animal 2008. i have heat on passengers side but not on drivers, replaced thermostat and flushed hoses but no success Heat on drivers side is mildly warm, have flushed out heater matrix also, more concerning engine over heating after 30-200 miles

Submitted: 24/01/2016 18:47:55 | ID: 126637

Answer this question

Wayne, West Midlands

Mitsubishi L200

First noticed when cruise control engaged feels like power increases then decreases so I stopped using it. Now when I accelerate in normal driving mode it's doing the same thing speeds up and down. It's the auto L200 barbarian 2010 80,000 miles on clock. Please help

Submitted: 15/01/2016 19:02:35 | ID: 126199

Answer this question

samuel, Barbados

Mitsubishi L200

Have a 2007 L200 4d56.Three weeks after changing the timing belt, the tensioner bolt snapped and I had to replace the belt. Any ideas has to why it snapped?

Answers

My guess would be a) You didn't replace the bolt or b) You overtightened it or c) Act of God, just plain bad luck. This is assuming that you did your installation correctly Brian from New Zealand

My guess would be a) You didn't replace the bolt or b) You overtightened it or c) Act of God, just plain bad luck. This is assuming that you did your installation correctly Brian from New Zealand

Submitted: 13/01/2016 20:27:53 | ID: 126077

Answer this question

annette jackson, South Africa

Mitsubishi L200

i have a 2006 colt club cab,2.8tdi ,i did put a new radiator in a year ago ,how ever it loses water and stats over heating ,if i travel 70km ,before i leave to get back home ,i have to top up the bottle and the radiator again ,there is no oil and water mixing ,the oil in he engine is black ,i reset the timing .but it still loses water ,when we do long distance travling please help annette

Submitted: 12/01/2016 13:38:12 | ID: 125993

Answer this question

Robert Mcelwee, Perthshire

Mitsubishi L200

I have a Mitsubishi L200 Animal 2008. The heater heat's up then after about 40 miles or so it turns cold and gauge jumps to red, i have changed Thermostat thinking this would solve problem but no.Is there anyone that could solve

Submitted: 06/01/2016 18:50:42 | ID: 125653

Answer this question

Christos Philippou, Rhondda Cynon Taf

Mitsubishi L200

Engine looses power and power comes back as soon as I shift to neutral and back into gear. After a little while same thing happens and again I have to repeat the same procedure,I.e. Shifting to neutral and back into the appropriate gear, which wakes up the engine to normal power until it repeats the same power loss once it reaches the higher sector of the Rev. Range. Please anything that you think would work would be highly appreciated, my mechanic is in despare and so am I.

Submitted: 05/01/2016 14:51:40 | ID: 125588

Answer this question

Terry, Ireland

Mitsubishi L200

I put a new battery in the wrong way round blew a fuse on the central locking fix it driving the jeep for a few days now I put the high beams on and power goes lights gone won't start any ideas please

Submitted: 31/12/2015 18:43:35 | ID: 125368

Answer this question

Bob lowe, West Midlands

Mitsubishi L200

My 15 l200 hazard lights are randomly coming on when I drive what could be causing this ?

Submitted: 28/11/2015 16:14:34 | ID: 124110

Answer this question

freddy, Nigeria

Mitsubishi L200

After changing my clutch plate I discover a strange warning light started showing on my dashboard and the mechanic claimed is the auxiliary oil light indicator meaning I needed to add more oil. Please help

Submitted: 27/11/2015 05:13:21 | ID: 124064

Answer this question

colin, West Yorkshire

Mitsubishi L200

white smoke comes fron exhaust but we are not loosing water,when your driving no smoke any help thanks

Submitted: 03/11/2015 17:53:09 | ID: 123087

Answer this question

Jeanette, Wiltshire

Mitsubishi L200

Hi guys reAly need help on this , I have a l200 1998 td it's not taking reves , I change turbo , I change injectors and it's still doing the same , loosing power please some one help

Submitted: 31/10/2015 13:19:34 | ID: 122927

Answer this question

jack black, West Midlands

Mitsubishi L200

What under seal do I use for my l200 ?

Answers

Wax oil jack black from West Midlands

Submitted: 24/10/2015 00:53:51 | ID: 122651

Answer this question

julie, Devon

Mitsubishi L200

Mitsubishi l200 double cab has a whirring sound underneath when driving along seems to come from front Especially noticeable when warm

Answers

Need more info. Does it happen when accelerating, does it go away under certain conditions, or, cruising/coming off the throttle. Is it worse when cornering, what effect does braking have, does it increase/decrease with speed? Ricky from City of Edinburgh

Submitted: 13/10/2015 20:00:18 | ID: 122293

Answer this question

Kevin, Trinidad and Tobago

Mitsubishi L200

Hi ihave a l200sportero we missed the appointment to service n did it our self bt now Wen we are in traffic or drivin slow we dnt get speed Unless we turn d van off n bt On Wat could bae d problem

Submitted: 17/09/2015 16:06:23 | ID: 121286

Answer this question

ashokanthaliyouth, Saudi Arabia

Mitsubishi L200

Over black smoke .please reasons.

Submitted: 15/09/2015 22:34:57 | ID: 121195

Answer this question

DAVE, Merseyside

Mitsubishi L200

I HAVE REPLACED MY BATTERY IN THE KEY FOB BUT IT STILL DOES NOT LOCK OR UNLOCK MY VEHICLE RED LIGHT FLASHES RAPPIDLY BY NO RESPONCE I HAVE THE CODE NUMBER IN THE FOB. WHERE CAN I SEND OFF FOR NEW ON AN WILL THE VEHICLE RESPOND TO A NEW ONE OR WILL I HAVE TO GET IT RESET I THINK THE INSIDE OF OLD FOB IS DAMAGED THANKS FOR YOUR HELP

Submitted: 14/09/2015 22:28:33 | ID: 121155

Answer this question

Larry, Greater London

Mitsubishi L200

Hi, I have a Mitsubishi Warrior L200 year 2003 I started L200 after 2 days of not using it. It started & reed like the choke was out when it wasn't. Black smoke came out the exhaust. Second time it did the same yet noticed some clear smoke coming from the air filter area. After this, it starts but cuts out after 2 seconds, no power to drive or idle. Is it full related or airflow? Thanks in advance for any advice. Larry

Submitted: 25/08/2015 22:12:51 | ID: 120336

Answer this question

Margaret macleod, Highland

Mitsubishi L200

The window control panel won't open the back or passenger side widows, they all open from Their own switch, but not from the drivers main control panel, the battery was removed, is there a code that has to be Reset. Thanks

Submitted: 27/07/2015 10:28:52 | ID: 118968

Answer this question

kevin wiltshire, Surrey

Mitsubishi L200

I have a L200 on a 55 plate, the vehicle will start but stalls approx 2-3 seconds , will start straight back up and do the same. on some occasions while keeping igntion and starter running the vehicle decides to keep running, if it has been running as long as you dont turn the ignition off for more than 7 seconds ( yes have tried it many times and its excatly 7 seconds ) it will go back to start and stall, anything under 7 seconds and will start and run, have donored engine ecu and immo ecu and key from a known gd donor and does the same. any ideas as am at my wits end trying to get to the bottom of it, regards

Submitted: 14/07/2015 10:28:56 | ID: 118439

Answer this question

Pat, Ireland

Mitsubishi L200

Hi my l200 makes a vibrating noise in first and second when pulling a heavy load can you tell me what it might be there is just 50,000 miles on it.

Answers

Check the rubber carrier bearing on your drive shaft Clive nelson from County Down

Submitted: 27/06/2015 23:25:31 | ID: 117782

Answer this question

mik, South Africa

Mitsubishi L200

I have recently notice my L200 overheating. Upon inspection no coolant in radiator if I refill it then it leakes out under glove compartment onto passenger floor.what can it be?

Submitted: 04/06/2015 08:22:52 | ID: 116791

Answer this question

U P Welikala, Sri Lanka

Mitsubishi L200

I have a Mitsubishi l200 elegance 2007, just want to know whether I have to change the automatic gearbox oil filter when I am changing the gearbox oil or never. If I have to change what is the frequency for the filter?

Submitted: 01/06/2015 06:37:06 | ID: 116674

Answer this question

steven, Spain

Mitsubishi L200

Hi My truck has been thoroughly tested on the engine side due to it losing power and the engine management light staying on ,I've had turbo cleaned and stripped down ,map sensor changed, throttle box replaced , and it keeps on coming up turbo over boost . Its been in 4 garages and still no fault found but I am now being told it could be the on board computer sending out the wrong signals and it will need resetting ? does anyone have any ideas as to how I go about this ? any help would be really appreciated . many thanks Steve

Answers

turbo valve faulty follow hose from wastegate to 2 sensor on manifold and change them for new ones john daly from Offaly

turbo valve faulty follow hose from wastegate to 2 sensor on manifold and change them for new ones john daly from Offaly

Submitted: 31/05/2015 20:06:51 | ID: 116665

Answer this question

Mark, East Sussex

Mitsubishi L200

The four-wheel-drive light is continuously flashing whilst it's not in four-wheel-drive can you help me please

Submitted: 30/05/2015 20:09:00 | ID: 116639

Answer this question

Barry, Moray

Mitsubishi L200

I have a 2007 l200 there is oil dripping out the bottom of the bell housing it's not engine oil as not using any oil. Is it likely to be coming from the gearbox side ?

Answers

Between the Bell housing and the engine there is a seal, that may be the cause of the Problem, the job can nt be done without the removal of the box as the spigot shaft enters the Flywheel, I'm sure it will be that seal that has perished, allow yourself a day to do the job. Trebor from Lancashire

Second that, Oil seal at the imput shaft. You will definitely need help lifting box in and out. Ricky from City of Edinburgh

Second that, Oil seal at the imput shaft. You will definitely need help lifting box in and out. Ricky from City of Edinburgh

Submitted: 25/05/2015 22:16:54 | ID: 116461

Answer this question

irene davies, Gwynedd

Mitsubishi L200

What could cause my Mitsubishi L200 to go into full revs as without pressing the throttle. Can anybody suggest any reason? Thank you.

Answers

Sounds to me like the turbo has gon. And the engine is Erving up using the engine oil as fuel. Bill from South Ayrshire

Submitted: 17/05/2015 17:37:27 | ID: 116159

Answer this question

Bishnu Jodha, Suriname

Mitsubishi L200

Ignition lights don't come on and battery power draining

Submitted: 05/05/2015 03:36:53 | ID: 115586

Answer this question

Patrick, Botswana

Mitsubishi L200

I have a 2004 model Mitsubishi L200 and when driving it is not steady on the road, it tends to some kind of goes off the road on its own. Can you help me with this one please.

Submitted: 05/04/2015 05:16:50 | ID: 114332

Answer this question

lisa guard, Carmarthenshire

Mitsubishi L200

Hi, when I unlock the car and open the door the hazard lights flash but don't make a noise and they won't stop flashing till I lock it again. Can you help me with any idea of what you think might be going on? Thanks

Submitted: 08/03/2015 19:18:52 | ID: 112985

Answer this question

Nery, Portugal

Mitsubishi L200

Good start cold in the morning. After about 10 kms If you stop and try to start again, the starter runs Ok but no start of the engine 2.5D . If you open the hood for about 10minutes and try again, the motor starts normally. What is the possible cause?

Submitted: 07/03/2015 22:34:59 | ID: 112937

Answer this question

Steve rouse, Lincolnshire

Mitsubishi L200

Hi my l200 does not start up first time most of the time but starts fine on a battery pack I have replaced the battery but no change I have noticed one of the fuel injectors is leaking fuel would this cause my starting issues?? Regards Steve

Submitted: 03/03/2015 17:14:25 | ID: 112681

Answer this question

Jason, Cheshire

Mitsubishi L200

My 08 plate L200 does not respond under load, it feels really flat but there's no lights on the dash. What can it be?

Submitted: 18/02/2015 17:52:37 | ID: 111820

Answer this question

paddy, Armagh

Mitsubishi L200

Hi, I have a 2004 Mitsubishi L200 2.5D pickup. It will try to fire up or start and not rev up then stop again. The engine management light is not coming on. Would this be a fuse or relay? Thanks

Answers

Hello could be the crank sensor happens alot cbe from Oxfordshire

Hello could be the crank sensor happens alot cbe from Oxfordshire

Submitted: 15/02/2015 19:16:24 | ID: 111606

Answer this question

Lee Young, Devon

Mitsubishi L200

Why does my truck lose vacuum to turbo waste gate as soon as engine management light comes on

Submitted: 14/02/2015 16:58:43 | ID: 111525

Answer this question

brian jack, Curacao

Mitsubishi L200

I just serviced my pickup l200 (diesel). I replaced the fuelfilter but now i can't find where i must plug the wire connected at the bottom of the filter. I'm a first timer.

Submitted: 25/01/2015 15:35:34 | ID: 110278

Answer this question

Maz, Gwent

Mitsubishi L200

I noticed my temp gauge up so stopped cooled it off asked some people I know to look at it as I suspected it was egr cooler they by passed it said it seemed to not be the issue as the header tank was still bubbling when it was by passed and they said it could be the head gasket or a cracked block they also checked my thermostat anyway cut a long story short I said save all the messing about if its cracked the head just fit a new one and gasket so they did its been ok for about 4 weeks then today whilst I was towing I noticed heaters were cold and temp started rising again so can somebody tell me what's the chances of it being the egr or has it blown the new gasket and if so why ?r is the bulk cracked should I just drop a new engine in it? I can source a new one from milners but is there any cheaper options should be looking at first?I need it back on the road asap I don't have time for messing about as I use it daily for my job as I run my own business and its my workhorse please help me find out what's wrong with my truck

Answers

It sounds like you need a new radiater cap!!! If it's blowing cold this could be the answer as it will also cause temp to rise. Obviously this would depend on how old your l200 is, but if seal gone on cap this could be the faults that show up,, and it's only a £20 replace!! Good luck. Jimmy horne from South Ayrshire

It sounds like you need a new radiater cap!!! If it's blowing cold this could be the answer as it will also cause temp to rise. Obviously this would depend on how old your l200 is, but if seal gone on cap this could be the faults that show up,, and it's only a £20 replace!! Good luck. Jimmy horne from South Ayrshire

Submitted: 09/01/2015 22:41:12 | ID: 109247

Answer this question

geordie, Northumberland

Mitsubishi L200

Hi I have an 07 Warrior new shape with superselect manual gearbox. My problem started when I was driving on tarmac in 4wd h and heard a clicking noise that seemed to be coming from the passenger side front wheel, but only a slight noise until I was returning home and the click turned into a sudden thud like noise and I was unable to drive on. I pulled up and couldn't see anything obvious wrong so tried again with the same result. I tried in 2wd and it drove home smooth as ever, so a couple of days ago I thought I would try 4wd again but when I tried to move it was like the front wheels were jammed, so I selected 2wd and drove off. After about half a mile I nearly had kittens as a loud screeching whistling noise came from truck that lasted about 10 seconds and it was driving really rough and noticed the 4wd lights on the dash were flashing, so I stopped and made sure it was back in 2wd and drove off with no problem. Any suggestions as to what's wrong? So far we have tried checking the vacuum pipes to actuator and actuator seems to be working ok. I believe if there was no vacuum the front diff would revert to 4wd automatically as the lack of vacuum would cause the actuator to fail.HELP

Submitted: 06/01/2015 14:54:13 | ID: 109032

Answer this question

Clarke, Renfrewshire

Mitsubishi L200

Does not always engaging gears and when it does it does not say in

Submitted: 30/12/2014 15:34:06 | ID: 108639

Answer this question

ALVANA, Greater Manchester

Mitsubishi L200

Why won`t my Mitsubishi take gas?

Submitted: 15/12/2014 00:16:12 | ID: 107918

Answer this question