LDV

Questions and answers

LDV CONVOY questions and answers

Ask and answer questions on a variety of LDV CONVOY models. Help and advice on everything LDV CONVOY. Feel free to ask and answer as many LDV-related questions as you wish.

Ask a question now


Search the questions and answers section:

Below are the latest LDV CONVOY questions submitted by visitors to RoadTestReports.co.uk. To supply an answer, simply click on the "Answer this question" link underneath each question. Alternatively, if you want to ask a question, please use this simple form. Please try to make the question as detailed as possible, with all the information necessary for a comprehensive answer included. Please do not use "text speech" or type everything in CAPS LOCK.

tara cooper, Hampshire

LDV Convoy

Will a 2008 aletrnator fit my 1997 LDV Tipper?

Submitted: 11/02/2016 09:59:08 | ID: 127430

Answer this question

Ruth, Worcestershire

LDV Convoy

Hi Guys, I have a convoy 400 53 plate van. I replaced the battery last September as notorious for not starting in frost. It has been starting fine in the frost. I got to work and it stood in cold all day. It started second time at home time and I traveled about 3 miles in the last mile the fuel light stated to flicker, popped into the shop and it wouldn't start again. it drained the battery trying to get it started again so I jumped it to no avail. I put more fuel in wouldn't start. Booster pack jumped it and it still wouldn't start. Does this sound like a fuel issue (airlock maybe) or just electrical? It turns fine when jumping just not catching?????? Love and thanks :)

Submitted: 22/01/2016 12:40:04 | ID: 126528

Answer this question

D morris, West Glamorgan

LDV Convoy

Hello, My 1999 ldv convoy (only 20000 miles) van runs fine. No some, seems to be full power, strong on hills, gearbox fine, clutch fine, electrics fine, everything works but... ...when I drive about five miles the engine light comes on yet everything runs fine. It does this all of the time and only after driving around five miles. I have drove the van with the engine light on 100 miles and still the van runs fine. It,s been doing g this for about six months. I did fit a new car stereo a while back I'm not sure whether this may have something to do with this, I checked battery it's getting over 13v so I don 't think it's that. I also had the timing belt changed professionally a year ago, no problems there, the van runs fine, strong as an ox. It's a ford engine not banana. Anyone know why this engine light is doing this.

Submitted: 22/01/2016 10:27:53 | ID: 126523

Answer this question

Roger, Suffolk

LDV Convoy

Can anyone help me to locate the glow plug relay on my 2004 Convoy 400 2.5TDi? I assume that it's in the engine compartment somewhere but it's not on the passenger-side bulkhead above the battery, which where I was expecting to find it. The wire from the glow plugs disappears into the wiring loom but I cannot see where it exits. Thanks.

Submitted: 17/01/2016 19:24:18 | ID: 126309

Answer this question

tony murphy, Bedfordshire

LDV Convoy

Need to replace a front wheel, where are the safe jacking points & is the spare easy to remove

Answers

Don't forget they undo the opposite way on both sides - always towards the back of van both sides - tighten towards the van - you will need a breaker bar and a deep socket , as they are self tighting nuts - but should be able to do it easy enough put jack in just at back of wheel , you should be able to see jack points. ldv_files files from Cambridgeshire

Submitted: 10/01/2016 14:58:08 | ID: 125860

Answer this question

neal paley, Lancashire

LDV Convoy

getting lots off grey black smoke and no power, any ideas

Answers

Neal, could be a few things.. head gasket, warped head, EGR valve stuck, turbo seals gone, but could also b failed sensors on camshaft, crankshaft, injector timing, fuel rail pressure sensor, blocked air filter, blocked fuel filter... er.. get it looked at by mechanic, fella, could be something totally simple and easy fix. R Evans from Caerphilly

Submitted: 08/01/2016 19:54:13 | ID: 125768

Answer this question

mike, West Midlands

LDV Convoy

I've had my convoy 400 for a few years now and no problems but I've lifted the tipper up but it won't go back down.ive checked fuses and battery etc and all seems to be ok any ideas anyone

Answers

hydraulic fluid , checked pipes for leaks ? ldv_files files from Cambridgeshire

Submitted: 02/01/2016 13:53:19 | ID: 125423

Answer this question

robin horton, Nottinghamshire

LDV Convoy

ldv convoy x reg luton van 2.4 d.. ran out of fuel, topped her up, bled her, started then cut off.... battery is new but the more I turn her over the weeker she gets.. any ideas.. its the banana engine.

Answers

Robin, you say you bled her.. but sounds like you have an airlock there somwehere R Evans from Caerphilly

Submitted: 31/12/2015 20:03:37 | ID: 125370

Answer this question

colin davies, Rhondda Cynon Taf

LDV Convoy

Hi I have an 04 16/17 seat high roof convoy minibus, there are two faults 1 the fuse for the rear fog lights keeps blowing. 2 the interior roof lights in the back do not come on when switch pressed in, the cab lighs work, as do all the other lights. Is the module on passengers side ie foglamp ecu, a relay ? Any help appreciated. Thanks.

Answers

Hi regarding above faults, they are now rectified I traced the loom going to rear of vehicle that runs along roof channel front to back, in roof section, I went in to the loom at 12" intervals followed wires to rear via diagram colour code found break in live wire to internal lights repaired break. Did same with fog lamp wiring, repaired. Re insulated loom. All working!! colin davies from Rhondda Cynon Taf

Submitted: 14/12/2015 12:47:25 | ID: 124674

Answer this question

Adrian Drummond, Herefordshire

LDV Convoy

Hope you can help. I bought an LDV Convoy a few months ago and last week attempted my own oil and filter change. Everything was fine but I could not unscrew the oil filter. I tried with a heavy-duty adjustable spanner but that did not work. I had seen in the LDV Service Manual that there was a special wrench tool for such a job. However, these are no longer available. I was advised that another tool designed for Ford Transit vans with the same Duratorq engine would also work. I bought what I was told would fit but it didn't. I now no longer know what to do. Please an you advise or tell me how a garage or mecahnic would remove it?

Submitted: 09/12/2015 08:22:51 | ID: 124511

Answer this question

steve, Devon

LDV Convoy

hello.i have a 2003 2.4diesel convoy .came to start the van,on turning key got only battery and oil light on dash.engine will not crank over unless i overide starter relay but will not fire up.had ecu checked and ok.

Submitted: 06/12/2015 13:29:04 | ID: 124407

Answer this question

robert gray, Yorkshire

LDV Convoy

hi got an ldv convoy ex postoffice van reg bx54nnl run grate parked it up for 4 days when out wouldent start immobiliser flashes fast turns over ... try esay start still no look tried all connections but the fip i carnt get to the top ov it anyone help? what can it be// thanks robert

Submitted: 28/11/2015 21:31:10 | ID: 124122

Answer this question

Aidan, North Somerset

LDV Convoy

Can anyone please answer my question I have a ldv convoy 400 2.4 ford engine it won't start on really cold mornings but it starts first time when there's no frost I had the aa out they said it's the glow plugs I took it to my usual garage and he said he needs a day to check it as he thinks it's a electric fault!! thanks in advance for any replies

Submitted: 25/11/2015 16:17:48 | ID: 123982

Answer this question

phil, Cumbria

LDV Convoy

I have a 1999 ldv convoy minibus it runs ok on the flat but going uphill is a nightmare down to 10 mph and in first then ok when on the flat any ideas it has the banana engine im told

Submitted: 19/11/2015 10:18:21 | ID: 123689

Answer this question

Bill C, Cumbria

LDV Convoy

REvving the engine in neutral gear thick black soot blows out the exhaust. This doesnt seem to happen when driving normally with it. Only if I rev it. It does happen if I drop to 2nd gear and accelerate hard. What would cause this and how is it fixed please

Submitted: 19/10/2015 16:39:23 | ID: 122481

Answer this question

Davey Sadler, Kent

LDV Convoy

Ive just brought a converted 2005 ldv convoy 400 12 seater mini bus. On the way home on the M25 the engine lost power, and on trying to turn over it just clicked. No chocking or sruggling just a clicking. The electrics all worked but the engine just start or make any noise. After getting towed and left on the sos layby i waited for the AA for 2 hours to come rescue me and I tried again and the engind started no problem. When the AA got there theu saw no fault and sent me on my way. I drove home very slowly 40-50 for 86 miles and no problems. I then drove to my town and back which is only 8 miles in total and as i pulled up at home again the engine cut of! No reason, no clugging or any noise to make it sound like it was sruggling, just cut out. It didn't start at all. Then an hour later it starts fine again. The aa again came out today and found no fault again as it was working. What is causing my engine to just cut of? The earth seems firm and i cant see a problem with the immobiliser wire, but no absolutely nothing about cars or vans. Any. Ideas?

Answers

Under the bonnet in front of battery above head light is a big wire block connector with a 10mm bolt going through it , check connection , this always plays up , sent me mad barn from Kerry

I have had a similar problem and the in line diesel filter was in need of changing it is only about £5 and changing it was no problem but priming it was time consuming as the primer does not work that well. I am an old hand at this sort of thing and I disconnected the fuel line to the distribution pump and connected a long see through pipe and sucked it until I could see it re connected the pipe to the to the filter and finished it off with the primer pump. it all worked fine. Nigel Mason from Surrey

I have had a similar problem and the in line diesel filter was in need of changing it is only about £5 and changing it was no problem but priming it was time consuming as the primer does not work that well. I am an old hand at this sort of thing and I disconnected the fuel line to the distribution pump and connected a long see through pipe and sucked it until I could see it re connected the pipe to the to the filter and finished it off with the primer pump. it all worked fine. Nigel Mason from Surrey

Submitted: 09/10/2015 13:48:16 | ID: 122107

Answer this question

grant, Merseyside

LDV Convoy

The battery light has come on and my power steering and brakes have gone x

Answers

I have the same problem with my 2 ltr ford convoy . I drove through surface water on the road which i couldnt avoid the power strerring failed battery light came on in the dash and brakes firmed up . On other types of vechile dodges with same symptomes they say its a water problem causing the power sterring pump drive to slip.I am not a mech but sounds resonable to me. But how do i dry it off? tim from Warwickshire

I have the same problem with my 2 ltr ford convoy . I drove through surface water on the road which i couldnt avoid the power strerring failed battery light came on in the dash and brakes firmed up . On other types of vechile dodges with same symptomes they say its a water problem causing the power sterring pump drive to slip.I am not a mech but sounds resonable to me. But how do i dry it off? tim from Warwickshire

Submitted: 05/09/2015 22:39:27 | ID: 120831

Answer this question

Nicola Mulligan, Devon

LDV Convoy

Hi, I have an 02 LDV 400 convoy that was previously used by a care home. It had a rear lift for wheel chairs which was removed before I bought it. I'm converting the bus into a camper. There is still a second battery under the bonnet on the drivers side. Can I connect this up to a solar panel and use it as a leisure battery?

Submitted: 18/08/2015 19:03:50 | ID: 119996

Answer this question

Rebecca king , South Yorkshire

LDV Convoy

Hi can someone please help. My ldv needs oil and I am unable to remove the oil cap on the engine, is there something I'm missing? I've tried turning both ways, pushing down, pulling up, you name it I've tried it. Many thanks

Answers

No, there's nothing you're missing - it just pushes in & pulls out. What's happened is that the rubber seal has dried out & stuck. Squirt WD40 into the gap between the metal tube & the plastic cap then _firmly_ wiggle it in all directions. Be aware that it may come out suddenly. If this doesn't work you can pop the rubber cover off the end then carefully & slowly pour oil through the mesh filter, but you'll tire of this quickly. The next thing is to get another rocker box & cap. One from a scrap yard is fine if you wipe it clean & fit a new gasket. Good luck with the WD40 :-) Anni from Bath and North East Somerset

No, there's nothing you're missing - it just pushes in & pulls out. What's happened is that the rubber seal has dried out & stuck. Squirt WD40 into the gap between the metal tube & the plastic cap then _firmly_ wiggle it in all directions. Be aware that it may come out suddenly. If this doesn't work you can pop the rubber cover off the end then carefully & slowly pour oil through the mesh filter, but you'll tire of this quickly. The next thing is to get another rocker box & cap. One from a scrap yard is fine if you wipe it clean & fit a new gasket. Good luck with the WD40 :-) Anni from Bath and North East Somerset

Submitted: 16/08/2015 15:38:27 | ID: 119875

Answer this question

Julian, Pembrokeshire

LDV Convoy

Hi, My expansion tank on the cooling system has sprung a leak - again! Is this an inherent weakness? (it is a only a few years since last replaced); Is it a symptom of another problem?; Is there a more robust replacement I could use rather than the genuine part? Your comments / advice would be gratefully received.

Submitted: 14/08/2015 10:44:34 | ID: 119751

Answer this question

Ian Fraser, Aberdeenshire

LDV Convoy

hi sorry i fogot to mention in my previous post its a ldv convoy 400 luton with a 2.4 td ford transint engine

Submitted: 09/08/2015 23:20:55 | ID: 119544

Answer this question

Ian Fraser, Aberdeenshire

LDV Convoy

hi i recently changed the fuel filter on my van and now it wont start have pumped fuel through and still wont start i was told it was a bad earth somewhere so i got autp elictrican to sort it which he did and he told me to get a heavy duty battery as the 1 i was using was no use so i did and changed them over and it still wont start even with a jump start or tow it will start and run for a minute when i use easy start i put the van into my mates work kwik fit and they say its an elictrical fault can you please help many thanks ian

Answers

Please tell us the engine type, if you dont know, what year / reg? at the front right of the engine bay is there a large multi pin electrical connector? will the engine turn over? when you replaced the fuel filter did you fill it with fuel before you fitted it? TJ from Devon

have you took the air out after you replaced your fuel filter? pumping is not enough, there is a little black screw on the side on top of the filter, you need to turn that and pump until all the air comes out and you see a good stream of fuel coming out, like the old school radiators if you know what i mean,,,you might need to do a few times as there might be a few bubbles on the system,,,, hope this helps Rog from Blackpool

have you took the air out after you replaced your fuel filter? pumping is not enough, there is a little black screw on the side on top of the filter, you need to turn that and pump until all the air comes out and you see a good stream of fuel coming out, like the old school radiators if you know what i mean,,,you might need to do a few times as there might be a few bubbles on the system,,,, hope this helps Rog from Blackpool

Submitted: 09/08/2015 21:27:12 | ID: 119542

Answer this question

Mark, Essex

LDV Convoy

I have a 3.5t, ldv convoy tipper, 2005 with transit engine. It keeps blowing fuse c9 for the pcm. All wiring been checked. Can sometimes only go 100 yards and it cuts out? Anyone had a similar problem, or know what t o check please?.

Answers

check on pasanger side under bulk head for loose wipermotor it can short out ecu wireing paul from Kent

Submitted: 14/07/2015 11:29:05 | ID: 118441

Answer this question

ellen horan, Ireland

LDV Convoy

I need to find the location of the Chassis vin number on the frame of the LDV van as the road test company will no longer accept the panel with this information. can you help please. thank you.

Answers

It's under the plastic guard by driver`s step. I myself have searched for the answer and they found here in the forum. But not my VIN number, have LHD K-D from Germany

It's under the plastic guard by driver`s step. I myself have searched for the answer and they found here in the forum. But not my VIN number, have LHD K-D from Germany

Submitted: 07/07/2015 12:13:40 | ID: 118151

Answer this question

John Dyson, Derbyshire

LDV Convoy

Have tested glow plugs and relay which seem to be ok, but still cannot get power to glow plugs, any suggestions?

Submitted: 03/07/2015 08:58:27 | ID: 117980

Answer this question

Tony Blunt, Dorset

LDV Convoy

I can't seem to find a drain plug on the rear axle (2.4 Duratorq) of my Minibus , am I losing the plot,I've certainly lost the plug! Cheers.

Submitted: 02/07/2015 14:20:56 | ID: 117945

Answer this question

rebecca, Merthyr Tydfil

LDV Convoy

I have now had my van diagnosed on a machine and this is what has come up code p1665 fip communications with pcm and code P0216 Injection timing control circuit any one have any ideas how to solve these problems

Submitted: 10/06/2015 13:01:03 | ID: 117030

Answer this question

rebecca, Merthyr Tydfil

LDV Convoy

Can anyone help please I have an ldv convoy 400 minibus drove it in the weekend drove absolutely fine no problems at all drive it home parked outside my house knocked the engine off to open gates jumped back in and it wouldnt start tried everything but to no avail so left it for a couple of hours jumped back in and she started took her for a test drive and she cut out and wouldn't restart towed it home and left it till the morning started her back up in the morning She started again but not for long my partner has had a good look under the bonnet and checked all fuses relays earth wires fuel filter u name it we have looked at it can any one suggest what to do next also when it won't start there is a flashing heater plug light on the dash board and as long as that flashes it won't start but as soon as it goes out after a couple of hours it starts for a few mins and it starts to flash again anyone know what to do would be most appreciated thanks in advance

Answers

it mite need a new diesel fillter or the lift pump that the fillter gos in 2 it happent 2 my ldv and thats wat it was fillter £12 try that and if you need the lift pump second hand £15-20 i hope it fixs it good luck tom from Antrim

it mite need a new diesel fillter or the lift pump that the fillter gos in 2 it happent 2 my ldv and thats wat it was fillter £12 try that and if you need the lift pump second hand £15-20 i hope it fixs it good luck tom from Antrim

Submitted: 09/06/2015 18:57:09 | ID: 117008

Answer this question

Alex, City of Glasgow

LDV Convoy

Hi, glow plug light doesn't stop flashing but everything works ok..? Thanks

Submitted: 03/06/2015 18:48:08 | ID: 116769

Answer this question

anthony, Brighton & Hove

LDV Convoy

hi could someone please help me I have a ldv 2.4td minibus yesterday I broke down and called the rac and he couldn't find the fault.my bus just died on me doing the school run it will not start or turn over yet I've got all the ignition lights on would really appreciate any help or advice many thanks

Answers

Could be immobiliser carl wilson from Yorkshire

try the starter wire it mite be lose or the battery wire or you can try and get a we bit of a tow if it starts by a tow then its a lose wire i hope this helps good luck tom from Antrim

hi many thanks for getting back but it was the starter relay been sorted now anthony from Brighton & Hove

Submitted: 03/06/2015 12:09:09 | ID: 116752

Answer this question

tony, Lancashire

LDV Convoy

Hi i have a 400 series convoy 2.5 Peugeot turbo The turbo is playing up but if i tap the turbo with a hammer It works .what do i need to do with it

Answers

Either Remove, clean, check oil flow for obstructions, or recon. Trebor from Lancashire

Submitted: 25/05/2015 20:47:26 | ID: 116456

Answer this question

Rich, City of Nottingham

LDV Convoy

I have just had propshaft seals changed on my LDV crewcab Tipper and when I drive over 35mph the van vibration is very bad. What would cause this to happen? It only happens when I get to speeds of 35mph

Answers

No sure what you mean by propshaft seals?Do you mean the seals behind the bolt-on flanges on the gearbox and rear axle,which the propshaft bolts onto? The most common causes for vibration is one or both of the centre mount/bearings,once these begin to wear,the extra vibration causes wear on the universal joints and bearings on the gearbox and rear differential.Chances are one or both of these are worn,or if these are the seals which you meant, that have been replaced already,its possible to get them slightly out of alignment or askew,as they have some adjustment in the mounting bolt locations.Maybe try loosen and adjust ,2x 10mm bolts, Failing that doesnt cure it,if the propshaft was removed and not marked on the corresponding flanges,so as to refit in the same position,the balancing will have been lost,meaning its now out of balance,Take a note of where its now bolted and you can relocate the prop on one of the other 3 mounting positions,abit time consuming but its the only way I can think you can do it.I hope thats of some help. Danny from Aberdeenshire

No sure what you mean by propshaft seals?Do you mean the seals behind the bolt-on flanges on the gearbox and rear axle,which the propshaft bolts onto? The most common causes for vibration is one or both of the centre mount/bearings,once these begin to wear,the extra vibration causes wear on the universal joints and bearings on the gearbox and rear differential.Chances are one or both of these are worn,or if these are the seals which you meant, that have been replaced already,its possible to get them slightly out of alignment or askew,as they have some adjustment in the mounting bolt locations.Maybe try loosen and adjust ,2x 10mm bolts, Failing that doesnt cure it,if the propshaft was removed and not marked on the corresponding flanges,so as to refit in the same position,the balancing will have been lost,meaning its now out of balance,Take a note of where its now bolted and you can relocate the prop on one of the other 3 mounting positions,abit time consuming but its the only way I can think you can do it.I hope thats of some help. Danny from Aberdeenshire

its your propshaft berring or at the bottom of your driveshaft thers a nuckel were the driveshaft gos on 2 the back axcel take the 4 bolts out of the back axcel that connecks the driveshaft that we round part is your prob you will feel it moves in your hand tom from Antrim

Submitted: 19/05/2015 16:01:24 | ID: 116226

Answer this question

gary, Merseyside

LDV Convoy

Where does black push on wire go that comes from top of fuel filter housing?

Answers

it goes on the bottom of the filter . it is a sensor dave mackenzie from Midlothian

it goes on the bottom of the filter . it is a sensor dave mackenzie from Midlothian

Submitted: 13/05/2015 21:05:44 | ID: 116001

Answer this question

John, Stoke-on-Trent

LDV Convoy

I have a LDV Convoy,2001 2.5 di Tipper.It went into limp mode.I could not find a code reader compatible with Epic.After wasting my money on different code readers and a Month later.I decided to spend some big Money on a code reader,I bought a sykes acre complete with pods and cables.I could not wait to try it,I had 5 codes on it and they would not reset until the fault was rectified.,which was cam out of position,crank out of position ,pump out of position,battery not charged.So I decided to change the cam belt to bring them back inline,changed water pump at same time.Started great but still went into limp mode,Put on code reader and came up crankshaft sensor.Thought great,After obtaining 3 different ones off ebay,non would fit,Found the part numbers and are £150 each,I managed to get one from Germany £50.Fitted it runs great,no fault codes,Im happy with my LDV…If you want your codes reading and local,let me know.If you want a crankshaft sensor 914F 6C 315 AB £50 let me know I have 4 of these.ThanksJohn

Answers

Hi John, Could do with your help. LDV 2.4 duratorq probs with intermittent glow plug light flashing.Code reader would be great help. Am prepared to travel Tony from Derbyshire

Hi John, Could do with your help. LDV 2.4 duratorq probs with intermittent glow plug light flashing.Code reader would be great help. Am prepared to travel Tony from Derbyshire

Submitted: 12/05/2015 16:10:25 | ID: 115945

Answer this question

craig, Middlesex

LDV Convoy

indicators and hazard light stopped working changed flasher relay also stork and and hazard switch still not working anyone have any ideas please

Submitted: 05/05/2015 20:30:10 | ID: 115609

Answer this question

Adam, Staffordshire

LDV Convoy

I've got a ldv convoy hi-top lwb. Problem is takes 3/4 attempts to start up. Then when i come to a junction/traffic lights it cuts out. Any ideas what the cause could be? Thanks in advance

Submitted: 31/03/2015 12:15:18 | ID: 114108

Answer this question

Alex, Kent

LDV Convoy

Just bought an Ldv convoy x reg it was standing from 4 months put a new battery on it fine put some new diesel in it and it fired so I drove it home but when we got to a hill it lost power and struggled to get up the hills but on flat roads it was fine what do I need to do.

Answers

I have an x reg convoy and the same thing happened to me. My fault was the accelerator cable was to slack. Best solution is to buy a new one. You can try adjusting it to see if that's your problem. ian from Scottish Borders

Submitted: 26/03/2015 23:06:48 | ID: 113923

Answer this question

Nick Wood, Nottinghamshire

LDV Convoy

My 2003 Convoy starts and drives perfectly, then for no apparent reason the engine cuts for half a second, then restarts and carries on. The heater plug light flashes on when the engine cuts and the immobiliser led comes on for a few seconds and then goes out. This problem is gradually getting worse, and currently occurs once every 5-10 miles of driving. Any ideas?

Answers

Hi Nick, the fact that the glow plug and immobiliser light come on when this happens shows that the problem is with the power supply. The symptoms you give are the same as very quickly switching your ignition off and on again. Check the battery connections are secure and the battery terminals are clean. Follow the earth lead from the battery to the body and check all is in order. Check the earth lead from the engine to the body is in order. Also check the connection to the solenoid valve switch situated on top of the injection pump. Check the connections on the steering column from the ignition switch going to the wiring loom. The only electrical power your diesel engine needs to keep running once it has started is a 12volt supply to the injection pump solenoid. When you switch off the ignition the power to the solenoid is cut and the solenoid shuts off the fuel supply so stopping the engine. Get back to me if these checks do not solve the problem. regards reg reg from Norfolk

Hi Nick, the fact that the glow plug and immobiliser light come on when this happens shows that the problem is with the power supply. The symptoms you give are the same as very quickly switching your ignition off and on again. Check the battery connections are secure and the battery terminals are clean. Follow the earth lead from the battery to the body and check all is in order. Check the earth lead from the engine to the body is in order. Also check the connection to the solenoid valve switch situated on top of the injection pump. Check the connections on the steering column from the ignition switch going to the wiring loom. The only electrical power your diesel engine needs to keep running once it has started is a 12volt supply to the injection pump solenoid. When you switch off the ignition the power to the solenoid is cut and the solenoid shuts off the fuel supply so stopping the engine. Get back to me if these checks do not solve the problem. regards reg reg from Norfolk

Hi Reg from Norfolk and others, thanks very much for the reply. Thanks to all the advice I received I have resolved this problem. I checked number of wiring issues in one go so I cannot pinpoint the exact problem, but the most likely was the earth connection from the battery (connection onto the bodywork). I have since driven about 600 miles with no further problems. Nick Nick Wood from Nottinghamshire

Submitted: 19/03/2015 10:43:33 | ID: 113533

Answer this question

John, Stoke-on-Trent

LDV Convoy

Please can some one help,I have a LDV Convoy 2.5 di 2001,It has the ford engine,I am looking for a code reader and I don't know which one is compatible,please can you help.Thanks John

Answers

I had my 2000 W reg diagnosed by a company in Sussex who may be able to tell you, Automarine Diesel Services on 01273 415296. They have Lucas, Delphi, Stanadyne, Denso, Bosch... Lovely people, I hope they can help point you in the right direction. Anna from East Sussex

I used a transit reader do's the same job. davy from Hertfordshire

I used a transit reader do's the same job. davy from Hertfordshire

Submitted: 04/03/2015 00:39:35 | ID: 112715

Answer this question

Jez Hellard, Germany

LDV Convoy

The battery light on my LDV Convoy has been flickering on and off for a couple of weeks and now it is on permanently, even before the engine warms up. Had a brand new altenator and battery fitted three months ago and has been working just fine. When it was flickering on and off, the lights would dim slightly when the battery light came on, and now the windscreen wipers are much slower than they should be. Been trying not to drive in the dark or rain, but I'm on tour with my band in Germany and we don't always have a choice. Any ideas?

Submitted: 02/03/2015 14:19:05 | ID: 112584

Answer this question