JAGUAR

Questions and answers

JAGUAR X-TYPE questions and answers

JAGUAR X-Type

Ask and answer questions on a variety of JAGUAR X-TYPE models. Help and advice on everything JAGUAR X-TYPE. Feel free to ask and answer as many JAGUAR-related questions as you wish.

Ask a question now

Buy used imageBuy new / nearly new imageContract hire image

Search the questions and answers section:

Below are the latest JAGUAR X-TYPE questions submitted by visitors to RoadTestReports.co.uk. To supply an answer, simply click on the "Answer this question" link underneath each question. Alternatively, if you want to ask a question, please use this simple form. Please try to make the question as detailed as possible, with all the information necessary for a comprehensive answer included. Please do not use "text speech" or type everything in CAPS LOCK.

COUAO NORBERT KOFFI , City Of Leicester

Jaguar X-Type

Hi sir! Which DIESEL HAND PUMP Bulb can fit to my jaguar x-type 2.2D 155CV (Year 2006)? THANKS. COUAO

Submitted: 20/08/2015 22:22:54 | ID: 120102

Answer this question

kevin price, Essex

Jaguar X-Type

My horn is not working but when I press the horn button the fog light sign on the dash lights up, any ideas

Submitted: 18/08/2015 19:44:07 | ID: 119998

Answer this question

peter cartledge, West Yorkshire

Jaguar X-Type

i keep losing water from expansion tank yet i cant see any leaks anywere and car isnt losing any power

Submitted: 18/08/2015 14:11:39 | ID: 119979

Answer this question

JD, Hertfordshire

Jaguar X-Type

My jaguar x type 2009 drove home fine yesterday but when I parked it on the drive I tried to go out again straight away but it made a weird mechanical noise and would not start. I recently had a new starter motor and clutch which was my problem before but I have no idea why it will not start now ? Glow plugs possibly ? There was white smoke coming from what looked like between the ending and the battery. Cheers.

Submitted: 16/08/2015 11:16:49 | ID: 119861

Answer this question

Ben, Durham

Jaguar X-Type

Hi, I have recently bought a 2002 Jaguar X-Type 2.5 V6 petrol. The car is great and pulls like a train. Unfortunately I am having an intermitent issue with my dashbourd light. Sometimes when i start the car the gauges do not illuminate. All of the warning lights work as they should but just the dials do not light up. As said this is an intermitent fault the comes and goes. Everything still works. Any ideas on what to check/fix?

Submitted: 16/08/2015 09:51:39 | ID: 119857

Answer this question

Matt, West Midlands

Jaguar X-Type

When I start my x-type 2.0D from cold the engine fires but revs stay low for 3-4 seconds before throttle responds and revs go to normal level. This does happen when engine starts when warm but only for a second. I have tried diesel injector cleaners but this does not make a difference. Has anyone had a similar problem? Other than this the car is fine.

Submitted: 16/08/2015 09:00:39 | ID: 119856

Answer this question

JOHN, Derbyshire

Jaguar X-Type

car suddenly starts to accelerate when I take my foot of the accelerator pedal to brake this is a manual vehicle and up to press when I have touched the clutch peddle it has gone back to normal this has happened twice so far has anyone else had the same problem oh and no warning lights showing.

Submitted: 13/08/2015 12:43:08 | ID: 119706

Answer this question

Tariq, Warwickshire

Jaguar X-Type

Hi guys ... I have just bought a My first jaguar from a private seller, while driving back home. I was doing around 60 mph when All of a sudden it started to jerk/shake and it lost speed ..ie it would not go up. The eml light came up on the dash too. I managed to drive the car home at 50 mph. I've had a look around the engine but I can't see anything wrong. I drove the in the evening to work And again when I reached around the 60/ plus mark it did it again ... The eml light has stayed ever since I drove the car home. Does anyone have any idea what the problem could be please.

Submitted: 09/08/2015 23:33:35 | ID: 119545

Answer this question

rob, Greater Manchester

Jaguar X-Type

my stereos volume increases at speed,how can i fix this?

Submitted: 09/08/2015 10:08:34 | ID: 119522

Answer this question

Craig thomson, South Lanarkshire

Jaguar X-Type

Hi car has been running fine went out today started up when driving out of car park heard a bang now have smoke coming from rear of car. There is also smell of burning.

Answers

sounds like the rubber hose (2" x 9") down the left side of your rad they tend to perish and split or a bracket corrodes and the hose gets rubbed against the power steering pulley, have given a more in depth answer but it came up on my screen that there was a problem of some sort! but if the noise you heard was more of a loud pop, then this is most likely the answer, I take it that your car is diesel? also there is a modified silicone hose out on the market now, Cheers and Good Luck Dave Maines. DAVID MAINES from Merseyside

sounds like the rubber hose (2" x 9") down the left side of your rad they tend to perish and split or a bracket corrodes and the hose gets rubbed against the power steering pulley, have given a more in depth answer but it came up on my screen that there was a problem of some sort! but if the noise you heard was more of a loud pop, then this is most likely the answer, I take it that your car is diesel? also there is a modified silicone hose out on the market now, Cheers and Good Luck Dave Maines. DAVID MAINES from Merseyside

Submitted: 04/08/2015 17:23:59 | ID: 119334

Answer this question

Patrick Barker, Dublin

Jaguar X-Type

Vehicle starts to hesitate when driving at 50 mph but is ok if I go above that speed also black comes out of exhaust intermittingly

Submitted: 03/08/2015 15:57:45 | ID: 119285

Answer this question

Chris Dacke, Hampshire

Jaguar X-Type

My 8 year old X type has recently started a fault. On starting up, invariably from warm, it takes 3 or 4 seconds before the engine will respond to the throttle. I have put half a can of diesel fuel system cleaner into the fuel tank, but no improvement so far. I am trading it in for a new Xe in five weeks time so don't want to spend unnecessary money on it. Any ideas?

Submitted: 30/07/2015 16:25:11 | ID: 119126

Answer this question

jon, Cornwall

Jaguar X-Type

Engine management system cuts out at 4000 revs and it is also underpowered, any suggestions? It's a petrol 2.5 V6.

Submitted: 28/07/2015 19:19:24 | ID: 119043

Answer this question

Nick, Essex

Jaguar X-Type

Hi, I have a 2.0 petrol x type, I have security fail on dash display so car won't start. Everything is normal but engine will not turn over. Car has been in garage for 2 months and they have changed each, wiring looms, keys and modules but still the same problem. . Has anybody got any ideas, I love the car if only I can get it to start.

Answers

Hi had this problem on a earlier car i think you,ll find the battery in the remote is not canceling the alarm thats your security fail hope it works D BULL from Leicestershire

Hi had this problem on a earlier car i think you,ll find the battery in the remote is not canceling the alarm thats your security fail hope it works D BULL from Leicestershire

Thanks D Bull, I will pass this info onto my mechanic, although we have got new key's and batteries. Thanks once again. Nick from Essex

Submitted: 22/07/2015 19:36:43 | ID: 118770

Answer this question

les jones, Cheshire

Jaguar X-Type

Long journeys...no problems. Short (town) journeys, the temp guage rises and the red warning light comes on. Checking the water..it's empty ! No sign of cracked container, cap seems okay. No signs of water leakage. Any ideas please?

Answers

Hi if you take it to a garage you,ll its the head gasket leaking into one of the cylinders and blowing the water out the exhuast best of luck D BULL from Leicestershire

Submitted: 18/07/2015 22:33:21 | ID: 118618

Answer this question

DAVE L, Durham

Jaguar X-Type

Had my xtype serviced on return drove terrible, then engine management light came on. parked up for the night ,next morning wouldn't start ,checked filter and pump all ok, but only start in a tow but runs terrible. please help.

Answers

If it ran fine before take it back always get a good garage to do the job D BULL from Leicestershire

Submitted: 18/07/2015 08:18:05 | ID: 118582

Answer this question

d scales, West Yorkshire

Jaguar X-Type

boot will not open just kliking under dashbord

Submitted: 11/07/2015 12:54:07 | ID: 118329

Answer this question

d scales, West Yorkshire

Jaguar X-Type

my boot will not open but can hear kliking under dash bord

Submitted: 11/07/2015 12:51:20 | ID: 118328

Answer this question

Andrew, North Yorkshire

Jaguar X-Type

Hi I'm after selling my xtype with 102k miles on the clock. It's running fine and I've just taken the egr valve off and given it a clean and going to get the error code wiped with my mates diagnostic kit Anyways I'd used my car and drive home from work about 20 miles, got home and a man came to view it He asked me to turn the engine on and then removed the oil filler cap n immediately shook his head and said there was too much 'Back pressure' and went on his way Now there was a bit of smoke coming out but nothing excessive really and baring in mind the engine was hot I didn't think that would be a big issue Can anyone help me out with some advice

Submitted: 07/07/2015 20:53:29 | ID: 118185

Answer this question

Darren, Leicestershire

Jaguar X-Type

Hi, I have an X type 2006 5 speed diesel. It has an intermittent fault with not being able to select any gear when the engine i running. When the engine is off you can select all gears. I was told by a local mechanic it's the limiter switch? I can't find a limiter switch in the workshop manual? Any thoughts?

Submitted: 06/07/2015 16:26:52 | ID: 118131

Answer this question

Diane, Middlesbrough

Jaguar X-Type

Hi when I accelerate at a certain speed it sounds like blasts of air comming in the vents

Submitted: 25/06/2015 22:48:32 | ID: 117711

Answer this question

ian, Tyne and Wear

Jaguar X-Type

engine starts to overheat when driving on motorways but it cools down when idling or driving around the town

Answers

Get this fixed right away before you wreck your engine Sounds like it is the thermostat or maybe water pump is the fan coming on at temp? check coolant level Randy from Canada

Submitted: 11/06/2015 20:30:40 | ID: 117092

Answer this question

patrick, West Yorkshire

Jaguar X-Type

Hi purchased 04 x type jag, however wipers work fine, no washer, cannot hear washer pump, unsure of the relays re electrical side (these may need changing) any one had this problems and if so which relays operate the window washer pump. May have to jack car up remove inspection cover drivers side front and check wiring to pump, although would love an easy fix, think this may be an electrical problem. Any one had this problem or aware of the relays in the fuse box in the front engine compartment ?.

Submitted: 11/06/2015 20:11:20 | ID: 117087

Answer this question

patrick, West Yorkshire

Jaguar X-Type

Hi just purchased car, wiper's working although no window-washer (cannot hear washer pump, checked fuses and relays, any common fault I should be aware of ?

Submitted: 11/06/2015 19:55:50 | ID: 117085

Answer this question

colin thomas, Bristol

Jaguar X-Type

had a flat battery. now car driving fine, but engine management light has come on.

Submitted: 11/06/2015 10:42:10 | ID: 117065

Answer this question

Graham, Somerset

Jaguar X-Type

Hi, just had a service, put car up to 90mph okay, let it come back to 70 and hold, at that car juddering as if it`s miss firing, accelerate back to 90 no problem, just around 70 ish?

Submitted: 18/05/2015 11:54:47 | ID: 116182

Answer this question

bernie batterton, Devon

Jaguar X-Type

Following a short fast-ish run at 60 mph on the M5, last Wednesday (to clear out any crap in the system), on checking out my oil level today Sunday I was met with oil slicks all around the windscreen reservoir area offside. Hope it`s not a major problem. No lack of power or any indication. Can`t seem to see where it came from. Any ideas?

Submitted: 17/05/2015 16:04:32 | ID: 116155

Answer this question

bernie batterton, Devon

Jaguar X-Type

Following a short, sharp sprint on the local motorway (to clean out the system), a few days later checking my engine oil I noticed oil had sprayed from the engine/off side onto the area around the windscreen res unit. I have cleaned it up and given the car another fast run and nothing to indicate where the oil shot from. The car still runs well and no oil leaks show. I hope the problem is not an eye watering repair. Can anyone give advice?

Submitted: 17/05/2015 15:40:39 | ID: 116154

Answer this question

anthony bateman, Northumberland

Jaguar X-Type

I have a Jaguar diesel estate 2.0.cc 2005 with problems, it runs great but when the engine gets up to temperature and is trying to keep the throttle at a steady speed I start to get a miss. Also it seems to use a lot more fuel than it should as I don't horse the car, when I put my foot down a little it runs fine but when going back to keep the throttle steady the miss kicks in again. It`s had a new egr valve fitted in Jan 2015 and fuel pressure switch, also had a service with all filters changed and sometimes the throttle will stick in higher gear as if the choke is stuck on. I have checked under the bonnet for any loose wires or connections but can`t see anything, could it be something electric that is heating up and making the car to misfire or is it something to do with the throttle?

Answers

got it sorted, it was a split in the turbo pipe. anthony bateman from Northumberland

Submitted: 12/05/2015 08:35:23 | ID: 115926

Answer this question

anthony bateman, Northumberland

Jaguar X-Type

When my Jaguar X-Type diesel gets warmed up trying to keep speed steady I start getting a miss, but soon as I put my foot down a bit the miss goes and when I go back to keeping the pedal steady the miss kicks in again. I had an egr valve replaced 2015, fuel pressure switch 2015, diesel cleaner 2015, all in Jan 2015, service in April 2015 and all filters changed, changed to shell diesel plus, but still have the miss.

Submitted: 04/05/2015 18:17:26 | ID: 115566

Answer this question

Godwin, Nigeria

Jaguar X-Type

Jagaur x type 1999 model 3.0 L .When on a drive ,after a short while the car just stop and after some moment, maybe ,when the engine is cooled ,then it moved normal again and stop again probabaly when the engine is hot .what can i change to make this car move normal .i have changed clutch plate and up and down gear clutchs and everything i believe that needed to be changed .

Submitted: 03/05/2015 16:05:27 | ID: 115521

Answer this question

Tracy, Lincolnshire

Jaguar X-Type

Hi Just purchased a Jaguar X Type 2 litre diesel 06, 110000 miles, smokes like a train and sounds tappety been told it probably needs a new cam chain, does anyone know if this sounds right?? and how much the bill might be??? Many Thanks Tracy

Answers

Its your tentioner at the bottom of the chain that needs replacing . Its a relatively easy job. Jurek from West Midlands

Its your tentioner at the bottom of the chain that needs replacing . Its a relatively easy job. Jurek from West Midlands

Its your tentioner at the bottom of the chain that needs replacing . Its a relatively easy job. Jurek from West Midlands

Submitted: 24/04/2015 20:47:56 | ID: 115185

Answer this question

kunku, Sri Lanka

Jaguar X-Type

Hi, my car is diesel 2005 Jaguar x type 2.0D SE. This car has been parked at a garage without running for about 3 month before I bought it. Now my car is having long cranking and after about 1 minute cranking it starts. And also I noticed at about 70 mph car goes to limp mode. Once engine stopped and restarted it runs nicely and comes again. I heard that I need to replace EGR, but why long cranking? Will I have to replace the fuel pump which is inside the tank? ( no smoke on running) Thank you in advance. Kunku from Sri Lanka

Submitted: 19/04/2015 11:21:59 | ID: 114921

Answer this question

Don reston, Merseyside

Jaguar X-Type

2.2 diesel auto water temp rises to just under the half way point on the temp gauge at 80 and 90 mph but when you slow down to 70 and under it drops to just above the quarter mark is that normal heats up ok and its warm in the cabin no probs with the heater

Submitted: 05/04/2015 13:50:53 | ID: 114339

Answer this question

alan, South Ayrshire

Jaguar X-Type

when I put on the alarm the car beeps every minute or so all night, its a single beep

Submitted: 03/04/2015 16:08:12 | ID: 114265

Answer this question

algis, Cambridgeshire

Jaguar X-Type

Hello. I have problem with my Jaguar , i came in the morning start the car , and at the same time Heater, speedometer , and windscreen washers stop working at all. So we made a diagnostic and it shows (P1637-CAN data bus, p1699- communication with heater/ air conditioner malfunction, p0571 brake switch signal foulty , p1544 unknow fault.) Does anyone can tell me what i should do first?

Answers

Morning, Is your battery Flat? did you leave some thing on when you parked it up last night? ( Left boot open_ Trebor from Lancashire

check your fuses insidebox and boxs under bonnet D BULL from Leicestershire

Submitted: 03/04/2015 10:36:12 | ID: 114225

Answer this question

malcolm, West Midlands

Jaguar X-Type

Hi I'm wondering if you can help me when changing gear on my manual gearbox box I get a clunking noise when changing gears at low speed but when I go about little faster it seems to go away please can you help Thank you

Submitted: 02/04/2015 01:19:34 | ID: 114190

Answer this question

martin, Bristol

Jaguar X-Type

hi can you help driving along the motorway at 70 mph glow plug light came on and engine just stopped and will not start thankyou

Submitted: 30/03/2015 12:30:20 | ID: 114068

Answer this question

john finnigan, Tyne and Wear

Jaguar X-Type

I have had the car parked up over the winter with the battery disconnected. I connected the battery up this morning and it started first time. Then I noticed computer reading gearbox fault, cruise control not available, also engine management light on. Took it out on the road and it`s not changing gear?

Submitted: 25/03/2015 19:59:04 | ID: 113849

Answer this question

malcolm adams, Shropshire

Jaguar X-Type

Can you help please with this problem I have? After start up when dashboard fault lights go off, I then move auto gear stick to drive off and all dashboard fault lights come on, including speed dial and rev dials not working and the anti skid red light keeps flashing. The car drives ok and auto gears change alright but I am driving with no speed counter and rev counter working and all dashboard fault lights still on. Can anyone help please?

Answers

I have exactly the same problem but have no idea what is causing this. I will keep looking and if I find an answer I will post it. Darren from Kent

I have exactly the same problem but have no idea what is causing this. I will keep looking and if I find an answer I will post it. Darren from Kent

what year is your car if all your dashboard is not working it could be a problem with grounding of the gauges or you ECM If this only happens when you but the car in gear? then it could be a short or grounding issue with the transmission sensors Randy from Canada

Submitted: 16/03/2015 14:56:04 | ID: 113401

Answer this question