FORD TRANSIT CONNECT questions and answers

FORD Transit Connect

Ask and answer questions on a variety of FORD TRANSIT CONNECT models. Help and advice on everything FORD TRANSIT CONNECT. Feel free to ask and answer as many FORD-related questions as you wish.

Ask a question now

Buy new / nearly new imageContract hire image

Search the questions and answers section:

Below are the latest FORD TRANSIT CONNECT questions submitted by visitors to RoadTestReports.co.uk. To supply an answer, simply click on the "Answer this question" link underneath each question. Alternatively, if you want to ask a question, please use this simple form. Please try to make the question as detailed as possible, with all the information necessary for a comprehensive answer included. Please do not use "text speech" or type everything in CAPS LOCK.

mick, Cambridgeshire

Ford Transit Connect

Hi, my van hunts on tick over, if you raise the revs a little it`s fine. Any ideas please? Thanks

Submitted: 18/12/2014 10:10:00 | ID: 108090

Answer this question

justin, Greater London

Ford Transit Connect

my van will nit stall know mater what i do . i put it in 5th and come off the clutch but it just starts moving . the van drives perfect and the clutch is good . why wont it stall ? thanks

Submitted: 04/12/2014 11:21:30 | ID: 107374

Answer this question

Craig, Tyne and Wear

Ford Transit Connect

What type of oil do I need for my ford transit connect 2007 diesel

Submitted: 25/11/2014 14:53:45 | ID: 106863

Answer this question

ryan pickston, Greater Manchester

Ford Transit Connect

Hi, my battery went flat so I changed it for a new one but now the red light on the dash is flashing really quickly and the van won`t start. I`ve had an auto locksmith out who plugged his laptop into my van but he said I can`t talk to the ECU, it won`t let me get past the clocks and charged me £50 for the privlilege! So what do I do next? The van is outside my house, up to now I`ve spent £50 on a battery and £50 on him

Answers

Hi Rian , I have got the same problem as you after disconnecting the battery to do a gear box change , I have been tol is the immobilizer on the diesel pump. Habe been told to get a second hand pump and have it reprogramed to the van cheapest option. Have you had yours sorted yet? nelson from Essex

Hi Rian , I have got the same problem as you after disconnecting the battery to do a gear box change , I have been tol is the immobilizer on the diesel pump. Habe been told to get a second hand pump and have it reprogramed to the van cheapest option. Have you had yours sorted yet? nelson from Essex

Submitted: 19/11/2014 14:24:54 | ID: 106485

Answer this question

graham, South Yorkshire

Ford Transit Connect

wen van is started it sounds like its hunting wen its hot or cold ive had it diagnosed they told me there was exessive fuel return on all the injectors

Submitted: 11/11/2014 17:09:03 | ID: 106047

Answer this question

richard byrne, East Sussex

Ford Transit Connect

I can't get the side door open ,it opens from the central locking(doesn't have its own keyhole). I know that the lock motor has had it, so how do I get the door open to change the lock?

Submitted: 01/11/2014 22:28:46 | ID: 105481

Answer this question

chris hanson, City of Glasgow

Ford Transit Connect

my diesel pump has gone and i have the chance of a pump from a 56 plate connect my van is a 2003 connect would this pump fit

Submitted: 30/10/2014 18:27:15 | ID: 105347

Answer this question

Denver, County Londonderry

Ford Transit Connect

My van seems to be down on power, very slow at going up through the gears?

Submitted: 17/10/2014 14:28:32 | ID: 104770

Answer this question

Denver, County Londonderry

Ford Transit Connect

My van has lost power?

Submitted: 17/10/2014 14:25:31 | ID: 104769

Answer this question

Tony Dixon , South Yorkshire

Ford Transit Connect

My Ford Connect starts first turn of the key, it runs for 3 seconds then stops, when I try to start it again it just turns over but will not fire up until I've tried several times. Once it's running it`s fine, then when it's standing for more than 12 hrs it happens again. I've fitted new glo plugs and fuel filter but it`s still doing the same. Can anyone help?

Answers

change the cam sensor see if that solves the problem Gordon from Worcestershire

change the cam sensor see if that solves the problem Gordon from Worcestershire

Sounds like fuel is draining back to the tank, runs on the little in the pump then has to suck it all back up from the tank to refill the pump, check the filter seal is good mick from West Midlands

my connect(2010)does the same ,only on sub zero mornings,i have to fit my lift pump and reprime the filter and eventually starts!! otherwise perfect starting if temp stays above zero. New cam sensor,no saved fault codes,filter as new,its a mystery and is driving me nuts. can anyone help? Dont see the point in taking to dealer as no fault in the memory?? Ewen Patterson from Scottish Borders

my connect(2010)does the same ,only on sub zero mornings,i have to fit my lift pump and reprime the filter and eventually starts!! otherwise perfect starting if temp stays above zero. New cam sensor,no saved fault codes,filter as new,its a mystery and is driving me nuts. can anyone help? Dont see the point in taking to dealer as no fault in the memory?? Ewen Patterson from Scottish Borders

Submitted: 09/10/2014 16:08:32 | ID: 104336

Answer this question

Tom, Middlesex

Ford Transit Connect

Will the a frame off a 06 reg ford ranger fit on a 53 reg ford transit connect

Submitted: 06/10/2014 22:04:41 | ID: 104183

Answer this question

mark@hutson.karoo.co.uk, East Riding of Yorkshire

Ford Transit Connect

Have come back to my van after a two week holiday, van started ok but warning light igniton light and glow plug light remain on. Also no tacho or speedo. If I start with main beam lights on everything`s fine. Alternator is charging ok. Also noticed a graunching noise from the steering column when turning the ignition on. Any suggestions?

Submitted: 05/10/2014 19:07:16 | ID: 104112

Answer this question

Dave morgan, Essex

Ford Transit Connect

Engine starts and runs on three cylinders after a while it`s on 4 but it seams to lose power. Is it the injectors? Change filters

Submitted: 20/09/2014 18:03:50 | ID: 103379

Answer this question

John, Ireland

Ford Transit Connect

When I start my van the temperature gauge is halfway up. When I turn off my van the gauge stays halfway up. When I drive for a bit it gos into the red. When I stop and see if it is overheating it is not, so when I look at the gauge when stopped with key removed the temp gauge is halfway up. When I turn the key the temp gauge goes to the red. When cold the temp gauge is halfway up. I start the van, then turn off straight away and the temp gauge stays halfways. If I start and drive for 15 mins the temp gauge will go into red and stay there. I have only driven short distance with this problem. Does anyone know what the problem is? Thanks JOHN

Answers

I have the same problem . Every time I turn on the van i And start it. It all over the place. I was told It was the clocks ( cluster) but if you change the clocks the Van will decode . The reson for this is to stop re clocking the van. So o left it alone , the van stays normal temp. So now I noticed a little leak in the thermostat . I am going to try a few things with it this week. Check to see if fan and thermostat are working then cooling sensor works. Thanks John John from Ireland

Submitted: 19/09/2014 00:31:13 | ID: 103276

Answer this question

Adrian, North Yorkshire

Ford Transit Connect

Will the injectors from a transit mk6 fit my connect 55plate ?

Submitted: 18/09/2014 18:29:39 | ID: 103262

Answer this question

Chris, Northumberland

Ford Transit Connect

I've done head gasket on my ford connect 1.8 tddi 2002 I got it running again,had to put four new glow plugs in for some reason all four stop working the problem I've got is rev counter speedo miles display and interior light not working glow light won't come on the clocks and battery light won't come on clocks aswell,glow plugs work fine fuel gauge works airbag light comes on hand break light works and back light on clocks is on all the time with key out so take leads off battery please help

Submitted: 05/09/2014 18:21:52 | ID: 102662

Answer this question

paulthomas, Stoke-on-Trent

Ford Transit Connect

Where is waterpump..and how differcult to replace myself

Submitted: 30/08/2014 23:32:28 | ID: 102405

Answer this question

james boyle, West Midlands

Ford Transit Connect

hi there my van runs ok but soon as you drive it the temp goes up and when you pull up and try to restart it turns but wont start then after a couple of hours it ok and will start ,ive changed crank shaft sensor cylinder head sensor oil switch sensor glow plugs /egr valve and its had a full service im baffled

Submitted: 25/08/2014 16:37:30 | ID: 102101

Answer this question

Joe, Antrim

Ford Transit Connect

Hi there. I’ve got a 2003 Ford Transit Connect and the battery sometimes goes flat overnight. I’ve checked the alternator and that’s charging the battery okay and I’ve had the battery tested and that’s okay, but I’ve noticed the digital clock, mileage and trip mileage are staying on. Is this normal with the key removed from the ignition?

Answers

Hi Joe. Chances are the battery will have a dead cell which does not reveal itself with a multi meter which will show 12.5 volts. Yes my dash display stays on but does not sap the battery. A healthy battery under load should show 14.5 volts. 13.5 will be a duff cell. No ignition light glowing i presume. This is a common fault caused by the wiring loom section from alternator rooted up round the radiator to multi plug. Easy to replace. Does this help you. Regards Dave. Dave Bramley from Lincolnshire

Submitted: 21/08/2014 17:13:45 | ID: 101882

Answer this question

Keith, Kent

Ford Transit Connect

Hi I brought this transit connect 2005 from new careful driver just done 90000 mile when do I need to change cambelt

Submitted: 15/08/2014 16:40:50 | ID: 101551

Answer this question

Peter Green, Lancashire

Ford Transit Connect

2009 1.8 T200 Transit Connect now on 68,000 miles. Owned from new. Same problem, 3 times, over equal periods. 3rd time today 5th Aug 2014. At 65-70 mph, engine dies but does NOT cut out. Engine Management light comes on and engine will idle. Attempts to rev in neutral (and stationary) and engine will not pass 1500rpm. Turn engine off, wait for 2-3 minutes and all returns to normal and van drives normally. The same symptom and subsequent recovery has now happened 3 times. Any suggestions?

Answers

get the engine management tested for fault codes but may need the throttle pedal replacing Gordon from Worcestershire

Submitted: 05/08/2014 22:49:52 | ID: 100985

Answer this question

Ants Promann, Estonia

Ford Transit Connect

My 2006 Ford Transit Connect 210LWB petrol was standing in good quality garage and it went simultaneously into fire and the interior burned down totally. the car was not used for 10 days before the fire started. Keys were out of the car. seems the fire has started from the drivers seat or under the drivers seat. Any reasonable comments/experience how this can happen? to me its a mystic how a car can go to fire when everything is swtched off and keys are out from the car. Battery was connected as usual. can there still be a voltage in the wires of the car that cuased the fire?

Submitted: 03/08/2014 09:54:00 | ID: 100812

Answer this question

Michael, Greater Manchester

Ford Transit Connect

Hi i was driving down the motoway my van jus cut out and now it will not crank over my milage has dissaperd all my feeds are fine ecu telling it not to start for sum reason can any1 help please?

Submitted: 30/07/2014 12:12:11 | ID: 100585

Answer this question

thomas, Northamptonshire

Ford Transit Connect

I HAVE THE STANDARD RADIO/CD UNIT. POWER AND CODE ARE GOOD. NO SOUND GOING TO SPEAKERS. RADIO TESTED AND WORKING. FUSES BEHIND GLOVEBOX SEEM OK. IS THERE AN ADDITIONAL RELAY SWITCH THAT MIGHT BE REQUIRED? I'M AT A LOSS. ANY ADVICE WOULD BE APPRECIATED. THANKS.

Submitted: 27/07/2014 22:53:52 | ID: 100467

Answer this question

Mike, Cambridgeshire

Ford Transit Connect

why does the revs go up when changing from 1st to second while depressing the clutch, only normally happens after engine has been running a while.

Submitted: 26/07/2014 07:54:30 | ID: 100364

Answer this question

sean mccaffrey, Armagh

Ford Transit Connect

hi, blower fan in cab does not work, in this weather it would roast you in the van, any suggestions would be appreacated, regards sean.

Submitted: 24/07/2014 20:44:12 | ID: 100305

Answer this question

ade, Devon

Ford Transit Connect

can anyone give us info on best way of getting ignition key cut and spare key for starting van and opening or do i have to go to fords??.my ignition key is badly rounded and warn ....... cheers..

Submitted: 23/07/2014 18:22:48 | ID: 100227

Answer this question

David, Greater Manchester

Ford Transit Connect

Hi slight confusion as to which instrument warning lamp Ford have used for the ABS lamp? I have scanned for codes and my scanner does not interrogate live data so unless I use back probing and wiring diagrams my scanner can't help me. There are no codes present to indicate that an ABS warning lamp circuit fault is present, but there is no ABS warning lamp illuminating either? I am suspecting that Ford have used the park brake/fluid warning lamp as the ABS warning lamp also, can anyone confirm or dismiss this? Thanks David

Submitted: 20/07/2014 10:08:13 | ID: 100030

Answer this question

pj, Ireland

Ford Transit Connect

Hi I have a 2008 Connect and I am trying to code a new remote fob but the van won't enter into program mode when I go from 0-ll 8 times?

Answers

If someone before you has recoded 4 times then main dealer only Rob from Gloucestershire

If someone before you has recoded 4 times then main dealer only Rob from Gloucestershire

Submitted: 11/07/2014 15:41:25 | ID: 99456

Answer this question

alex, United States of America

Ford Transit Connect

Where is the low pressure port located?

Submitted: 07/07/2014 21:11:31 | ID: 99184

Answer this question

Peace, Zimbabwe

Ford Transit Connect

I have a refridgerated 2003 Ford Transit Connect Van that is consuming a lot of water because we put more than 4 litres in a day. The mechanic suspected that it was the head and it was pressure tested and skimmed but the problem persisted. We had a reconditioned head gasket fitted since we could not find one like that. Please can you explain to me what the problem could be and where l can get some spare parts like the camshaft seal, diesel filter and pump, air filter etc?Thanks in advance.

Submitted: 23/06/2014 15:50:36 | ID: 98284

Answer this question

Stan spalding , West Midlands

Ford Transit Connect

How much is my transit connect worth 54 plate 278.000miles reconditioned engine at 153,000 miles

Answers

hi there it depends on age condition and how clean it is but at a guess from 650 to 1150 hope this helps andy p from Hampshire

hi there it depends on age condition and how clean it is but at a guess from 650 to 1150 hope this helps andy p from Hampshire

Submitted: 21/06/2014 17:46:59 | ID: 98191

Answer this question

Yovitsa, Macedonia

Ford Transit Connect

Hi i have problem with the engine,when it starts its working like on 3 cill,and if you rev more than 1000 rpm,than itself it goes to 3000-4000 rpm and stays there. it has tested Bosch pump ,its OK. it has changed belts and same. it has 110 000 Km. it was tested without turbine,same. it has brand new injectors. on tester don't have any mistakes,but on live preview injectors flow is 0.00. on first start they have some values 2-3 sec and than 0.00 and it start to work bad. HELP.

Submitted: 18/06/2014 14:42:39 | ID: 97968

Answer this question

james boyle, West Midlands

Ford Transit Connect

my van starts fine of a morning but once its been driven for a few miles the temp goes up to half way and when i stop and try and restart the glow plug doesent light up and after a few seconds the key cuts out i have to leave it for a couple of hours be for it will restart .its had a new egr valve ,new glow plugs, a full service/a new vacum line anda new intercooler hose any ideas please

Submitted: 13/06/2014 19:14:54 | ID: 97622

Answer this question

James Pushman , Essex

Ford Transit Connect

Ps van just required shows 240,000 on clock glow plug flashes &engine cuts out around 70mph will restart & runs ok if I'm gentle on excel erasing and keep speed down on motorway. Please help if possible

Submitted: 28/05/2014 23:17:39 | ID: 96389

Answer this question

James Pushman , Essex

Ford Transit Connect

When van reaches around 70mph glow plug light flashes on dash board and engine cuts out but will restart will run ok as long as I do not excellerate to hard otherwise glow plug light comes on & engine cuts out. When stopes it will restart.if I keep speed below 75 it will keep running

Submitted: 28/05/2014 23:07:26 | ID: 96388

Answer this question

Adam Davey, Suffolk

Ford Transit Connect

I have been driving my van all day, on my way home from work I stopped to get a haircut. I parked up was gone for 35 to 45 mins and when I got back in the van it wouldn't start, was just a constant clicking noise. Anyone know what this could be please. Thanks Adam

Answers

I think you will find there is either a loose connection to the starter motor which is easy to find if you look straight at it or a sticky starter motor which is temporarily curable by wacking it with a hammer whilst someone else turns the key or a faulty connection to the battery even. nik from Kent

Submitted: 22/05/2014 21:02:10 | ID: 95953

Answer this question

Mick, Australia

Ford Transit Connect

G'day mate, I have a 1999 ford transit lwb high roof petrol 2.4 ltr 5 speed, my battery went flat overnight and heard a lot of clicking going on? I wobbled over to find it was locking and unlocking itself ? Do I call Ghost Busters or call a priest to perform a exocistism? Do you recon you can help me fella?

Submitted: 18/05/2014 09:07:13 | ID: 95650

Answer this question

philip coombs, Cheshire

Ford Transit Connect

My eps light keeps coming on and saying no hill start, with traction light on as well. What`s wrong?

Submitted: 11/05/2014 19:38:27 | ID: 95394

Answer this question

Mickloughlin, Ireland

Ford Transit Connect

I have an 06 Ford Connect and the starter went 6 months ago so I fitted one but now I have no clock, interior light, no gauges and when the battery is connected lights are staying on the dash, as if I had parking lights on. Also I have no battery light, all wires are correct. The van starts and drives ly, just no gauges. Can anyone help?

Answers

You`ve blown a fuse buddy nik from Kent

Submitted: 05/05/2014 23:45:19 | ID: 95144

Answer this question