FORD TRANSIT CONNECT questions and answers

FORD Transit Connect

Ask and answer questions on a variety of FORD TRANSIT CONNECT models. Help and advice on everything FORD TRANSIT CONNECT. Feel free to ask and answer as many FORD-related questions as you wish.

Ask a question now

Buy new / nearly new imageContract hire image

Search the questions and answers section:

Below are the latest FORD TRANSIT CONNECT questions submitted by visitors to RoadTestReports.co.uk. To supply an answer, simply click on the "Answer this question" link underneath each question. Alternatively, if you want to ask a question, please use this simple form. Please try to make the question as detailed as possible, with all the information necessary for a comprehensive answer included. Please do not use "text speech" or type everything in CAPS LOCK.

Thomas chambers, Antrim

Ford Transit Connect

Handle broke on rear doors how do I get them open

Submitted: 16/05/2015 00:08:39 | ID: 116081

Answer this question

frank, United States of America

Ford Transit Connect

I`ve got a 2010 Ford Transit Connect. I had to put a new master cylinder and brake booster in. I bled the brakes, checked all hose fittings, no leaks. Now I drive for 10 mins and the brake pedal locks up. Please help

Submitted: 09/05/2015 21:13:53 | ID: 115811

Answer this question

Simon, Devon

Ford Transit Connect

My connect seems to very under powered especially when climbing hills 3rd gear is very common 2nd sometimes for a1.8turbo diesel injection make me wonder what both bits are doing is this just how the t200 is

Submitted: 02/05/2015 19:43:30 | ID: 115499

Answer this question

Rolfe, Norfolk

Ford Transit Connect

What is the national speed limit for this type van?

Submitted: 01/05/2015 18:04:55 | ID: 115460

Answer this question

Rolfe, Norfolk

Ford Transit Connect

What is the allowed speed limit on the national roads?

Submitted: 01/05/2015 18:01:46 | ID: 115459

Answer this question

brandon moss, West Yorkshire

Ford Transit Connect

Will a 2005 drivers door fit a 2006 drivers door??

Submitted: 30/04/2015 07:24:21 | ID: 115398

Answer this question

Jon, Meath

Ford Transit Connect

Just reshelled my van an 08 into a 04 shell everything good only stereo no output stereo good would the door looms be different

Submitted: 03/04/2015 16:26:45 | ID: 114268

Answer this question

keith Michael Snape, Tyne and Wear

Ford Transit Connect

The idle speed is well over 1000rpm. it can vary from 1000 to 1500rpm. I have to turn the idle adjust screw on the throttle lever as far back as it will go. and yet it still tick's over fast. and the speed continues to vary between 1000 and 1500.is there anyone out there that can advise me?

Submitted: 21/03/2015 03:52:29 | ID: 113605

Answer this question

nigel bates, Cambridgeshire

Ford Transit Connect

hi i have a problem with my dash the speedo is lite up all the time even with the keys out battery goes flat after a day or so and when you turn the key on the wipers sweep for five times then stop any ideas

Submitted: 04/03/2015 18:44:34 | ID: 112753

Answer this question

aran, Norfolk

Ford Transit Connect

My vans in the garage at the moment, Problem was temperature gauge did not move off the cold and I had no hot air blowing through heaters.they have put a new water pump and thermostat and the temperature gauge works now but no heat still, they are saying head gasket any thought please much appreciate it

Submitted: 04/03/2015 18:18:50 | ID: 112752

Answer this question

Graeme, Middlesbrough

Ford Transit Connect

Hi, my interior light and headlamp warning tone keeps stopping working. I keep resetting them by removing the dash fuse which sorts it out for a while but then they stop again. Now it is getting more frequent.Any suggestions?Regards Mac

Submitted: 27/02/2015 15:13:55 | ID: 112435

Answer this question

Owen, Hampshire

Ford Transit Connect

I ma having issues with the temperature/heater output on the van especially with the outside temp < 6 deg. If I use it on the motorway it warms up to normal (Halfway) on the gauge. However if I'm doing short/low speed journeys e.g. driving through traffic at around 10 to 20 miles and hour. the gauge only get up to the first position. If I then am stationary the temperature gauge goes dow to the small c. This is with the heater control on max and the fan on 2. the heater temperature output also goes colder. Our local ford garage say they can't fault it but have changed the thermostat. Today In the 10 miles (6 on the motorway) it got to just below normal then went down on the last two miles through town. Any Ideas?

Submitted: 17/02/2015 21:54:15 | ID: 111758

Answer this question

Tim, United States of America

Ford Transit Connect

Something got wet now radio works but speakers don't play music just a buzzing sound.

Submitted: 15/02/2015 08:04:06 | ID: 111563

Answer this question

Tom, East Lothian

Ford Transit Connect

Hi I have a 2007 Connect Tourneo smashed I can get a bonnet/grill & bumper from a 2013 face lift model does it fit my 2007. Thanks

Submitted: 05/02/2015 16:52:49 | ID: 110949

Answer this question

John Langston, Tyne and Wear

Ford Transit Connect

I have a 53 reg SWB tdi connect & the heater has went on the blink....It will only work on the highest setting & takes ages to warm up....Any ideas

Submitted: 04/02/2015 14:54:00 | ID: 110878

Answer this question

Andrew, Scottish Borders

Ford Transit Connect

Hi i have a 55 plate ford transit connect. I tried changing the starter motor and it didn't work now i have no dash lights. Does anyone know what this could be i was thinking its blew a fuse?

Submitted: 25/01/2015 16:05:01 | ID: 110279

Answer this question

michael, Malta

Ford Transit Connect

i had a problem with my van since i had an accident last week.the problem is when i turn the key to start the engine crank but the engine did not start.i had the impact on the front side but the engine is ok just the radiator and the bumper shield i crashed

Submitted: 10/01/2015 12:42:47 | ID: 109283

Answer this question

Phil, Greater Manchester

Ford Transit Connect

What number is the fuse for the heating> I can't find the picture in the van

Submitted: 09/01/2015 13:16:34 | ID: 109208

Answer this question

david morgan, Northamptonshire

Ford Transit Connect

I have the identical fault as Ali. I hope someone can answer what the fault is?

Submitted: 07/01/2015 18:31:24 | ID: 109125

Answer this question

Roger, Cambridgeshire

Ford Transit Connect

I have black oil in the water header tank. Any idea what could be the problem?

Submitted: 04/01/2015 10:08:29 | ID: 108866

Answer this question

Arshad Ali Shah, Essex

Ford Transit Connect

Hi yesterday I was driving back from Scotland on m11 my van's temp gauge suddenly went to red and the engine stopped. I pulled over and checked the water and other. Every thing was fine after 20 mins it started again . This morning even when I turned on the engine the gauge went back to red mark. It starts fine but it goes red and the engine stops. What could b the problem . Thanks for your help.

Submitted: 28/12/2014 15:16:06 | ID: 108532

Answer this question

mick, Cambridgeshire

Ford Transit Connect

Hi, my van hunts on tick over, if you raise the revs a little it`s fine. Any ideas please? Thanks

Submitted: 18/12/2014 10:10:00 | ID: 108090

Answer this question

justin, Greater London

Ford Transit Connect

my van will nit stall know mater what i do . i put it in 5th and come off the clutch but it just starts moving . the van drives perfect and the clutch is good . why wont it stall ? thanks

Submitted: 04/12/2014 11:21:30 | ID: 107374

Answer this question

Craig, Tyne and Wear

Ford Transit Connect

What type of oil do I need for my ford transit connect 2007 diesel

Submitted: 25/11/2014 14:53:45 | ID: 106863

Answer this question

ryan pickston, Greater Manchester

Ford Transit Connect

Hi, my battery went flat so I changed it for a new one but now the red light on the dash is flashing really quickly and the van won`t start. I`ve had an auto locksmith out who plugged his laptop into my van but he said I can`t talk to the ECU, it won`t let me get past the clocks and charged me £50 for the privlilege! So what do I do next? The van is outside my house, up to now I`ve spent £50 on a battery and £50 on him

Answers

Hi Rian , I have got the same problem as you after disconnecting the battery to do a gear box change , I have been tol is the immobilizer on the diesel pump. Habe been told to get a second hand pump and have it reprogramed to the van cheapest option. Have you had yours sorted yet? nelson from Essex

Hi Rian , I have got the same problem as you after disconnecting the battery to do a gear box change , I have been tol is the immobilizer on the diesel pump. Habe been told to get a second hand pump and have it reprogramed to the van cheapest option. Have you had yours sorted yet? nelson from Essex

Yeah, it's sorted. I rang a company called Kwik key, he came out and was only there 10 minutes. He plugged a laptop/machine into the van and it started 1st time. The first company who came out were called Kap, they were there 2 hours but didn't fix it and charged me 50 notes! So Kwik key saved the day! Ryan from Greater Manchester

Submitted: 19/11/2014 14:24:54 | ID: 106485

Answer this question

graham, South Yorkshire

Ford Transit Connect

wen van is started it sounds like its hunting wen its hot or cold ive had it diagnosed they told me there was exessive fuel return on all the injectors

Submitted: 11/11/2014 17:09:03 | ID: 106047

Answer this question

richard byrne, East Sussex

Ford Transit Connect

I can't get the side door open ,it opens from the central locking(doesn't have its own keyhole). I know that the lock motor has had it, so how do I get the door open to change the lock?

Submitted: 01/11/2014 22:28:46 | ID: 105481

Answer this question

chris hanson, City of Glasgow

Ford Transit Connect

my diesel pump has gone and i have the chance of a pump from a 56 plate connect my van is a 2003 connect would this pump fit

Submitted: 30/10/2014 18:27:15 | ID: 105347

Answer this question

Denver, County Londonderry

Ford Transit Connect

My van seems to be down on power, very slow at going up through the gears?

Submitted: 17/10/2014 14:28:32 | ID: 104770

Answer this question

Denver, County Londonderry

Ford Transit Connect

My van has lost power?

Submitted: 17/10/2014 14:25:31 | ID: 104769

Answer this question

Tony Dixon , South Yorkshire

Ford Transit Connect

My Ford Connect starts first turn of the key, it runs for 3 seconds then stops, when I try to start it again it just turns over but will not fire up until I've tried several times. Once it's running it`s fine, then when it's standing for more than 12 hrs it happens again. I've fitted new glo plugs and fuel filter but it`s still doing the same. Can anyone help?

Answers

change the cam sensor see if that solves the problem Gordon from Worcestershire

change the cam sensor see if that solves the problem Gordon from Worcestershire

Sounds like fuel is draining back to the tank, runs on the little in the pump then has to suck it all back up from the tank to refill the pump, check the filter seal is good mick from West Midlands

my connect(2010)does the same ,only on sub zero mornings,i have to fit my lift pump and reprime the filter and eventually starts!! otherwise perfect starting if temp stays above zero. New cam sensor,no saved fault codes,filter as new,its a mystery and is driving me nuts. can anyone help? Dont see the point in taking to dealer as no fault in the memory?? Ewen Patterson from Scottish Borders

my connect(2010)does the same ,only on sub zero mornings,i have to fit my lift pump and reprime the filter and eventually starts!! otherwise perfect starting if temp stays above zero. New cam sensor,no saved fault codes,filter as new,its a mystery and is driving me nuts. can anyone help? Dont see the point in taking to dealer as no fault in the memory?? Ewen Patterson from Scottish Borders

Submitted: 09/10/2014 16:08:32 | ID: 104336

Answer this question

Tom, Middlesex

Ford Transit Connect

Will the a frame off a 06 reg ford ranger fit on a 53 reg ford transit connect

Submitted: 06/10/2014 22:04:41 | ID: 104183

Answer this question

mark@hutson.karoo.co.uk, East Riding of Yorkshire

Ford Transit Connect

Have come back to my van after a two week holiday, van started ok but warning light igniton light and glow plug light remain on. Also no tacho or speedo. If I start with main beam lights on everything`s fine. Alternator is charging ok. Also noticed a graunching noise from the steering column when turning the ignition on. Any suggestions?

Submitted: 05/10/2014 19:07:16 | ID: 104112

Answer this question

Dave morgan, Essex

Ford Transit Connect

Engine starts and runs on three cylinders after a while it`s on 4 but it seams to lose power. Is it the injectors? Change filters

Submitted: 20/09/2014 18:03:50 | ID: 103379

Answer this question

John, Ireland

Ford Transit Connect

When I start my van the temperature gauge is halfway up. When I turn off my van the gauge stays halfway up. When I drive for a bit it gos into the red. When I stop and see if it is overheating it is not, so when I look at the gauge when stopped with key removed the temp gauge is halfway up. When I turn the key the temp gauge goes to the red. When cold the temp gauge is halfway up. I start the van, then turn off straight away and the temp gauge stays halfways. If I start and drive for 15 mins the temp gauge will go into red and stay there. I have only driven short distance with this problem. Does anyone know what the problem is? Thanks JOHN

Answers

I have the same problem . Every time I turn on the van i And start it. It all over the place. I was told It was the clocks ( cluster) but if you change the clocks the Van will decode . The reson for this is to stop re clocking the van. So o left it alone , the van stays normal temp. So now I noticed a little leak in the thermostat . I am going to try a few things with it this week. Check to see if fan and thermostat are working then cooling sensor works. Thanks John John from Ireland

Submitted: 19/09/2014 00:31:13 | ID: 103276

Answer this question

Adrian, North Yorkshire

Ford Transit Connect

Will the injectors from a transit mk6 fit my connect 55plate ?

Submitted: 18/09/2014 18:29:39 | ID: 103262

Answer this question

Chris, Northumberland

Ford Transit Connect

I've done head gasket on my ford connect 1.8 tddi 2002 I got it running again,had to put four new glow plugs in for some reason all four stop working the problem I've got is rev counter speedo miles display and interior light not working glow light won't come on the clocks and battery light won't come on clocks aswell,glow plugs work fine fuel gauge works airbag light comes on hand break light works and back light on clocks is on all the time with key out so take leads off battery please help

Submitted: 05/09/2014 18:21:52 | ID: 102662

Answer this question

paulthomas, Stoke-on-Trent

Ford Transit Connect

Where is waterpump..and how differcult to replace myself

Submitted: 30/08/2014 23:32:28 | ID: 102405

Answer this question

james boyle, West Midlands

Ford Transit Connect

hi there my van runs ok but soon as you drive it the temp goes up and when you pull up and try to restart it turns but wont start then after a couple of hours it ok and will start ,ive changed crank shaft sensor cylinder head sensor oil switch sensor glow plugs /egr valve and its had a full service im baffled

Submitted: 25/08/2014 16:37:30 | ID: 102101

Answer this question

Joe, Antrim

Ford Transit Connect

Hi there. I’ve got a 2003 Ford Transit Connect and the battery sometimes goes flat overnight. I’ve checked the alternator and that’s charging the battery okay and I’ve had the battery tested and that’s okay, but I’ve noticed the digital clock, mileage and trip mileage are staying on. Is this normal with the key removed from the ignition?

Answers

Hi Joe. Chances are the battery will have a dead cell which does not reveal itself with a multi meter which will show 12.5 volts. Yes my dash display stays on but does not sap the battery. A healthy battery under load should show 14.5 volts. 13.5 will be a duff cell. No ignition light glowing i presume. This is a common fault caused by the wiring loom section from alternator rooted up round the radiator to multi plug. Easy to replace. Does this help you. Regards Dave. Dave Bramley from Lincolnshire

Submitted: 21/08/2014 17:13:45 | ID: 101882

Answer this question