FORD MONDEO questions and answers

FORD Mondeo

Ask and answer questions on a variety of FORD MONDEO models. Help and advice on everything FORD MONDEO. Feel free to ask and answer as many FORD-related questions as you wish.

Ask a question now

Buy used imageBuy new / nearly new imageContract hire image

Search the questions and answers section:

Below are the latest FORD MONDEO questions submitted by visitors to RoadTestReports.co.uk. To supply an answer, simply click on the "Answer this question" link underneath each question. Alternatively, if you want to ask a question, please use this simple form. Please try to make the question as detailed as possible, with all the information necessary for a comprehensive answer included. Please do not use "text speech" or type everything in CAPS LOCK.

jack houston, Antrim

Ford Mondeo

Heater Blower Motor FORD MONDEO 1.8 Edge . Bearings have been affected by water ingress from ,faulty pollen filter seal.water has dried out the lubricant in the bearings and now the motor squeeks when switched on. Do I try to replace bearings or the complete motor.

Submitted: 30/01/2015 23:58:50 | ID: 110604

Answer this question

dave, Derbyshire

Ford Mondeo

Hi. I have whiring sound that sonetimes gets louder when when car moving sounds at front of car . I had bairing done thinking was that but continues. Could it be as simple as as a tyre. As the guy I bought it from replaced tyre or am I grasping at straws . Any feedback I woyld be very greatful for. Thanks

Submitted: 28/01/2015 21:21:19 | ID: 110450

Answer this question

Jim graingr, City of Derby

Ford Mondeo

Hi I have a 2009 1.8 edge tdci. my car alarm has started going off at all hours night n day (01:30 this morning) I've replaced the main car battery as I was advised this was the cause but to no effect anyone got any advise before I have to resort to dealer visit?? Cheers jim

Submitted: 26/01/2015 07:25:32 | ID: 110297

Answer this question

Ian Clarke, South Yorkshire

Ford Mondeo

Filled the car today and the "miles remaining" display showe 808 miles remaining - this number is usually 670 miles.Having travelled 56 miles the number displayed is now 820 miles and i noticed a rapid climb in the outside temperature from 3 degrees to 14 and then a rapid drop back down to 5 degrees.Is this a technical problem and are the two issues related?

Submitted: 20/01/2015 19:20:58 | ID: 109969

Answer this question

jeffrey page, West Yorkshire

Ford Mondeo

no pressure on my clutch pedal ,will select gear when engine is not running. but nothing when engine is running.has my clutch gone,i dont know if it has a clutch cable or not. help please,

Submitted: 17/01/2015 15:34:27 | ID: 109725

Answer this question

william duff, Fife

Ford Mondeo

9 strathenry place Would a weak or low battery cause my mondeo to cut out whilst driving. Car restarted and cut out again in idle mode after 20 seconds. Tried again nothing at all , battery dead. When turning on ignition guages speedo etc went over to max for 2 0r 3 secs then dropped back. Would a weak battery cause this?

Submitted: 16/01/2015 11:16:14 | ID: 109659

Answer this question

perry mcbride, Northamptonshire

Ford Mondeo

I have a mondeo 1.8 lx petrol duratec engine 16 valve injection and recently i ran the tank dry and sucked all the debris from bottom of tank and now i am losing power when using gears from 1 thru to 5 and i get a shuddering motion on the revs when changing gear. i have replaced the fuel filter and today i replaced the spark plugs with new ones , the two centre piston chamber spark plugs were covered in wet oil but the one at either side were good. the car is running like it is misfiring and feels like it is losing compression but have not done a test yet. have not checked injectors or coil wires or coil itself. is my engine done ? can anyone help please...

Submitted: 13/01/2015 16:12:49 | ID: 109473

Answer this question

Shabz, Greater London

Ford Mondeo

What be the reason why my car heater heat is really really hot? Even if I lower the resistant it stills blows really hot heat! Please advise?

Submitted: 09/01/2015 19:18:40 | ID: 109235

Answer this question

Daniel, Bedfordshire

Ford Mondeo

Hi all, the central Locking won`t work on the key fob but will work with the key in the door. I have changed the batteries in both fobs and still nothing. Does anyone know what is wrong?

Submitted: 05/01/2015 08:53:58 | ID: 108933

Answer this question

rebecca, Merseyside

Ford Mondeo

my mondeo driving fine then all of a sudden it just cut off. no spark from spark plugs when checked. what could be the cause. when you try and start it spins over until battery dies tried jumpstart it will not start just spinning could some one help please!!!

Answers

Personally I don`t know, but I do know I`m having the same issues. Car was misfiring last night and this morning will not start. I`ve tried new spark plugs, coil leads and coilpack but still no spark. Fuel is getting to the engine, isn`t the problem either. I`m thinking in my case the ecu, but if you figure it out any help would be appreciated. Thanks Gav from West Yorkshire

Submitted: 30/12/2014 21:05:06 | ID: 108653

Answer this question

Craig, West Yorkshire

Ford Mondeo

I just bought a ford Mondeo zetec sport 2010 (60 plate) new shape 1.8tdci 6 speed (duratec engine) and car drives well, infact I believe it drives as it should but I couldant help but notice the other day I were driving along without the radio on and when accelerating in 3rd gear and maybe 2nd i could ear a deep vibrating sound but no vibrating or shuddering it is quite a faint sound and clearly not that noticeable when radio is on quite low at talking levels I mean, I usually change gear between 1500-2000 rpm but the sound when putting my foot down it just ain't there no more, Am I changing too early or is the car telling me something is wrong or is this normal, no warning lights or anything on the dash and no loss of speed or acceleration... It's my first diesel car too I have had petrol cars in the past Milage is just over 119000 it's had new belts on and a few other parts replaced by the garage I bought it from...can anyone give me any good news or not lol? Thanks in advance.

Submitted: 23/12/2014 10:24:31 | ID: 108318

Answer this question

Wayne salmon, Southampton

Ford Mondeo

I have a 1800 52 plate Zetec mondeo the temperature gauge takes quite a while before it gets to its central position where a year ago it would reach its central postion within a minute or so would like some feed back if possible

Submitted: 13/12/2014 20:42:34 | ID: 107860

Answer this question

Malvern, Zimbabwe

Ford Mondeo

My ford mondeo mk3 duratec engine makes a grinding sound every time i start it in the morning. This sound also comes when I start it after parking it for a long time, during the day. The sound often disappears after running it for for about 15 to 20 minutes. Any idea what this could be?

Submitted: 13/12/2014 13:53:47 | ID: 107846

Answer this question

Gaz, City of Derby

Ford Mondeo

How many bolts hold the exhaust manifold to the head ? I can only find 6 but I'm not sure if there should be 8.

Submitted: 06/12/2014 22:21:55 | ID: 107491

Answer this question

Andy perry, West Midlands

Ford Mondeo

Battery keeps dying on me I've fitted a new battery but its also died..

Submitted: 03/12/2014 20:10:39 | ID: 107341

Answer this question

scott harding, West Midlands

Ford Mondeo

Hi Strange one for me. The temp sensor on dash rises to over halfway but only when headlights are on? Turn them off and its fine!! Ive recently had to have some work done yo head gasket but this issue was happening before hand. Ive replaced thermostat and sensor. The temp will rise high with ign off but the lights still on. I have noticed high amounts of condensation coming out the exhaust too while stationary en hoping that the gasket hasnt gone completely!! Any help on this would be great

Submitted: 01/12/2014 01:41:37 | ID: 107169

Answer this question

richard quinton, Essex

Ford Mondeo

The second bulbs on low beam have stopped working on both sides I have changed the bulbs but no luck

Submitted: 26/11/2014 22:52:59 | ID: 106959

Answer this question

Peter, Worcestershire

Ford Mondeo

8 Birchfield Road Hi I have driven my Mondeo for the last 3 years with no major problems, mileage is now approx 90,000 miles. I now have a starting problem; on turning the key the engine fires up normally and idles at 800rpm as normal, but the rev counter does not respond, the engine warning icon lights up and the engine dies after a few seconds. After several attempts the engine finally starts normally, and runs ok from then on. I have now found that applying a gentle amount of throttle after it first fires up can often keep the engine running long enough (a few minutes) for the rev counter etc to work and the engine not to stall.

Submitted: 21/11/2014 12:58:04 | ID: 106596

Answer this question

alan miller, Telford and Wrekin

Ford Mondeo

Fitted slav cyl, won`t bleed up?

Submitted: 16/11/2014 14:49:39 | ID: 106277

Answer this question

rob, Bournemouth

Ford Mondeo

Hey, got a couple of problems 1. I have a battery warning light on the dash board but nothing wrong with the battery when car off the battery is 12.6 when engine running it's 14.5 and there's no loss so i know its being charged any ideas? 2. Simple fix I'm sure but I have both a red snow flake all the time and no outside temp reading and an airbag light cos these came on at the same time I think it's the sensors behind the bumper any other ideas Cheers

Submitted: 16/11/2014 11:15:31 | ID: 106267

Answer this question

Chastity, New Zealand

Ford Mondeo

Hi, as of the last few weeks my Ford Mondeo has been been studdering and sucking up large amounts of fuel. Have checked the spark plugs but these seem fine. Would you be able to help me identify the cause for this problem? I'd appreciate any help given, thankyou. Chastity Te Rangi

Submitted: 15/11/2014 02:52:19 | ID: 106235

Answer this question

alec, Essex

Ford Mondeo

I have a 2 ltr tdci 140 Mondeo Edge and the engine management light is on and the indication is that the dpf is blocked. Will this stop the cruise control from working? Best regards, Alec

Submitted: 13/11/2014 13:52:29 | ID: 106160

Answer this question

l worthington, Staffordshire

Ford Mondeo

Is there a cam belt or chain?

Answers

It depends on the year and model of your Mondeo? alec from Essex

Submitted: 03/11/2014 17:01:38 | ID: 105616

Answer this question

Phil, North Yorkshire

Ford Mondeo

When accelerating I have a whining sound when in low gears when at speed don't hear the noise.

Submitted: 02/11/2014 22:53:37 | ID: 105540

Answer this question

Dave, New Zealand

Ford Mondeo

Hi. My 2001 2.0 Zetec Mondeo has within the past few weeks gone from showing less then 1/4 on gauge to showing 1/4 after 10min and then shows 1/2 after another 5 min. that's as high as it goes. There is plenty of hot air and turning the heater on doesn't change the indicated temp. What is a normal operating gauge indication. I was thinking that maybe the thermostat had been stuck open and now it has started operating correctly, but I don't know what normal is.

Submitted: 01/11/2014 18:37:08 | ID: 105471

Answer this question

Neil evans, Rhondda Cynon Taf

Ford Mondeo

My car wont rev past a certain point it just judders like its not getting enough fuel ?a friend of mine has plugged it in to a fault finder and it showed a fuel pressure code. He thinks it may be the particle filter due to using bio fuel from the big supermarkets.any suggestions welcome

Submitted: 29/10/2014 09:16:52 | ID: 105279

Answer this question

Richard, Powys

Ford Mondeo

hi guys I've got a problem my hazard warning lights have come on and won't go off I've checked the switch it's not that I've Unlocked and re locked car and still on let it run and tick over a bit and still on, any solutions?

Submitted: 20/10/2014 20:56:04 | ID: 104921

Answer this question

don hendry, Lancashire

Ford Mondeo

abs light staying on when running and then goes off next time i start up .done 68,000 miles

Submitted: 20/10/2014 13:25:53 | ID: 104896

Answer this question

Egan, South Africa

Ford Mondeo

i have a 2000 model ford mondeo, the whipers can't switch off eventhough its switch off by the whiper switch

Submitted: 17/10/2014 17:00:03 | ID: 104776

Answer this question

Paul, Kent

Ford Mondeo

I've recently bought a 2000 mondeo Verona.there are 2 things that I'm wondering,firstly the temp gauge stays at about a third of way up when keys aren't in the ignition then when start it it goes to lowest point,after a couple of minutes it'll go to about a third of way up again but no higher or lower even if sitting in traffic etc?also the petrol gauge reads the correct amount of fuel [i think] but also stays in position of the amount of fuel have when no keys are in ignition?are these normal only I'd presume they'd go to lowest point on dials when not running

Submitted: 15/10/2014 20:07:55 | ID: 104662

Answer this question

shane murphy, Kent

Ford Mondeo

Hello ive got a Mondeo 1.8td on a v-reg 1999 and when its on tick over it chucks out loads of smoke then when you drive it it chucks out lots of bluey/white smoke,it misfires on tick over,its only really done this since a friend told me to put "diesel magic" in it any clues anybody.........thanks

Submitted: 12/10/2014 13:42:59 | ID: 104491

Answer this question

norman boston, County Down

Ford Mondeo

Clutch fluid keeps dropping slowly and clutch pedal stays down on the floor and has to be lifted by foot or hand. Eventually the fluid gets too low, pedal won't stay up again and clutch cannot be operated. No sign of fluid leaks and slave cylinder is inside bell housing. Would appreciate any help.

Answers

It will be the slave cylinder. Had the same problem. As it is a big job removing the gearbox,, you should replace clutch and DMF at the same time. Iain McDonald from North Ayrshire

It will be the slave cylinder. Had the same problem. As it is a big job removing the gearbox,, you should replace clutch and DMF at the same time. Iain McDonald from North Ayrshire

Submitted: 02/10/2014 22:52:05 | ID: 103983

Answer this question

Andre, Bournemouth

Ford Mondeo

Hi, I just bought a Mondeo 2010 plate,and I decovered something strange with the lights.First of all the parking lights didn't work and in the dash was the sign of parking lights when turn them on,and when turn to the main beam,the same parking lights sign remained in the dash. Now I replaced the bulbs of parking lights and they are working correctly,but when I change into the main beam,the same problem,the parking lights sign stays in the dash. Can someone tell me any advices?

Submitted: 02/10/2014 21:17:26 | ID: 103975

Answer this question

danny, Middlesex

Ford Mondeo

Hi, just wanted know if anybody would know why the earth strap from the battery to the gearbox would get really hot to the point that it melts away the insulation around the cable?

Submitted: 27/09/2014 12:22:08 | ID: 103709

Answer this question

john, Ireland

Ford Mondeo

Hi. My Mondeo runs ok for a while but when it`s warm like stuck in traffic after that it`s very sluggish and if you try a long drive it`s like it`s running out of fuel. It will slow down to 30k or so on hils, it`s a nightmare but it doesn`t cut out, it ticks over fine. Is it a fuel pump problem? Can anyone help please?

Submitted: 20/09/2014 14:57:41 | ID: 103369

Answer this question

morris braybrooke, Suffolk

Ford Mondeo

Hi, I have a 2011 Ford Mondeo 2.0 tdci Titanium Estate car. Today I filled the car up with £80 worth of diesel and noticed the fuel gauge still stayed on empty. Could you please let me know how to correct/solve this problem? Kind regards MB

Submitted: 18/09/2014 22:46:16 | ID: 103274

Answer this question

Anders Björklund, Angus

Ford Mondeo

hi i have a mondeo 2003 duratec and it misfire cyl4 and i try to connect with the engifte computer but it says no contact with the ecm. After i tried to connect i should do a compression test but then the starter didnt workshop and the throttle had a loud noise. Then i disconnet the ecm and reconnect it again and the starter workshop again. Tok a compression test and it was good so i mounted the sparks and the started the engifte and Now its cyl 2 misfire. Ive tried to disconnet ecm again but its still cyl 2 Now WHO misfire. I have tried with new ignition coil injectors spark plug ignition leads. Any solutions or thoughts about it?

Submitted: 04/09/2014 19:12:45 | ID: 102612

Answer this question

Gill, France

Ford Mondeo

Hi, my Mondeo has an intermittent problem. The red or yellow snowflake symbol appears on the dash when it's 30°C+ The temp readout will say it's -34°C which gradually increases to +4°C. The air con will sometimes work when this happens and sometimes it doesn't....help please!! Ford dealer have recharged the aircon, and failed to find the cause of the problem, is there not a simple diagnostic they can do?

Answers

The outside temperature gauge is loose and hitting the metal of your car causing this red/yellow snowflake to appear. Easy fix, the gauge is situated underneath the front bumper driver`s side at the grill area (it just hooks back on (can be tricky though). It`s a pain as it causes the front/rear screens to heat automatically as it thinks the car temperture is below 4 c scott from City of Edinburgh

Submitted: 22/08/2014 16:16:15 | ID: 101940

Answer this question

howard6040, North Yorkshire

Ford Mondeo

Hi, I do quite a lot of caravan towing including going to France/Spain in the summer months. Various caravanners have suggested I fit a second oil cooler, particularly because my Mondeo is automatic. Also same people recommend changing transmission fluid every 2 years. Has anyone any views on these points? Thanks

Submitted: 19/08/2014 20:55:51 | ID: 101786

Answer this question

John melia, Merseyside

Ford Mondeo

Hi. I`ve got a 2009 Modeo hatchback and want to purchase leather seats but the seats that I`ve found are from a 2004 saloon Mondeo. Could it be possible that these could fit my car?

Submitted: 19/08/2014 16:03:51 | ID: 101765

Answer this question