FORD MONDEO questions and answers

Ask and answer questions on a variety of FORD MONDEO models. Help and advice on everything FORD MONDEO. Feel free to ask and answer as many FORD-related questions as you wish.

Ask a question now


Search the questions and answers section:

Below are the latest FORD MONDEO questions submitted by visitors to RoadTestReports.co.uk. To supply an answer, simply click on the "Answer this question" link underneath each question. Alternatively, if you want to ask a question, please use this simple form. Please try to make the question as detailed as possible, with all the information necessary for a comprehensive answer included. Please do not use "text speech" or type everything in CAPS LOCK.

Jason Scott, East Sussex

Ford Mondeo

My "engine malfuntion " warning light came on, during a journey. It was amber, and i managed to get home. The problem was a loss of power, especially going up hill. What could be the cause of that ?

Submitted: 27/03/2017 10:12:02 | ID: 140184

Answer this question

CHRIS CAIRNS, County Tyrone

Ford Mondeo

How does fan belt go on

Submitted: 19/03/2017 21:56:27 | ID: 140011

Answer this question

Stuart, Dorset

Ford Mondeo

Mondeo 1999 2.0 ltr SI, with difficulties from exhaust gas regulator, I believe. Car starts and idles ok! But when I move off after about 3-400 yes engine seems to drop off slightly in speed and To maintain same speed I have to increase revs. Within a short distance the car starts to kangaroo as though there is a fuel problem. When I stop on three occasions I have noticed that one of the rubber hoses that seem to run eventually to the PP-GF30 Exhaust Gas recycling regulator has blown off. ( Ford part no.1053801) It seems after this to be difficult to get above 2500 - 3000 rpm and I have had to replace the rubber hose from the exhaust to the EGR because it was beginning to break from heat generated. The car is in overall good condition and has been a real delight when it runs properly. Surprisingly even with these problems it has gone through an MOT and is therefore good foe another 12 months. Apart from scrapping it has anyone got anyone got any suggestions as to remedial action, that might be effective in restoring my SI

Submitted: 17/03/2017 15:03:26 | ID: 139935

Answer this question

John Stewart, Angus

Ford Mondeo

On initial start up first thing in morning there is a chirping sound from the engine. This sound only happens if the engine has been switched off for 6 hours or longer. Would appreciate any comments on what this can be and if it is serious to continue driving my car.

Answers

Could be a leak from the exhaust manifold, possible one of the gaskets has gone or is missing. Hugh from City of Glasgow

Submitted: 07/03/2017 12:14:32 | ID: 139577

Answer this question

Bob baldock, Surrey

Ford Mondeo

I have replaced the fuel pump and filter and as told the pump was faulty but it sounds as though the pump is not working any idea's

Submitted: 26/02/2017 13:41:50 | ID: 139207

Answer this question

Ray, Essex

Ford Mondeo

I've been having problems with the car jumping then starts to cut out I've change the spark plugs no change any idea wht this could be

Submitted: 21/02/2017 09:15:29 | ID: 139085

Answer this question

Amran Janjua, South Yorkshire

Ford Mondeo

Hi I have a Ford Mondeo 62 plate and few questions. As like the ford Focus & Cmax 62 plates onwards when you look the cars with remotes the headlights stay on for 30 seconds before going off which is normal. My Mondeo does not do this neither on opening or locking. Are the light supposed to stay on for 15/30 seconds upon locking & opening my Mondeo?

Submitted: 10/02/2017 14:32:16 | ID: 138861

Answer this question

Tony Crome, Devon

Ford Mondeo

When I indicate right , a beeping alarm sounds , in time with the indicator . Indicating left is fine . Checked bulbs , they are flashing . When I have dipped headlights it doesn't happen .

Answers

Is your car fitted with a towbar & electrics? If so it might have an indicator warning buzzer fitted which could be faulty if it's operating when a trailer isn't plugged in. Mick from Portugal

Submitted: 03/02/2017 14:52:34 | ID: 138641

Answer this question

mick, Hampshire

Ford Mondeo

ford mondeo 2.0ltr 2001 abs light comes on when you switch on any instrument then engine stalls and will not turn engine over

Submitted: 25/01/2017 08:33:57 | ID: 138388

Answer this question

Sandro Centola, Midlothian

Ford Mondeo

my battery light kept coming on and off in my 2004 130bhp ford mondeo,my mechanic told me it was alternator problem.i had no problem with the car starting but in new years day a burning smell was coming through and i could see my windscreen wipers and heater going very slow. i went to my sister in law's house and when i came out my car would not start.put battery charger on for 20 minutes and still would not start.tried to jump start and still nothing,called in AA and charged battery with booster for about 20 minutes and still would not start.towed car to my mechanic and on the 3 of January got new alternator not put on as my mechanic cannot get the car going to see what is going on, he is saying to me now that it could be engine problem. on forums what i am getting back seems to be ecu or smart manager loom.any advice please i hope it not engine problem

Submitted: 08/01/2017 16:11:16 | ID: 137937

Answer this question

Sandro Centola, Midlothian

Ford Mondeo

my battery light kept coming on and off in my 2004 130bhp ford mondeo,my mechanic told me it was alternator problem.i had no problem with the car starting but in new years day a burning smell was coming through and i could see my windscreen wipers and heater going very slow. i went to my sister in law's house and when i came out my car would not start.put battery charger on for 20 minutes and still would not start.tried to jump start and still nothing,called in AA and charged battery with booster for about 20 minutes and still would not start.towed car to my mechanic and on the 3 of January got new alternator not put on as my mechanic cannot get the car going to see what is going on, he is saying to me now that it could be engine problem. on forums what i am getting back seems to be ecu or smart manager loom.any advice please i hope it not engine problem

Submitted: 08/01/2017 16:04:53 | ID: 137936

Answer this question

Mihail, Norfolk

Ford Mondeo

Hello.cylinder 1 fail to start and car is working on 3 cylinders,smells strong of petrol from exhaust and have no power. Car starts from everytime and mooving. Sometimes on high rpm power kicks in.have some nasty knocking from engine but very quiet, only when car is on neutral gear.someone have idea what could be the problem? Thank you.

Submitted: 07/01/2017 00:32:21 | ID: 137884

Answer this question

Ben, West Midlands

Ford Mondeo

Can you tell me if there is some kind of bearings, by the steering wheel, because she. I start the engine, I hear s churning like noise? Thanks

Submitted: 05/01/2017 21:38:03 | ID: 137849

Answer this question

john, Hertfordshire

Ford Mondeo

when using my ignitionkey the lights on dashboard work but engine wont fire normally takes 4or5 goes

Submitted: 01/01/2017 13:33:50 | ID: 137707

Answer this question

dave hillyard, Durham

Ford Mondeo

when i start the engine up all the lights go out except the battery and engine management lights they stay on for about 20 seconds and while they are on i can't do anything when they go off i can then drive away. also when driving at low revs between 1000 and 1500 the battery light comes on i have to stop the engine and restart to take battery light off i had a new allternator fitted recently this problem has started since then

Submitted: 07/12/2016 11:10:26 | ID: 137220

Answer this question

Hugh, Warwickshire

Ford Mondeo

My mondeo 51 plate keeps stalling at 2000 revs and steering wheel locks up, the engine management light has come on also, it drives but only below 2000 revs any ideas what the problem could be, thanks.

Submitted: 26/11/2016 17:40:51 | ID: 136977

Answer this question

kris maguire, Dorset

Ford Mondeo

Hi Just had a clutch fitted and now runs very loud any ideas. Thanks Kris

Answers

Check the rubber seals on firewall around the steering shaft, brake pedal. martin from Flintshire

Submitted: 20/11/2016 12:19:08 | ID: 136816

Answer this question

julie, Greater Manchester

Ford Mondeo

Hi I have a Mondeo 58 plate. Last night whilst out driving the dashboard lit up with all the symbols on it. Ie engine light. Seat belt light does ext for a few seconds then went off. The power in the car didn't change out the head lights didn't dip but the mileage gage that tells you how much petrol you have changed to temperature of 54 f.. Could anyone let me know if they have had this problem and is the car safe to drive as I don't know what's wrong.

Submitted: 30/10/2016 18:18:50 | ID: 136368

Answer this question

Howard, Nottinghamshire

Ford Mondeo

On start up and during the first couple of miles engine sluggish when depressing accelerator, any ideas.

Submitted: 16/10/2016 14:47:10 | ID: 135997

Answer this question

Arye, Israel

Ford Mondeo

I have three questions, please: 1. There are two thick pipes that are connected to the upper area of the expansion tank. One is above the other. One comes from the input of the radiator, the second comes from the bottom of the engine. Does it matter what pipe is above the other? 2. The pipe that comes from the input of the radiator, it seems to me that it bypasses the radiator, is always cold or much colder than the other pipes in the system. Is it OK? If it is not, what should I do? 3. The fan starts to run when the coolant is 107 Celsius. I am afraid that it is too high. The coolant goes to 108 Celsius, the fan starts to run and the temperature drops to 100 - 102 Celsius, warming again to 108 and so on. Thank you very much, Arye

Submitted: 07/10/2016 12:30:47 | ID: 135773

Answer this question

thorpe, Hartlepool

Ford Mondeo

headlights stay on when started up horn not working heater blowers not working front and rear fog lights not working front screen demister not working headlight adjuster not working

Submitted: 13/09/2016 21:26:24 | ID: 135164

Answer this question

thorpe, Hartlepool

Ford Mondeo

when turning ignition on headlights come on and stay on until car is turned off also heater blowers don't work horn does not work front and rear fog lights don't work front screen demister not working and headlight adjusteralso not working

Submitted: 13/09/2016 20:59:36 | ID: 135160

Answer this question

Chris, Essex

Ford Mondeo

I have started using 5w30 fully synthetic oil and am using quite a lot..will using part synthetic burn off slower and can I change to 10w40 now the car has done 110000?

Submitted: 16/08/2016 19:20:16 | ID: 134405

Answer this question

Andrew, South Yorkshire

Ford Mondeo

Hi this an intermittent fault fan comes on while driving and the car when you come to a stop the car stops running. Turn it all off and then restart and runs ok can any one help please

Submitted: 09/08/2016 14:15:36 | ID: 134226

Answer this question

Lynn Whyte-Heath, Surrey

Ford Mondeo

There was a problem with the gear-box which is now fixed, this caused the engine to close down and now we are unable to get the revs to come up again, will only do 30mph uphill. anybody?

Submitted: 08/07/2016 22:40:07 | ID: 133355

Answer this question

Simon haworth, Kent

Ford Mondeo

I have just fitted a new fuel pump and new filter n car still start

Submitted: 01/07/2016 14:17:02 | ID: 133167

Answer this question

iulian, Norfolk

Ford Mondeo

hi i have a ford mondeo 53 plate lx 2.0 tdci my problem is i start the engine and the airconditioning stay on the function to swich off is not working... what can be?

Submitted: 21/06/2016 15:17:17 | ID: 132847

Answer this question

Janette Davies , Wiltshire

Ford Mondeo

My seat belt holder, drivers side, I am having a problem with - the seat belt won't stay in the holder. How do I take the holder out hand replace it? Thanks

Submitted: 30/05/2016 19:32:23 | ID: 132165

Answer this question

andrewhsmith@sky.com, Hertfordshire

Ford Mondeo

The car alarm keeps coming on after a hot day when it 'cools' in the evening. All the doors are closed and windows fully up, NO obstruction to the boot. I heard it can be an issue with latch assembly on the bonnet which has a sensor? Any ideas how to turn off the alarm or disable permanently without immobilising the car and spending loads?

Submitted: 12/05/2016 15:01:41 | ID: 131447

Answer this question

Ann Nelson, Greater London

Ford Mondeo

Registration isw61 wgb. Have had a new rocker cover put on and topped up with oil. Since taking the car out of the garage it is vibrating as soon as I turn the ignition on and feels like the whole car is vibrating as I am driving. Please could you give me any advice as to what this could be. Please help. Kind regards Ann Nelson

Submitted: 08/05/2016 16:16:37 | ID: 131314

Answer this question

Mariusz, Medway

Ford Mondeo

How to change motor blower fan mondeo ml4 2008 tdci??

Submitted: 24/04/2016 14:56:28 | ID: 130763

Answer this question

Lloyd, Essex

Ford Mondeo

Hi- Ihave a mondeo mk2 2.0 16v zetec..at around 1500-2000 revs- about 45-50 mph,it starts missing. I've replaced coil pack,leads,plugs,etc,but still does it. I've been told that it could be fuel sensor,then someone else told me they rarely go wrong. Also,on start up when it's warm,it revs to about 1500 revs,then drops really low-almost stops,then revs again,then drops,then idles normally-any ideas?

Submitted: 23/04/2016 21:51:16 | ID: 130742

Answer this question

SIAN, Essex

Ford Mondeo

The cigarette lighters in the car stopped working, I Finally located the fuse for the cigarette lighter it is okay. So why is there no power if the fuse is okay?

Submitted: 21/04/2016 16:30:17 | ID: 130661

Answer this question

Tony, Warrington

Ford Mondeo

Engine management light has come on , car starts and runs ok but offside rear wheel bearing noisey, can this cause engine manage Ment light to come on

Submitted: 21/04/2016 11:13:35 | ID: 130651

Answer this question

Tony, Greater London

Ford Mondeo

Car has just started to idle at 11000 revs and when I press throttle it goes up to3000 revs and takes a long time to drop back

Submitted: 13/04/2016 17:12:48 | ID: 130346

Answer this question

Dean, Laois

Ford Mondeo

My car is making a ratiling noise when i rev the car just over 2 rpm and when im driving it goin true the gears plz help

Submitted: 04/04/2016 23:55:09 | ID: 129956

Answer this question

Dean, Laois

Ford Mondeo

Mondeo making a rattil noise when revving

Submitted: 04/04/2016 23:47:56 | ID: 129955

Answer this question

Linda Warren, Hertfordshire

Ford Mondeo

Heater hose blew off, steam coming from under bonnet , car did not overheat, (thermostat is ok) been advised to have water pump checked, although computer showed no sign of trouble with the water pump...are there any other symptoms which would tell me what caused this please... many thanks...

Answers

Linda, there could be a blockage somewhere but there could also be a problem with the water pump.. thing is.. garages say "didn't show up on the diagnostics"... well.. a water pump is mechanical and a fault in it won't necessarily show up on electronic diagnostics... there has been a tendency lately for people to consider the computer diagnostics as the dogs thingies.. and it can be.. in the right situation. You may still have issue with water pump. However, pressure building up high enough in cooling system to blow a hose potentially could be a sign of head gasket failure.. the high pressures built up in cylinders leaking into the cooling channels which are very close by. R Evans from Caerphilly

Submitted: 23/03/2016 17:21:08 | ID: 129375

Answer this question

Rachel Fife, New Zealand

Ford Mondeo

The cooling fans are not working on my Mondeo and it is overheating. Have checked fuses and they are fine. Before the fans stopped working I had noticed that when the fan was working it was very loud

Answers

Rachel, it sounds like the bearings in the fan may have gone. with the engine off.. try manually turning the fan blade around and see how much resistance there is.. if it grinds and/or shows resistance to turning then that's it. The fan should turn around freely and smoothly. R Evans from Caerphilly

Submitted: 17/03/2016 05:05:22 | ID: 129111

Answer this question

Michael, Surrey

Ford Mondeo

Hi there iv got a Ford Mondeo 58 plate desal 1.8 tci and every time I try to start it all the lights come on as normal on the dash but it just clicks and some times does not click at all or I have to walk away but if I put the clutch down and in or not in gear it starts well some times takes 3 or 4 times and a plume of smoke comes out and it's good to go but when I stop and try and start I could be doing all that again for 2min or 10mins or walk away. Please could some one help me as iv been told 101 different things by car mechanics...

Submitted: 14/03/2016 19:29:57 | ID: 129013

Answer this question