CITROEN XSARA PICASSO questions and answers

CITROEN Xsara Picasso

Ask and answer questions on a variety of CITROEN XSARA PICASSO models. Help and advice on everything CITROEN XSARA PICASSO. Feel free to ask and answer as many CITROEN-related questions as you wish.

Ask a question now

Buy used imageBuy new / nearly new imageContract hire image

Search the questions and answers section:

Below are the latest CITROEN XSARA PICASSO questions submitted by visitors to RoadTestReports.co.uk. To supply an answer, simply click on the "Answer this question" link underneath each question. Alternatively, if you want to ask a question, please use this simple form. Please try to make the question as detailed as possible, with all the information necessary for a comprehensive answer included. Please do not use "text speech" or type everything in CAPS LOCK.

MD, Lincolnshire

Citroen Xsara Picasso

Is there a high beam on the xsara Picasso? Because the low and high beam symbol are on the same level on the switch. When I try to put the high the low beam symbol appears dashboard. So slightly confused.

Submitted: 19/12/2014 21:14:13 | ID: 108150

Answer this question

John, Durham

Citroen Xsara Picasso

Hi, can anyone help? For some reason my headlight bulb keeps blowing. I can change it nearly every 4-5 weeks. Has anyone else had this problem? Thanks

Submitted: 11/12/2014 06:38:11 | ID: 107711

Answer this question

Wendy, Norfolk

Citroen Xsara Picasso

My car starts but I have nothing showing on my dashboard what so ever. It was working fine one day then when my husband went to drive it there was nothing showing. What could the problem be please??

Submitted: 09/12/2014 21:42:11 | ID: 107647

Answer this question

Mark Hope, North Lincolnshire

Citroen Xsara Picasso

When I start my car the running is fine for about 5 miles, then as soon as the engine warms up the car revs really high and there is little power in the engine, until running at a reasonable speed. Any advise before I take it into a garage I dont want to get ripped off.

Submitted: 08/12/2014 22:42:07 | ID: 107580

Answer this question

Tony, Lancashire

Citroen Xsara Picasso

Is it possible to fit cruise control to the desire model of the Xsara picasso ? will it work if i just fit the CC stalk on the steering column or does it need to be switched on in the brain ?

Submitted: 06/12/2014 22:13:51 | ID: 107490

Answer this question

barry, Blackpool

Citroen Xsara Picasso

my heater only works on no4 setting what do I need to fix the problem

Submitted: 06/12/2014 19:55:56 | ID: 107478

Answer this question

kathy, Northumberland

Citroen Xsara Picasso

Hi, my headlights and side lights right front side stopped working. I took them to a garage to replace. When I now turn them on they work but are dull and fall too short for me to see far in front of me. I have tried the adjust wheel on the dash to the right of the steering column which works but does not lengthen the fall. There are also 2 buttons one with a large headlight and one with a small head light which don,t seem to do anything. Does anyone know what is wrong. Have the bulbs been wrongly adjusted when replaced?

Submitted: 04/12/2014 22:49:59 | ID: 107409

Answer this question

colin ratcliffe, Merseyside

Citroen Xsara Picasso

hi most of the time when I start the car I get a sound like a bell ,like a loud ding alarm sound does any one know what it is please.

Submitted: 04/12/2014 20:11:01 | ID: 107391

Answer this question

Susan cowley, South Yorkshire

Citroen Xsara Picasso

The esp light comes on occasionally . why? Is it dangerous to drive about in ?

Submitted: 03/12/2014 23:00:36 | ID: 107352

Answer this question

Pete, Lancashire

Citroen Xsara Picasso

Can't turn radio on after changing the battery. Headlights come on as soon as car started

Answers

If you diconect the battery you may have to recode your stereo, you should have the code number with your citreon handbooks normally on a little card hope it hellps davemoody from Devon

Submitted: 03/12/2014 21:48:34 | ID: 107349

Answer this question

Mr I.Wakeley, Dorset

Citroen Xsara Picasso

Is there a 16" alloy road wheel from later Citroens that will fit my car, without modifications. This model uses 15" steels.

Submitted: 03/12/2014 08:11:15 | ID: 107301

Answer this question

Steve, Kent

Citroen Xsara Picasso

Hi All hope you can help? I have lost all my side lights and number plate lights on the left side of my car i have changed the fuse and have replaced the stop and tail bulb in the cluster but still no joy. Please can someone help me. regards Steve

Submitted: 01/12/2014 20:22:32 | ID: 107217

Answer this question

ian, West Midlands

Citroen Xsara Picasso

I have just had the can belt and water pump changed on my Picasso. The car now makes a whirring noise while driving through all the gears. It doesn't do it while stationary/ ticking over. Any ideas please?

Answers

Could be that the can belt has been fitted incorrectly.. By that I mean overtightened too much tension on belt wayne from Bristol

Submitted: 29/11/2014 19:45:56 | ID: 107094

Answer this question

paul, Tyne and Wear

Citroen Xsara Picasso

hi i have 54 plate petrol citroen xsara picasso , recently the coil pack knacked up so i changed it and now runs sweet , it also came up with a fault code p0341 which is the camshaft sensor , so i replaced with one from tbe dealer , i reset fault and the light went off , but when i drive for a little bit the fault comes back , so i check it and its the same fault again and again , totaly baffled , an anyone help plz

Submitted: 28/11/2014 01:26:36 | ID: 107020

Answer this question

roy, Hertfordshire

Citroen Xsara Picasso

hi. I have a problem with my 5th gear continuously slipping out when driving at 50mph or more. All it takes is a slight reduction in pressure on the accelerator and out it pops. Have taken it back to the garage and had bushes changed but that has not stopped it at all. Any ideas or similar ?

Submitted: 27/11/2014 11:09:32 | ID: 106975

Answer this question

colin, South Africa

Citroen Xsara Picasso

Hi , my 1.6i petrol Picasso was driving fine apart from the irregular idle when you stop . I parked the car in the garage and when I tried to start it the next morning it was only turning over not starting, I checked the battery and even swapped it but still no starting only turning over. I checked the plug on the ecu but no problems there..... removed the coil pack ,got some white marks around the sparkplug connectors , may coil pack, one more thing , got a airbag fault a week ago. Please help.

Submitted: 26/11/2014 17:51:33 | ID: 106934

Answer this question

Terry, Poole

Citroen Xsara Picasso

Hi I have 05 2l hdi picasso. Have an oil leak from below oil filter. How do I remove oil cooler please

Submitted: 25/11/2014 17:45:47 | ID: 106877

Answer this question

norman stewart, Northumberland

Citroen Xsara Picasso

airbag warning light has come on. dash reads ( airbag fault ) any ideas.

Submitted: 25/11/2014 09:11:17 | ID: 106848

Answer this question

Mogamat Hassiem Arnold, South Africa

Citroen Xsara Picasso

I have a 2003 Citroen Picasso Xsara 2L Diesel HDI The alternator is faulty and has to be replaced. How do I remove the steering pump unit and alternator.

Submitted: 25/11/2014 04:01:45 | ID: 106841

Answer this question

Mogamat Hassiem Arnold, South Africa

Citroen Xsara Picasso

How do I remove the steering pump unit and alternator

Submitted: 24/11/2014 18:42:00 | ID: 106806

Answer this question

Bruce Graham, Leicestershire

Citroen Xsara Picasso

I have a citroen xsara picasso 2.0 HDi Exclusive 5dr. 54 plate. As soon as I unlock the car there is a 5 second wait and the lights come on by them self, the lights will not turn off until I've finished my journey, stopped the engine and locked the car even if it's the day time or night, I wait a minute and the lights go off. Also when I'm driving the heating/fans don't work so I have a misty window for ages and it's freezing! So in a nutshell the lights are on all the time and the heaters don't work. Any advice would be great. Thanks

Submitted: 22/11/2014 12:26:18 | ID: 106657

Answer this question

andrew, West Yorkshire

Citroen Xsara Picasso

Anyone know what the 2.0L Hdi diesel should idle at and how to check it? Thanks

Submitted: 20/11/2014 13:41:43 | ID: 106534

Answer this question

Maria, Berkshire

Citroen Xsara Picasso

My car has a loud ticking and is juddery after not being driven for a few hours, the belt thing that goes round seems to be where the ticking is coming from.

Submitted: 19/11/2014 19:06:23 | ID: 106504

Answer this question

Mauren Laverty, Antrim

Citroen Xsara Picasso

I need to top up water level, I don't know where it goes and I cannot locate my user guide. Can you help?

Submitted: 17/11/2014 20:34:38 | ID: 106362

Answer this question

leeannd8o, Renfrewshire

Citroen Xsara Picasso

My clutch pedal has been rather stiff/sticking recently, it seemed to be ok in neutral first then ok going into 1st etc but I have noticed a metal clapping noise during gear change?? Anyways I reversed parked uphill last nite & there was a bit of a clatter & shudder then the pedal hit the floor ?? Any ideas & suggestions of the cost of this operation as I'm asumuming the clutch has died ??

Submitted: 17/11/2014 12:21:03 | ID: 106337

Answer this question

Edward Wilson, Buckinghamshire

Citroen Xsara Picasso

How can I remove the middle rear seat as the right lug is stuck?

Answers

I had a similar problem, mine turned out to be that the seat had been slid forward. In this position the seat release mechanism doesn't work tony from Lincolnshire

Submitted: 12/11/2014 18:34:03 | ID: 106110

Answer this question

Neil Hayes, Cambridgeshire

Citroen Xsara Picasso

Hi, Hope someone can help me. My front wipers recently started playing up. they would not work every time I turned them on. If they don't work on intermittent or first speed, they often will start if I go straight to second speed, wait a few seconds then reduce there speed. again they are the same when I push the wiper switch down for a one off wipe & again when using the washers. I have already replaced the complete switch gear with one off the internet by the same is still happening. Any ideas please; Thanks. Neil.

Answers

I had same problem checked all fuses none blown had wiper motor checked finally replaced complete wiper mechanism with motor still same fault managed to google a answer and it worked In the car right hand side of steering wheel usually where people put their sunglasses pull the panel off and look for a little grey connector block disconnect wait 15 seconds re-connect job sorted hope this helps this sorted mine Sean from South Yorkshire

I had same problem checked all fuses none blown had wiper motor checked finally replaced complete wiper mechanism with motor still same fault managed to google a answer and it worked In the car right hand side of steering wheel usually where people put their sunglasses pull the panel off and look for a little grey connector block disconnect wait 15 seconds re-connect job sorted hope this helps this sorted mine Sean from South Yorkshire

Sean, thanks for the reply. Is the grey plug the one connected into the BSI box with a red clip holding it in?Did you have to switch on the ignition to power up the box, then reconnect the grey one? Sorry to be a pain. Neil. Neil Hayes from Cambridgeshire

Peugeot Citroen cars have a “B S I” (Body Systems Interface) ECU. This system holds information for immobiliser, mileage display, lighting and many other Peugeot Citroen programmed settings. The software that controls the operation of these systems can become corrupted if the battery has been replaced and the “BSI” has not gone to sleep before disconnection of old battery or been woken up after reconnection of new battery or sometimes for no good reason at all! Think of it as running your laptop on the battery and then removing the battery without shutting it down., not a good idea. The system can be rebooted if a problem has occured so all is not lost. Follow this procedure for the reset (reboot). Have the drivers window fully open. Open the bonnet and make sure all equipment is switched off including interior light. Close all doors and remove key from the ignition. Wait 3 minutes, disconnect the vehicle battery then wait 15 seconds. Reconnect the vehicle battery and wait a further 10 seconds. Switch on the side lights through the driver’s window. Switch on the ignition DO NOT start the engine at this point. Hold the lock button on the key down for 10 seconds while key is still in the ignition. Switch off ignition and remove key open & close door to test central locking system. Start the engine. This is how to reset the BS.I It is worth doing if you have problems with lights,wipers,radio,central locking,starting etc as it only takes a few minutes and can save you ££ Sean from South Yorkshire

: 1. ignition on 2. disconnect grey 6 way plug from comm 2000 3. wait 3-5 seconds then lights come on (mine didn't) 4. switch ignition off and wait 2 minutes 5. reconnect comm grey plug 6. switch ignition on 7. switch ignition off 8. put wiper stalk in auto or intermittent position 9. put wiper switch in off position 10. allow bsi to shut down 2 minutes 11. switch ignition on THIS WORKED ON MINE NEIL NEVER HAD A PROBLEM SINCE THAT WAS 2 yrs ago Sean from South Yorkshire

Sean, thanks so much for your help. I try the grey plug first, if no joy I'll try the BSI reboot. I will post how I get on. Thanks again. Neil. Neil Hayes from Cambridgeshire

Submitted: 12/11/2014 10:32:22 | ID: 106087

Answer this question

Colin, Cambridgeshire

Citroen Xsara Picasso

i have a citroen xsara picasso 2.0 HDi Exclusive i am having to top up my water now every week can anyone please tell me what could be the problem.and how to sort it.

Answers

I had the same thing with mine, it was a coolant leak on the oil cooler hose. If you find the oil filter and look at housing it mounts to, there are 2 hoses that come from it that connect to the coolant system. Mine started with a drip but eventually overheaded due to it becoming a dribble rather than a drip. It was a leak in the fuel pump (Bosch CP1), dripping deisel onto the hose that causing it to corrode. Might want to check for a small fuel leak too! Paul from City of Glasgow

I had the same thing with mine, it was a coolant leak on the oil cooler hose. If you find the oil filter and look at housing it mounts to, there are 2 hoses that come from it that connect to the coolant system. Mine started with a drip but eventually overheaded due to it becoming a dribble rather than a drip. It was a leak in the fuel pump (Bosch CP1), dripping deisel onto the hose that causing it to corrode. Might want to check for a small fuel leak too! Paul from City of Glasgow

Submitted: 11/11/2014 20:46:52 | ID: 106065

Answer this question

Chris Jones, Gwynedd

Citroen Xsara Picasso

The throttle on my Citroen Xsara Picasso 2 litre diesel has become very heavy and the response is not the same as previously. When drive on the motorway even of I press down the throttle on any hills it does not speed up ! Any ideas !

Submitted: 11/11/2014 19:48:31 | ID: 106062

Answer this question

j wajker, City of Nottingham

Citroen Xsara Picasso

When my engine is idling it keeps cutting out. Why is this happening?

Submitted: 11/11/2014 13:48:26 | ID: 106037

Answer this question

Lucille, Tyne and Wear

Citroen Xsara Picasso

After driving a while a squeek develops sometimes louder than other times but squeek not always there, yet will go as I slightly depress brake.Car just passed mot and no brake problem or other problems identified.

Answers

Hi Lucille, brakes do sometimes squeal and it is usually just some dirt or rust. You should notice that it doesn't happen when driving in the wet. Some cars have anti-squeal shims on them to help stop the noise. However, i would always check the brakes to make sure there are no other faults.....better safe than sorry :) Daryl Statham-Waring from Nottinghamshire

Hi Lucille, brakes do sometimes squeal and it is usually just some dirt or rust. You should notice that it doesn't happen when driving in the wet. Some cars have anti-squeal shims on them to help stop the noise. However, i would always check the brakes to make sure there are no other faults.....better safe than sorry :) Daryl Statham-Waring from Nottinghamshire

Submitted: 08/11/2014 11:44:55 | ID: 105882

Answer this question

Martin, Norfolk

Citroen Xsara Picasso

citroen xsara picasso mpv 2004 ,cd radio just fitted beeping sound in speakers

Submitted: 07/11/2014 22:20:33 | ID: 105868

Answer this question

Richard B, Kent

Citroen Xsara Picasso

Hello, I have a 2.0 litre petrol xsara picasso automatic which has a bad misfire midrange. If trying to accelerate uphill from around 30 mph the car shudders and sounds like it's misfiring on at least one cylinder. Also on accelerating from 30-60 on a flat road. Once 60 is reached it runs very sweetly and easily exceeds 70 mph with good fuel economy(around 40 mpg). Generally below 30 it runs perfectly. It's had new coil pack, spark plugs, air filter and mass air flow sensor. It seems a bit slow pulling from standstill to 5 mph but that may just be the auto gearbox . I'm not sure where to look next, replace Mass air flow body, clean throttle body? Any ideas please

Submitted: 07/11/2014 16:56:04 | ID: 105845

Answer this question

david, Malaysia

Citroen Xsara Picasso

Hi, after changing Alternator belt and tensioner . the engine is turning but not starting and the battery light stay on. anybody can help me

Submitted: 07/11/2014 05:00:22 | ID: 105808

Answer this question

Trucker, Bedfordshire

Citroen Xsara Picasso

I was driving down the motorway when the engine cut out and the car rolled to a stop, there was a message saying engine fault and the car wouldn't restart. I sat for 5 minutes and tried to start it, the car started but the engine fault message stayed on along with the management light. On the way home from work 11 hrs later the management light went out and the car seems to be running perfectly again. Can anyone say what may have caused this or if it`s a warning of something expensive that may happen?

Answers

I had the same trouble with my xsara 2 litre diesel a few years back.. I called the AA out and was told it was the fuel pump.. Had rhe pump checked only to be told the fuel pump was working perfectly.. Took it to citroen who said it would cost £700 to fix.. I took it to my local garage who said after a diagnostic check said it was a sensor and charged me ljust over £100 to put it right.. Hope this may help.. Michael from West Midlands

I had the same trouble with my xsara 2 litre diesel a few years back.. I called the AA out and was told it was the fuel pump.. Had rhe pump checked only to be told the fuel pump was working perfectly.. Took it to citroen who said it would cost £700 to fix.. I took it to my local garage who said after a diagnostic check said it was a sensor and charged me ljust over £100 to put it right.. Hope this may help.. Michael from West Midlands

Just had both pumps replaced so the sensor sounds more likely, thanks for your reply - cars running nice again but will get it checked anyway Trucker from Bedfordshire

The same happened to me on the A1, called the AA,mechanic did his tests and said fuel was not reaching the fuel filter so he suspected the fuel pump and towed me to a citroen garage. They put the computer on and the only problem the computer threw up was ....... brake light switch. Now I didnt understand this at first so I went looking for an answer and when you think about it , it actually makes sense. Try work it out, if you cant drop me a line and I`ll explain. Cheers andrew from West Yorkshire

I am not mechanically minded, dont know anything about cars, so if you want to share,..How can we contact you.? Michael from West Midlands

Submitted: 05/11/2014 13:41:44 | ID: 105707

Answer this question

Christine sampson, West Midlands

Citroen Xsara Picasso

544 Penn Road Penn The outside teperature gauge started to go up to 49 degrees this went on for a while now it is blank,is this something we can fix ? many thanks

Submitted: 02/11/2014 19:33:40 | ID: 105531

Answer this question

bob, Essex

Citroen Xsara Picasso

Hi. When i start the engine the head lights come on automatically, is there a control to turn this setting off so I can turn them on manually. Thanks

Submitted: 01/11/2014 17:52:01 | ID: 105469

Answer this question

emlyn kelly, Lincolnshire

Citroen Xsara Picasso

Hello I bought today my picasso and noticed when I pull away in 1st or reverse the front wheels shake. I at first thought maybe I not putting enough revs in but at high revs still shaking any ideas guys as I hoping I not bought a dud ????

Answers

just bought the same car this week,same problem.took it to a friends garage who said it was clutch shudder and should be all right for a while.fingers crossed.they just got burnt with the last car l bought!good luck Jim Easdown from Lancashire

just bought the same car this week,same problem.took it to a friends garage who said it was clutch shudder and should be all right for a while.fingers crossed.they just got burnt with the last car l bought!good luck Jim Easdown from Lancashire

Submitted: 01/11/2014 16:59:28 | ID: 105465

Answer this question

laura, Kent

Citroen Xsara Picasso

My hubby has done a clutch change on our car and now there is no power at all not even central locking, all fuses checked and fine! any ideas????

Answers

Hi Laura, I've just had a clutch change on my xsara and you have to reset the electrics if the battery has been disconnected. Hope this helps Debs debbie from Northamptonshire

Submitted: 01/11/2014 12:33:48 | ID: 105447

Answer this question

Nick, Hertfordshire

Citroen Xsara Picasso

Hi, my heater only works on the 4 setting on the the dial for the blower? is this the relay? if it is , is it easy to change?

Answers

Having the same problem, would welcome any advice.. Michael from West Midlands

Checked online and it says its a common problem with the xsara.. It suggests the 2 main causes are fuses or the resistor... Michael from West Midlands

Had this with mine last year. its to do with the ignition and is a common fault. Ask a local garage to put a bypass thingy in and it will work fine again. The ignition constantly blows the resistor kelly from Durham

Had this with mine last year. its to do with the ignition and is a common fault. Ask a local garage to put a bypass thingy in and it will work fine again. The ignition constantly blows the resistor kelly from Durham

Submitted: 30/10/2014 11:35:52 | ID: 105330

Answer this question