FORD questions and answers: find help and give advice

Ask and answer questions on a variety of FORD models. Help and advice on everything FORD. Feel free to ask and answer as many FORD-related questions as you wish.

Buy used imageBuy new / nearly new imageContract hire image

Search the questions and answers section:

Below are the latest FORD questions answered by visitors to RoadTestReports.co.uk. To supply an answer yourself simply click on the "Answer this question" link underneath each question. Alternatively, if you want to ask a question, simply click on the link below.

Ask a question now

Kevin, City of Glasgow

Ford Kuga

Got a new ford kuga zetec 2.0 diesel (2014) and my lights stay on all the time, is this normal? Looked at my booklet but doesn't tell me anything?

Answers

It sounds like you're lights are on auto , I leave mine on this all the time Steve from Kent

It sounds like you're lights are on auto , I leave mine on this all the time Steve from Kent

Submitted: 09/08/2014 15:36:07 | ID: 101216

Answer this question

Terri, Surrey

Ford C-Max

I have c max zetch 2011 1.6. Recently my DAB radio has stopped working. The message shown on display is "service not available" however, I'm able to pick the radio stations up on FM. The radio is a ford radio not sony. Any ideas? Thanks

Answers

Hi. This has happened to my vehicle, has yours been fixed? Thanks, Mark mark haywood from Nottinghamshire

Submitted: 10/06/2014 21:33:33 | ID: 97384

Answer this question

Carol Edwards, Shropshire

Ford Puma

I can only get hot air even when the fan is turned to cold. Also, there is a clicking noise under the dashboard on the drivers side. Would the two be connected? I would be grateful of any advice. Thanks

Answers

The heater control valve under the plastic at the back of the engine bay has gone, easy to spot because there is four pipes running off it, About £15 to buy Jonathan from Cardiff

Submitted: 01/05/2014 17:19:03 | ID: 94954

Answer this question

Mark, Hampshire

Ford Ka

Hi my mums sport ka over heated , had a water pump fitted , over heated again , then had head gasket done , thremo taken out new heater valve and it over heated again ? Took the pipes off and bypassed the heater and it lasted a few days and over heated again ? Any ideas ? Just found out the heater valve was a non ford one

Answers

Simple easy fix I had this issue, remove the pipe from the thermostat housing that go.s to the header tank it's blocked. Darren from Kent

Simple easy fix I had this issue, remove the pipe from the thermostat housing that go.s to the header tank it's blocked. Darren from Kent

Submitted: 12/08/2014 18:48:39 | ID: 101391

Answer this question

carl, Cambridgeshire

Ford Galaxy

HI my galaxy has recently started to 'stutter' around 3.5k revs under acceleration...if i feather the accelerator it eases off..but this is in all gears.....someone has mentioned the throttle contol sensor.....is that so? and if so where might i find it on the car?? Thanks in advance for any info :)

Answers

I had the same problem for over a year. No-one could figure it out. By chance I found I had a blocked catalyst and this had blown the pipes to the egr. Exhaust gas recirculation valve. Check under the bonnet with the engine running. Can you hear gas whooshing out. Careful its very hot.... maybe this may help..... bennyk1981 from Hertfordshire

I had the same problem for over a year. No-one could figure it out. By chance I found I had a blocked catalyst and this had blown the pipes to the egr. Exhaust gas recirculation valve. Check under the bonnet with the engine running. Can you hear gas whooshing out. Careful its very hot.... maybe this may help..... bennyk1981 from Hertfordshire

I had the same problem for over a year. No-one could figure it out. By chance I found I had a blocked catalyst and this had blown the pipes to the egr. Exhaust gas recirculation valve. Check under the bonnet with the engine running. Can you hear gas whooshing out. Careful its very hot.... maybe this may help..... bennyk1981 from Hertfordshire

Submitted: 31/05/2014 12:41:15 | ID: 96578

Answer this question

Tracey Luckhurst, England

Ford Focus C-Max 2007

Hi there. I have been looking for my Aux socket in my Ford Focus C-MAX. It says it’s in the glove box but I cannot find it. Can anyone offer any help? Much appreciated.

Answers

There seems some typing error. there are two sockets on a C-Max, one next to the drivers handbrake under the lift up flap and the second one is in the boot. When you lift the tail-gate you will see it on the right-hand side. can’t miss it Joe Waterfall from Nottinghamshire

.my cmax has 3, theother one is under the ashtray? behind the central console, for use by rear seat passengers. wayne from Nottinghamshire

my cmax has 3, theother one is under the ashtray? behind the central console, for use by rear seat passengers. wayne from Nottinghamshire

Submitted: 23/10/2012 09:14:38 | ID: 66289

Answer this question

Mike Childs, England

Ford Galaxy 2005

How do I check the level of automatic gear box fluid in my Ford Galaxy, as it will not go into reverse unless the engine is warm?

Answers

I have exactly the same problem with my 04 galaxy , can you let me know if you have found the cause. cheers Mike Bell Mike Bell from Cheshire

I have exactly the same problem with my 04 galaxy , can you let me know if you have found the cause. cheers Mike Bell Mike Bell from Cheshire

Submitted: 07/06/2012 09:21:15 | ID: 71252

Answer this question

Hifsi, Kent

Ford Galaxy

My central locking is not working checked key is fine. It seems to have its day when it works but now I can't lock drivers door. I can lock passenger doors manually but not drivers door if I get in and use the central locking button on drivers door it was locking then I'll get out passanger door no light comes on for alarm . But now it won't allow me to do that neither pls is there a easy solution to resolve this

Answers

Central locking module in your driver`s door Peter from Essex

Submitted: 04/08/2014 07:20:58 | ID: 100872

Answer this question

Donald, Albania

Ford Galaxy

My ford galaxy 2006 2.0 tdci make a loud noise when i drive over 120 km/h like an airplan in start. Can u give ne an answer about this what i have to do

Answers

Possibly a turbo air leak Peter from Essex

Submitted: 11/08/2014 07:56:03 | ID: 101302

Answer this question

AlanT, Greater Manchester

Ford Ka

Hi, my daughters 2014 KA with 1000 miles on the clock has an accelerator problem. It is impossible to get the revs up when setting off on a hill, the revs just die off, this happens on the flat too. I contacted my local ford garage today and they agreed there was a problem and that the problem was known to Ford. In fact they had several ford KA,s awaiting rectification of similar problems to mine. I was advised that on their system it showed that Ford were working on a software upgrade to sort out the problem of this flat spot being experienced when accelerating. I was advised that this is likely to be ready towards the end of July 2014 to August 2014. I await to see.

Answers

Took my 2 month old 2014 KA to Ford this morning as I had problem with lights flickering and they told me about this software update. They carried on with software upgrade. Following upgrade when the tried to bring it out of garage the car won't start and may have to reset it back to factory settings! Jenni from County Londonderry

Took my 2 month old 2014 KA to Ford this morning as I had problem with lights flickering and they told me about this software update. They carried on with software upgrade. Following upgrade when the tried to bring it out of garage the car won't start and may have to reset it back to factory settings! Jenni from County Londonderry

Submitted: 10/07/2014 19:12:56 | ID: 99400

Answer this question

peterdarts27@yahoo.co.uk, Wrexham

Ford C-Max

I got a 2004 Ford c max 1.8 petrol I just got home and switched off the head lights I got out and locked the car and then noticed the stereo was still lit up and also the milage counter was lit up and all other lights were off I'm just been back out its been an hour and the lights are still on I'm worried about having a flat battery in morning can anyone help please

Answers

Did you solve this problem? Ross from Oxfordshire

Submitted: 12/07/2014 22:53:07 | ID: 99536

Answer this question

rob, West Midlands

Ford Focus C-Max

I`m having problems with my central locking. All of the doors are locked except the driver`s door and boot. The driver`s door will only open with the key and the boot will not lock. I have tried to reset the central locking but this does not seem to have worked. Does anybody have any ideas?

Answers

Check the switches in the door shut the tend to corrode or wear out, especially the drivers door as it's the most used one! Garreth from Kent

Submitted: 19/08/2014 13:24:10 | ID: 101756

Answer this question

Jill Field, Warwickshire

Ford Focus C-Max

Can you please advise me where the reversing light switch is located?

Answers

It's on the gearbox they bolt into the gearbox just tap it with a hammer on the nut part of it, they get stuck a lot! Garreth from Kent

Submitted: 17/08/2014 13:53:18 | ID: 101643

Answer this question

Anthony, Cornwall

Ford Focus C-Max

Hi do you need to disconnect battery to change n/s/f seat belt, and if you do has anything needs reprogramming

Answers

Yes you do need to disconnect the battery and also leave it for a good half hour before working on it as the airbag control module will have stored enough backup power in its capacitor so will need time to drain itself. as far as programming goes if it is just a seatbelt change then it shouldn't need programming but if the seatbelt has deployed then you will need to renew the module too which will need programming Hope this helps! Garreth from Kent

Yes you do need to disconnect the battery and also leave it for a good half hour before working on it as the airbag control module will have stored enough backup power in its capacitor so will need time to drain itself. as far as programming goes if it is just a seatbelt change then it shouldn't need programming but if the seatbelt has deployed then you will need to renew the module too which will need programming Hope this helps! Garreth from Kent

Yes you do need to disconnect the battery and also leave it for a good half hour before working on it as the airbag control module will have stored enough backup power in its capacitor so will need time to drain itself. as far as programming goes if it is just a seatbelt change then it shouldn't need programming but if the seatbelt has deployed then you will need to renew the module too which will need programming Hope this helps! Garreth from Kent

Submitted: 15/08/2014 13:19:10 | ID: 101542

Answer this question

Harry Hatton, Nottinghamshire

Ford Fiesta

When the engine is turned on there is around a 15 second delay for any of the dials to start moving, the radio to turn on and for any thing to appear on the dashboard screen. Recently removed the stereo and not sure if this was happening before hand. anyone experienced this before?

Answers

Mine`s doing the same, did you find the answer to your problem? Lewis from Stoke-on-Trent

Mine`s doing the same, did you find the solution to your problem? Lewis from Stoke-on-Trent

Submitted: 15/07/2014 18:17:11 | ID: 99727

Answer this question

christina, Spain

Ford Ka

I have water coming near my feet on both sides of car when air con is on. Can you advise where you think this is coming from

Answers

It is normal to get water in the heater box inside the car when aircon is used Usually the water drains out through a pipe under the car This pipe is probably blocked or split Scott merrills from East Riding of Yorkshire

Submitted: 20/07/2014 10:32:35 | ID: 100032

Answer this question

Barry, Dumfries and Galloway

Ford Mondeo

Oil round engin and makes a whisling noise when excelerate

Answers

If your vehicle is a turbo diesel the likely cause is a split turbo hose in the area where the oil is seen Scott merrills from East Riding of Yorkshire

Submitted: 11/07/2014 19:53:17 | ID: 99472

Answer this question

Steven Burrows, Essex

Ford Fiesta

Hello, When I turn left or right round corners, the red exclamation light (the same as when the handbrake is applied) on the dash lights up. Any idea why this may be? Thanks, Steve

Answers

Check the brake fluid level. If low get the vehicle`s hydraulic system checked for leaks and check brake pads for wear. Check rear shoes for wear and cylinders for leaks Scott merrills from East Riding of Yorkshire

Submitted: 20/07/2014 13:37:51 | ID: 100045

Answer this question

vic, Wrexham

Ford Fiesta

clutch won't work the pedal goes straight to the floor but there is a leak from the gearbox underneath

Answers

The clutch slave cylinder has failed The gearbox will need to be removed and a replacment slave cylinder installed. Also a clutch would maybe required if contaminated with fluid Scott merrills from East Riding of Yorkshire

The clutch slave cylinder has failed The gearbox will need to be removed and a replacment slave cylinder installed. Also a clutch would maybe required if contaminated with fluid Scott merrills from East Riding of Yorkshire

Submitted: 17/08/2014 12:56:32 | ID: 101637

Answer this question

Brian, Australia

Ford Mondeo

Last year had a problem where the Mondeo (2009 TDC1 Titanium) would suddenly cut out while driving. Fortunately the couple of times it happened I was slowing down. Ford could not find the problem. It didn't happen again till last week when it cut out just as I was going round a corner in to a side street. Then over the next 2 days it was doing it intermittently. Took it to mechanic who has been servicing the car and he tested it for a few hours but could not fault it. The only error code on the computer he could find as well was P02E1 - Diesel intake air flow control performance. He cleared the code and since then no more problems . Just wondering has anybody else had this problem and if so what was the fix? I do consider it to be dangerous particularly if I was to be in high speed traffic.

Answers

I had a similar problem. My mechanic cleaned a couple of sensors (crank case was one I think) that had a little oil on them..... problem solved. steve from Essex

Submitted: 13/06/2014 09:39:30 | ID: 97590

Answer this question

Brad, United States of America

Ford Fusion 2008

My Ford Fusion`s check engine light intermittently comes on and then some time later (like next time I start the car) it goes off on it`s own. What kind of problem can cause this? Also, the battery light intermittently comes on and then goes off on it`s own. Voltage reads a little high (14.5 - 15.5) when this is occurring. Are these problems possibly related? This problem has been there longer and the cover on the positive terminal shows signs of being hot at times (partially melted). Any suggestions please?

Answers

Engine light problem on my vehicle had the same problem however on having computer check at garage discovered it was a misfire on one of the spark plugs so rplaced and all is well Alex Pratt from Argyll and Bute

Submitted: 21/02/2013 11:40:29 | ID: 89533

Answer this question

derek mills, Cambridgeshire

Ford Mondeo

car runs fine all the time until you turn on the headlamps them the management light comes on and the engine mis fires and runs on 3 cylinders if you turn on just the sidelights its fine and you can hold full beam on and its fine only on dipped beam when you turn off the headlamps after a few seconds it returns too normal the alternator is fine as you can load it with both heated screens heater motor sidelights and indicators and no problem until you put on dipped beam headlamps

Answers

hi just in case anyone has this problem in the future we found out the coil pack was at fault god knows why it only happened with dipped headlamps but was an easy fix after a scan picked up the fault not too expensive either around £22.00 derek mills from Cambridgeshire

Submitted: 10/08/2014 15:44:41 | ID: 101272

Answer this question

Del, Dorset

Ford Focus

Hi there. I have a Focus TDCi on a 52 plate and I'd like a rough idea how much in fuel it would cost to drive from Poole in Dorset to Peterborough? Journey time is 3.25hrs/146miles. Cheers Del Lopez

Answers

Go onto google maps, click the 'directions' option, put in your start and finish points and it should tell you the distance, time and fuel cost Phil from East Renfrewshire

Submitted: 03/07/2014 18:40:58 | ID: 98911

Answer this question

Emma, Bridgend

Ford Ka

Hello, I have noticed a smell of burning rubber coming from my car, there is no pattern that I can ascertain. There are no oil leaks that I can find, no oil on the floor, wheel rubber is all intact, brakes were replaced nine months ago. There are no noises to indicate wheel bearing problems, no vibration or wobble through steering, cam shouldn't need doing at 42,000 miles and is not screeching. What could it be? Any ideas for troubleshooting before I take it to the garage would be appreciated! It`s six years old and has had nothing replaced since new apart from brakes and tyres. Thanks.

Answers

Hi I have had similar problem of intermittent burning rubber smell, then recently smell suddenly appeared together with reduced power this time and I needed a new clutch, so maybe burning smell is a sign yours is going, mine had simple milage. Les from Norfolk

Submitted: 13/07/2014 22:28:14 | ID: 99616

Answer this question

Paul Farrow, Hertfordshire

Ford Ka

Why does the driver`s seat get hot, even during short journeys?

Answers

Ive noticed that weird thought was the leather,i know the bottom part u have a button to put heater on dont know why back gets warm, great for winter time wendy from Kent

Submitted: 29/07/2014 09:57:00 | ID: 100545

Answer this question

Geoff, Bedfordshire

Ford Mondeo

My mondeo will not start, The dashboard lights are on ok but when I turn the key to start the it nothing happens...there is no noise at all ie no click etc. I tried jumping the battery from another car with a new battery but still the same...any ideas.

Answers

Sounds very much like the starter motor derek mills from Cambridgeshire

Sounds very much like the starter motor derek mills from Cambridgeshire

Submitted: 31/07/2014 18:37:12 | ID: 100670

Answer this question

Driver girl, Cumbria

Ford Fiesta

Since having a new set of injectirs fitted my car is putting a big cloud of black smoke out when accelerating quickly anyone got any clues ?

Answers

Mine was doing the same, it was the egr valve. We cleaned it and it was fine for a couple of months then it starting kicking out black smoke again, we ended up fitting a blanking plate, it runs better than ever now. You can pick one up for under a fiver on ebay :) Vidia from Northumberland

Mine was doing the same, it was the egr valve. We cleaned it and it was fine for a couple of months then it starting kicking out black smoke again, we ended up fitting a blanking plate, it runs better than ever now. You can pick one up for under a fiver on ebay :) Vidia from Northumberland

Submitted: 16/07/2014 11:05:52 | ID: 99770

Answer this question

Jane DOLTON , Berkshire

Ford Focus

Please help me. I bought a new Ford Focus in 2004 and drove it for four years but then had to take it off the road. It has 36,000 on the clock and was kept under cover for 6 years. I put a new battery in it and it won't fire up, it sounds like it is trying to start up but won't. So far two mechanics have looked at it, fiddled under the bonnet and charged me for their service but have not got it started.I'm a woman on my own and as I can't get it to a garage I am being charged a call out charge each time I get someone out. Can anyone help? Thank you very much.

Answers

Hi Jane, its not going to be easy to diagnose without inspecting the vehicle, is it petrol or diesel for starters? Neil from West Midlands

Hi Jane, it`s not going to be easy to diagnose without inspecting the vehicle. Is it petrol or diesel for starters? Neil from West Midlands

Hello Neil It's a 1.6. Petrol 5door Focus. It sounds like it wants to start up and it backfires. Thank you very much, Jane Jane DOLTON from Berkshire

Hi, call ford up and ask then to come out and put a diagnostics machine on it, it could be a number of things, maybe the alternator if you was more local my hubby would of popped up we have all the machines to check as he is recovery/ mechanical specialist, good luck hope you sort it soon xx Louise from Kent

Hi, call ford up and ask then to come out and put a diagnostics machine on it, it could be a number of things, maybe the alternator if you was more local my hubby would of popped up we have all the machines to check as he is recovery/ mechanical specialist, good luck hope you sort it soon xx Louise from Kent

Submitted: 23/06/2014 22:41:40 | ID: 98325

Answer this question

Simon, Wiltshire

Ford Fiesta

My wife's car seems to have an intermittent starting fault. It's a 2007 model with approx 90000 miles FSH and due it's next service in a couple of weeks. On a number of occasions she has driven the car to town only to find when she returns to the car and try's to start it again it fails. On one occasion she called me to it and I couldn't start it either was turning over fine but not firing. I left it a while and phoned to get it recovered I then tried it one more time whilst waiting for RAC after about 20 mins and it then started. No warning lights flash up and temp whilst driving is normal. No issues when driving and car is used daily with fault happening about 8 times now. The fault has only happened shortly after car is driven she states that it always starts again if she then leaves it 20-30 mins . We have taken it to a local garage but they said as the car starts fine with no fault codes then they can't fix it until it develops the fault again. The car will be going for a service end of this month I am hoping someone may have come across a similar fault before so I can pass info on to garage when it goes in so we can get it sorted. Any info appreciated.

Answers

Check battery oz from Greater London

Any update on this fault as I am having the same problem with mine. Also can hear a ticking noise every ten seconds whilst the car is running? Andrea from Lancashire

Any update on this fault as I am having the same problem with mine. Also can hear a ticking noise every ten seconds whilst the car is running? Andrea from Lancashire

Hi Andrea no real update from having a read on other forums I suspect that it may be a injector issue. I told the garage to have a look whilst it was in for service but they couldn't get fault to develop so looks like I may have to get Ford to check injector pressures etc. Simon from Wiltshire

Submitted: 13/07/2014 15:02:01 | ID: 99586

Answer this question

Paul Kennedy, Aberdeenshire

Ford Focus

My car has been back to the dealer who assures me that this vehicle doesn't have one touch windows. The window goes all the way down but you have to hold your finger on the button to put the window up. Is this correct or is he having me on? My 2000 astra had one touch windows so surely this thing must?

Answers

This is usual with the rear windows, in case a child puts there hand out whist you are closing it. Will from Devon

Thanks for the reply it's a 3 door so only front windows goes all way down but hold to put up Paul Kennedy from Aberdeenshire

Submitted: 16/07/2014 15:11:13 | ID: 99786

Answer this question

Sarah, Kent

Ford Focus

Stability Control Light(ESP) keeps coming on, garage done investigation and changed the steering wheel angle sensor, but light still coming on. Came on this morning when going round a corner at less than 20 mph. Any ideas?

Answers

Had the same problem 12 months ago a wire from a sensor had rubbed and was earthing out. Will from Devon

Had the same problem 12 months ago a wire from a sensor had rubbed and was earthing out. Will from Devon

Submitted: 27/07/2014 12:08:08 | ID: 100425

Answer this question

Mark Sugden, Kent

Ford C-Max 2008

Neither the AA or my local garage can find a fault code when my Ford C-MAX`s engine malfunction light comes on, which now is nearly all of the time. The car was running okay until yesterday when it seemed to be running in a speed restricted mode- I can’t accelerate well and it takes ages to get to 60mph on the motorway. Can anyone suggest what is wrong? (Diesel)

Answers

wheel ballencing probs the best bet if you can drive out of it at 80mph get that done and it should be alright or swap front wheels with back darren from Argyll and Bute

wheel ballencing probs the best bet if you can drive out of it at 80mph get that done and it should be alright or swap front wheels with back darren from Argyll and Bute

Submitted: 02/04/2013 10:27:57 | ID: 90303

Answer this question

sophia davies, Swansea

Ford Focus

Hello there, can anyone please help me, i'm desperate to find out the code for my radio!

Answers

Mine is a 09 plate Focus and the radio code is on the inside of the glove box door. Geoff from Cheshire

Mine is a 09 plate Focus and the radio code is on the inside of the glove box door. Geoff from Cheshire

Submitted: 13/07/2014 11:50:57 | ID: 99565

Answer this question

natasha, Bedfordshire

Ford Galaxy

Hi. I have a stange problem that no one seems to know what it could be. When going over 10 miles and accelerating the car starts making this clicking noise every its put into acceleration. The drive shaft was cha ged today and the problem is still there. Has anyone got any ideas or answers as to what could be the cause. Thanks

Answers

I have a 2.0 petrol '56 (new shape) Galaxy and I also get ticking / clicking noise when accelerating. The dealer thinks it may me the fuel injectors over working which is apparently a known problem and can't be addressed. Our Galaxy has only done 65K miles and been serviced regularly. No impact to performance, temperature needle or economy. Paul from Berkshire

I have a 2.0 petrol '56 (new shape) Galaxy and I also get ticking / clicking noise when accelerating. The dealer thinks it may me the fuel injectors over working which is apparently a known problem and can't be addressed. Our Galaxy has only done 65K miles and been serviced regularly. No impact to performance, temperature needle or economy. Paul from Berkshire

Submitted: 15/07/2014 19:32:49 | ID: 99734

Answer this question

Craig, City of Glasgow

Ford Kuga

I have just bought a Ford Kuga Titanium with the Sony DAB radio but every time I start the car my time and date resets. How do I fix this?

Answers

Hello Craig of Glasgow. Quickly send the car back to the dealership. Since it is NEW it will still be covered by their warranty. The problem seems to be the Electrical System and it could get worse if other electronics are affected as well.Take care. Cheers! Melvin Lee from Malaysia

Submitted: 30/07/2014 21:51:17 | ID: 100614

Answer this question

johyn, Portsmouth

Ford Galaxy

my sisters car is running lumpy it is a 2005 1.9 td we have changed a couple of little bits on the advice of her garage glow plugs air filter and it is still running really lumpy does anyone have any ideas what we can check next as she really doesnt have the money to get garage to fix thanks

Answers

Check the egr valve and Dpf Collin parkin from Northamptonshire

Submitted: 14/07/2014 21:42:14 | ID: 99684

Answer this question

Mel Kemp, Berkshire

Ford Focus C-Max 2007

Whilst driving my Ford Focus C-MAX all lights on the dashboard come on and the speedo clock goes down to 0. I then have no power steering and I have to then press the mileage reset button for it to all come back on. I have to turn the key about 30 times to start the car and it only starts if I hold the mileage reset button. Can anyone help? Thanks.

Answers

Did you find out what was wrong as mine is doing the same kevin anderson from Lancashire

Did you find out what was wrong as mine is doing the same kevin anderson from Lancashire

Submitted: 07/11/2013 15:21:47 | ID: 57548

Answer this question

lee, Ireland

Ford Fiesta

Hi all, Have a nightware with my 2001 ford fiesta 1.25 zetec se ghia 5 door i bought the car as a non-runneras the previous owner over filled it with oil and he hadn't servided it in 2years either so i saved the poor motor haha :) now ive done a full service - spark plugs, oil, oil filter, pollen filter, air filter, full coolant change. Car was running great then i found the Brake master cyclinder was leaking brake fluid so i fixed that then i start the car again and everything when bad now the car is mis-firing, choking, shaking, water like liquid coming out the exhaust and the revs are bouncing even when idle in neutral and i can not control the revs onlys at 4,000 and the engine management light is flashing on and off randomly and i mean RANDOMLY like sometimes when i start up the car or sometimes when i have it running idle for a while. Now i'm a 3rd year apprentice mechanic so i buy and sell cars to help my low income. Now i've checked the coil and plugs there all sparking the leads are carring current fine theres no rips or corrosion on the leads or coil pack. When i first got the car it did have the engine management light on and the code was PO420 i cant remeber it was catalytic convertor treshold something anyway i didn't have alot of money so i went against my gut and bought a bottle of cataclean it was meant to fix the problem with the catalytic convertor and turn of the engine light but to my surprize it worked 100% amd done everything it said it would do ! anyway any advice or experience in what my problem may be ? i'm thinking trottle body/ mass air flow meter or EGR Valve ? thanks

Answers

Hi it's your egr valve had same problem I took it out cleaned it runs perfect now matthew from Limerick

Hi it's your egr valve had same problem I took it out cleaned it runs perfect now matthew from Limerick

Submitted: 04/07/2014 21:38:58 | ID: 98977

Answer this question

Marcus, Bristol

Ford Ka

My abs light is on and I don't know why. Can you help please?

Answers

One of your ABS sensors is faulty. I had this on my wifes Street KA. IIRC it was about £50 to fix it. It is an MOT failure so cant be left. Strax from North Ayrshire

One of your ABS sensors is faulty. I had this on my wifes Street KA. IIRC it was about £50 to fix it. It is an MOT failure so cant be left. Strax from North Ayrshire

Submitted: 28/06/2014 22:45:29 | ID: 98651

Answer this question

Matthew, Surrey

Ford S-Max

I was driving my 2007 Ford S-Max Titanium 2.0 TDCi at 70 mph on the motorway, in normal weather conditions, when the ESP light and the warning triangle light came on, and the car started to lose power. I stopped on the hard shoulder, switched off, started the engine again and the lights had disappeared but, after 2 miles, the same thing happened. However, the car was normal on the 100-mile journey to get back home. The Ford garage checked the car but could find no cause. Do you have any ideas as to why this happened, please?

Answers

hi i have an ford smax 2.0 and i have over rev it now it wont start could you please help faisal from West Yorkshire

Hi Matthew, I have also had this problem and I have been to Ford dealers the length of the country with no luck. My wife used to use the car for just city driving until I had a job up north. Once I gave this a good run on the motorway, 300 miles plus, I have never had this issue since, fingers crossed it has sorted out the problem. John Kirkham from Bath and North East Somerset

Submitted: 04/06/2014 14:57:51 | ID: 96891

Answer this question