FORD questions and answers: find help and give advice

Ask and answer questions on a variety of FORD models. Help and advice on everything FORD. Feel free to ask and answer as many FORD-related questions as you wish.

Buy used imageBuy new / nearly new imageContract hire image

Search the questions and answers section:

Below are the latest FORD questions answered by visitors to RoadTestReports.co.uk. To supply an answer yourself simply click on the "Answer this question" link underneath each question. Alternatively, if you want to ask a question, simply click on the link below.

Ask a question now

D. Veal , Rhondda Cynon Taf

Ford Fiesta

Top water hose on my car. Is hot and bottom hose is cold car is boiling over when car is ticking over for about 15 to 20 min

Answers

check near top of radiator core if its cool then sounds like radiator could be blocked I would also check water pump an thermostat ken from Australia

check near top of radiator core if its cool then sounds like radiator could be blocked I would also check water pump an thermostat ken from Australia

Submitted: 30/11/2014 14:26:59 | ID: 107137

Answer this question

hayley, West Midlands

Ford Focus

My 51 plate ford focus wont start we tried juming it with jump leads attached to my daughters c1 but nothing. The dash lights went bright then dimed, there is a loud clicking noise whilst im turning the key, it seems to be coming from the glove box? please help

Answers

it sounds like it is either the battery or the starter motor the loud clicking sounds like the solanoid on the starter motor, test what voltage you have at the battery it should be about 12.5v if not i would put a new battery on if it has then it has to be the starter motor i hope this helps you. Adrian Paine from Northamptonshire

it sounds like it is either the battery or the starter motor the loud clicking sounds like the solanoid on the starter motor, test what voltage you have at the battery it should be about 12.5v if not i would put a new battery on if it has then it has to be the starter motor i hope this helps you. Adrian Paine from Northamptonshire

Submitted: 01/12/2014 11:40:48 | ID: 107177

Answer this question

Lisa, Essex

Ford S-Max

The electric blind that covers my panorama roof started to play up, stopping and starting and then the blind became baggy and wouldn't retract properly. I took it to a ford dealer and was told that to replace the blind it would cost £1000, without actually knowing if the mechanics are faulty or not! My car is 16months old and is not covered by warranty, as the blind is classed as trim, yet it could mechanical which would mean it would be. Anybody uncounted similar problems, if so how did you go about getting ford to rectify it.

Answers

Hello Lisa, Funny - I have exactly the same problem and was doing a google search and came across your query. I am in touch with Ford about this as the 3 year classic plan warranty that comes with all fords does not mention this as an exclusion. As far as I am concerned the blind is not closing so it is a mechanical fault and should be covered. david from Worcestershire

Hello Lisa, Funny - I have exactly the same problem and was doing a google search and came across your query. I am in touch with Ford about this as the 3 year classic plan warranty that comes with all fords does not mention this as an exclusion. As far as I am concerned the blind is not closing so it is a mechanical fault and should be covered. david from Worcestershire

Submitted: 28/08/2014 11:51:24 | ID: 102271

Answer this question

Jonny, Durham

Ford Ka

I need urgent help, I have a dashboard warning message reading; Exess. Radiator liquid temp.. It urges me to turn my engine off, I checked the coolant level and it's pretty low. Could this be as simple and a loose clip losing coolant or my actual radiator split? Any recommendations on how to check this problem would be MASSIVELY appreciated! Jonny Durham

Answers

This happened on mine earlier this year something had split in the radiator pipes had to have it fixed before I could drive cost about£140 Amy from Cheshire

This happened on mine earlier this year something had split in the radiator pipes had to have it fixed before I could drive cost about£140 Amy from Cheshire

Ended up being a snapped thermostat Union! Ford using plastic parts... Shock! Replaced with a metal Union. Engine gets to temperature a lot faster now. Jonny from Durham

Submitted: 07/12/2014 02:29:53 | ID: 107502

Answer this question

Michelle Huxley, Cheshire

Ford Puma 2001

My Ford Puma`s temperature gauge goes into the red after driving for a couple of minutes and stays there. The fan kicks in but the temperature gauge stays right in the red. I have had the temperature control valve changed, a second valve changed, it had a new water pump done before I bought it, I`ve had the cambelt changed, even tried a new cap on the coolant tank but still no success. I have had it tested and it is not electrical. I have been told that maybe it could be the head gasket. The engine is not overheating though, nothing smells. I have had the car 2 months and most of that time it has been in the garage and it`s still there now. I don`t really want to get rid of the car as she is in perfect condition apart from this problem and drives like a dream. Can anyone help?

Answers

Hi any joy with this? I'm having same issue. Was advised pressure in tank causing temp to rocket, but could be head gasket on way out. I'm trying steel seal to try and solve it. Fingers crossed! Kate from Merseyside

Hi any joy with this? I'm having same issue. Was advised pressure in tank causing temp to rocket, but could be head gasket on way out. I'm trying steel seal to try and solve it. Fingers crossed! Kate from Merseyside

Submitted: 03/04/2014 11:48:35 | ID: 93848

Answer this question

Ciro Torres, Greater London

Ford Galaxy

Clutch pedal on my Ford Galaxy 2.3 has suddenly stopped working, as I was driving out. I doesn't raise up at all. Can any one help me please; any idea of what caused it and how to repair. Many Thanks

Answers

Hi Cliff, Had similar on my Ford Fusion. At the top of the pedal is a linkage that connects to a pin on the RH side of the pedal. The linkage moved sideways and slipped off the pin. i slotted the linkage back on and all well. Good luck ! Roger Roger Newman from Leicestershire

Hi Cliff, Had similar on my Ford Fusion. At the top of the pedal is a linkage that connects to a pin on the RH side of the pedal. The linkage moved sideways and slipped off the pin. i slotted the linkage back on and all well. Good luck ! Roger Roger Newman from Leicestershire

Submitted: 27/11/2014 03:17:12 | ID: 106964

Answer this question

martin boyle, Antrim

Ford Focus C-Max

A cog wheel comes up on my dash - what is it telling me?

Answers

i had this problem and when i had a diagnostic it showed the fault was the fuel pressure try a new fuel filter graham from Greater Manchester

i had this problem and when i had a diagnostic it showed the fault was the fuel pressure try a new fuel filter graham from Greater Manchester

Submitted: 07/11/2014 19:48:42 | ID: 105859

Answer this question

Richard Ogbuka, Nigeria

Ford Fusion

I perceive smells in my ford fusion 2003 , I don't know if I should change my clutch or brakes .

Answers

It might be neither. You can get smells from the air conditioning too. Reg Vernon from Staffordshire

Submitted: 19/10/2014 07:03:44 | ID: 104838

Answer this question

Denise, Northamptonshire

Ford Fiesta

My car only blows cold air I think its the thermostat but I can't locate the thermostat to be able to test it what else could it be, the car runs fine also is this an expensive job is it an easy or hard job any advise would be grateful

Answers

Have you checked your oil levels? john whitbread from Derbyshire

Have you checked your oil levels? john whitbread from Derbyshire

Submitted: 24/11/2014 11:38:42 | ID: 106773

Answer this question

Richard Ogbuka, Nigeria

Ford Fusion

Which car can I compare with ford fusion 2003 , I want to know the value of the ford fusion 2003 . Cos I just bought a new one.

Answers

The nearest equivalent in the UK car market is the Vauxhall Meriva. Both were launched at about the same time and have similar specifications. The modern equivalent to the Fusion is Ford's B-Max, the Fusion is no longer in production. I have a Ford Fusion 3 first registered in November 2003 with the 1.6L petrol engine. It has been extremely reliable over 118,700 miles. I have only had to replace the OEM alternator (yesterday), part of the exhaust (due to a failed bracket) about two months ago and a new battery in 2012. The Fusion is a very strong car. I strongly recommend it. Reg Vernon from Staffordshire

Submitted: 19/10/2014 07:11:53 | ID: 104839

Answer this question

Teresa Serle, Hampshire

Ford Ka

Can I turn the passenger air bag off? How?!

Answers

How do I turn air bags off either just passengers side or both in new shape ka 2010. I would like to put my baby in the front rather than the back. Is there anyone who can help Kelly from Cardiff

How do I turn air bags off either just passengers side or both in new shape ka 2010. I would like to put my baby in the front rather than the back. Is there anyone who can help Kelly from Cardiff

Submitted: 01/09/2014 14:36:36 | ID: 102457

Answer this question

arthur bemrose, Warwickshire

Ford Focus

In frosty weather the driver`s door will not shut and latch?

Answers

Had the same problem this morning with the first frost since bought focus this year Mine has key less ignition door opened okay but would not close,googled problem and it seems in cold weather grease in lock freezes stopping lock returning I just sprayed wd 40 into mechanism on door and all was fine after about 10 min.Seems it will free itself when warmed up Going to be a pain if we have a bad winter.Hope the wd 40 works for a while Jeff from Cheshire

Had the same problem this morning with the first frost since bought focus this year Mine has key less ignition door opened okay but would not close,googled problem and it seems in cold weather grease in lock freezes stopping lock returning I just sprayed wd 40 into mechanism on door and all was fine after about 10 min.Seems it will free itself when warmed up Going to be a pain if we have a bad winter.Hope the wd 40 works for a while Jeff from Cheshire

Submitted: 06/11/2014 12:33:14 | ID: 105759

Answer this question

Frank Rodgers, Cornwall

Ford Galaxy 1997

Hi. Does anyone know how to put the timing back to normal on a Ford Galaxy 2.3? (2.3)

Answers

Try replacing power hold relay and fuel pump relay Steve from Isle of Wight

Try replacing power hold relay and fuel pump relay Steve from Isle of Wight

Submitted: 29/10/2013 09:47:40 | ID: 56867

Answer this question

Nicola, Greater Manchester

Ford Kuga

My car was fine this morning but then when I restarted the engine the i light came on then it shows my bonnet is open and the frost light is red. My heaters and my parking sensors are no longer working, unsure as to whether it's effected my wipers as it is not raining. I took it to a local garage to check to see if it was a fuse but they don't think it is. Can anyone help? Thanks

Answers

Hello Nicola, I had the same exact problem, I checked the fuses myself with no luck so I took it to my mates garage he couldn't find the problem either but when he screwed the fuse holder back into place everything started working as normal it seems that there was just a loose connection from where a passengers feet must have loosened a wire get someone to check this for you Sean from Cardiff

Hello Nicola, I had the same exact problem, I checked the fuses myself with no luck so I took it to my mates garage he couldn't find the problem either but when he screwed the fuse holder back into place everything started working as normal it seems that there was just a loose connection from where a passengers feet must have loosened a wire get someone to check this for you Sean from Cardiff

Submitted: 17/11/2014 13:43:20 | ID: 106340

Answer this question

Anita Hensman, England

Ford Focus 2003

Hi. I bought my Ford Focus being told everything was fine. Now all the lights on the dashboard keep flashing and an alarm comes on, the speedo drops as well as the petrol gauge, then it corrects itself. A friend did a diagnostic check and said it looks okay but thinks it is the crash sensor on the bumper? I can`t afford to pay too much. Please can anyone help? (1.8 diesel tdci Zetec)

Answers

Hi, I had a similar issue with my 1999 MK1 petrol 1.8 Ford Focus. The speedo went haywire, idling speed erratic and could be prone to cutting out! I replaced the "Speed Sensor" which is located virtually at the bottom of the engine! The cost can vary, I paid £20.00 online from a Ford specialist parts supplier, but I would suggest buying brand new they do seem cheaper now. Hope this helps.- Paul Holland from England.

I have a 2003 focus and the speedo , revs , temp and petrol gauges stopped working . Was told I may need A new speedo cluster . I found that it was a problem with the electric board at the back of the speedo . If you take the speedo out at the back there is a white plastic cover take this off and you will see the electric board , check all the solder points , if you see that they have started to corrode get the bit of wire wool or small grit sand paper and lightly clean all the board ,be very carful not to rub to hard els you will reck the board . Seb . B from West Midlands

I have a 2003 focus and the speedo , revs , temp and petrol gauges stopped working . Was told I may need A new speedo cluster . I found that it was a problem with the electric board at the back of the speedo . If you take the speedo out at the back there is a white plastic cover take this off and you will see the electric board , check all the solder points , if you see that they have started to corrode get the bit of wire wool or small grit sand paper and lightly clean all the board ,be very carful not to rub to hard els you will reck the board . Seb . B from West Midlands

Submitted: 25/07/2013 14:19:53 | ID: 52960

Answer this question

peterdarts27@yahoo.co.uk, Wrexham

Ford C-Max

I got a 2004 Ford c max 1.8 petrol I just got home and switched off the head lights I got out and locked the car and then noticed the stereo was still lit up and also the milage counter was lit up and all other lights were off I'm just been back out its been an hour and the lights are still on I'm worried about having a flat battery in morning can anyone help please

Answers

Did you solve this problem? Ross from Oxfordshire

I am having the same problem and unable to find out if this a normal feature of the car or a fault, would be pleased if anyone can give an answer Maurice from Gloucestershire

I am having the same problem and unable to find out if this a normal feature of the car or a fault, would be pleased if anyone can give an answer Maurice from Gloucestershire

Submitted: 12/07/2014 22:53:07 | ID: 99536

Answer this question

sam, County Antrim

Ford Focus

Hi there recently my 2008 ford focus zetec 1,8 tdci keeps playing up when im driving i flashinglight keep popping up on dash board beeping with the message Bonnet Open ive tryed openibg and closing the bonnet checking for faults but bonnet sames ok.. and i cant lock my car for the alarm keeps going off also Helppppppp!!!! 2nd question my ford focus 2008 zetec tdci locking system on key doesnt work which means ive to lock and open car by key does the fuse need charhed or is it best to hive ford £170 to make a replacement key thanks

Answers

Sounds like a faulty instrument cluster, various intermittent problems . I've had problems and have discovered from research that this is a fairly common fault , Ford main Dealer £700 + for a new one or companies advertising to repair cheaper with a 2 year guarantee. graeme stockton from Berkshire

Submitted: 05/11/2014 02:27:19 | ID: 105689

Answer this question

Cei Thomas, Blaenau Gwent

Ford Focus

Hi my Focus 57 estate has suddenly developed an issue, when it's cold or has not been run a lot an engine malfunction light appears sometimes going into limp mode, other times not. I turn the key off or the light vanishes then it drives fine. Any ideas would be greatly appreciated?

Answers

Sounds like a similar problem to mine. Various intermittent problems , lots of warning lights come on and off, rest of the time car drives fine. Ford main dealer tells me it is a faulty instrument cluster, £700 + for a new one . Searching on line there are companies that will repair it for less and give a 2 year guarantee. graeme stockton from Berkshire

Sounds like a similar problem to mine. Various intermittent problems , lots of warning lights come on and off, rest of the time car drives fine. Ford main dealer tells me it is a faulty instrument cluster, £700 + for a new one . Searching on line there are companies that will repair it for less and give a 2 year guarantee. graeme stockton from Berkshire

Submitted: 17/11/2014 17:47:27 | ID: 106354

Answer this question

Paul Sabin, England

Ford Fiesta 2008

I have a Ford Fiesta 1.2 mk6 3dr. When I turn the steering wheel to the left there is a slight grinding noise which sounds like a disk is catching on brake calliper. I have put new wheel bearings on and changed brake pads and disks twice. I have taken drive shaft gaters off and they are fine. I have run out of ideas now. Can anyone help? (mk6)

Answers

Have you checked bearing on drive shaft near elbow? I had the same problem and did the same and it turned out it was the bearing on drive shaft. Hope this helps Liam from Norfolk

Submitted: 06/12/2012 12:01:49 | ID: 64508

Answer this question

l worthington, Staffordshire

Ford Mondeo

Is there a cam belt or chain?

Answers

It depends on the year and model of your Mondeo? alec from Essex

Submitted: 03/11/2014 17:01:38 | ID: 105616

Answer this question

antony, Blackburn with Darwen

Ford Fiesta

i have a ford fiesta st and it jumps out of first gear now and again when setting off what could the problem be

Answers

Could be the gear linkage adam from Greater Manchester

Submitted: 01/10/2014 14:29:14 | ID: 103898

Answer this question

jane, Lancashire

Ford Fiesta

Could anyone please tell me why my steering has become very heavy?

Answers

Have you checked your power steering fluid? Ensure to look for any wet patches around the fluid well adam from Greater Manchester

Submitted: 05/10/2014 22:33:16 | ID: 104122

Answer this question

LOUISE POTTER, West Midlands

Ford Kuga

Iam at a loss what to do about my kuga,the engine malfunction mode keeps coming on and it goes into limp mode.Ive had the aa out and its been in the ford gararge twice.They say its diesel residue caught in the filter and I need to go on long drives in 4th gear to rectify the problem,this is not acceptable and I need advice what to do next.please help!

Answers

Could be a dpf sensor, the engine management light will stay on until you get Ford to reset it but they do charge heavily Phil from Antrim

Submitted: 19/10/2014 10:39:39 | ID: 104845

Answer this question

Claire Ransted, Wiltshire

Ford Fiesta

I was driving this afternoon parked the car and turned off the ignition forgot to put the electric window up then restarted the car but when I tried to close the window it wouldn't work. After 5 minutes it worked. It happened again later on in the day but the second time the window button didnt work so now its stuck open (about 1 inch) , the lights arent on on the actual window button in the door, is this the fuse or something else?

Answers

Sounds like it's the window motor. Bang on the inside bottom left of the door card. Try again. If this does not work, check for blown fuses. Johnathan Jones from Monmouthshire

Sounds like it's the window motor. Bang on the inside bottom left of the door card. Try again. If this does not work, check for blown fuses. Johnathan Jones from Monmouthshire

Submitted: 02/11/2014 20:23:03 | ID: 105533

Answer this question

Craig, City of Glasgow

Ford Kuga

I have just bought a Ford Kuga Titanium with the Sony DAB radio but every time I start the car my time and date resets. How do I fix this?

Answers

Hello Craig of Glasgow. Quickly send the car back to the dealership. Since it is NEW it will still be covered by their warranty. The problem seems to be the Electrical System and it could get worse if other electronics are affected as well.Take care. Cheers! Melvin Lee from Malaysia

Hi, We had the same problem with our second-hand 08 AWD Kuga Titanium - date and time resetting randomly, not necessarily on every start up, and our Ford garage eventually concluded it needed a new alternator. This was replaced under the extended warranty but the problem continued so they carried out a Software update for us which seems to have resolved the issue. Hope that helps. Lara Thompson from Cumbria

Hi, We had the same problem with our second-hand 08 AWD Kuga Titanium - date and time resetting randomly, not necessarily on every start up, and our Ford garage eventually concluded it needed a new alternator. This was replaced under the extended warranty but the problem continued so they carried out a Software update for us which seems to have resolved the issue. Hope that helps. Lara Thompson from Cumbria

Submitted: 30/07/2014 21:51:17 | ID: 100614

Answer this question

Carmel Danagher, Ireland

Ford Focus 2009

Hi. I recently bought an 09 Ford Focus tdci Style. Every now and then it jerks. I took it back to the garage and they changed the egr valve and checked the sensor on the pedal which the mechanic said was fine. I took my car home tonight and it jerked once again. Does anybody have any other idea what could be wrong with it? Thanks in advance, I hope someone can guide me.

Answers

Hi Carmel, I have the same problem with my 2011 3 series tdci Ford Focus. Starting off in 1st gear the car jumps and jerks. It has been back to Ford’s main dealership about 4 times. They reprogramed the engine managment system , the car still the same. They then said I was using the wrong diesel and I had to use BP diesel . After using BP diesel for about 4 months the car still jumps and jerks when moving of in 1st gear. They have road tested the car and said that they could find nothing wrong. It’s most annoying in traffic but if Ford’s main dealers can’t fix it I will have to put up with this fault. I hope you have better luck tnan me William Gracey from County Down

Possibly faulty wiring to pressure sensor on the end of the fuel rail. Had a similar problem, a pretty serious jerking, ECU was sensing full pressure on fuel rail and cutting supply accordingly due to wires shorting intermittently. On removal of pressure sensor I noticed wiring was kinked. Straightened out wiring, refitted PS and no further problems Ken from Ireland

Hi found my prob .dirt in the diesel tank .took tank off gave it a good clean out and prob sorted .hope this helps a few more Carmel Danagher from Ireland

Submitted: 24/06/2013 11:48:38 | ID: 92131

Answer this question

justin, West Midlands

Ford Galaxy

Hello my Ford Galaxy is struggling to keep running in the mornings,starts ok but wont go over a 1000 revs and once you try and rev it up it cuts out?.Eventually it will let you rev it and then its ok all day no more problems. The car has had a new battery 6 months ago,any idea's and i would be most grateful,many thanks Justin

Answers

Happened with mine. It turned out to be the E.G.R. valve. Initially it was intermittent then it went completely. Shields from Cambridgeshire

Happened with mine. It turned out to be the E.G.R. valve. Initially it was intermittent then it went completely. Shields from Cambridgeshire

Submitted: 19/10/2014 20:01:49 | ID: 104873

Answer this question

Andrew, Devon

Ford Focus C-Max

Hello, I am writing in absolute desperation, I own and have owned my Ford Focus C-Max 2.0 TDCI Ghia 2006 for 3 years. I am not knocking the car I still feel this is the best car i've owned in years and so reliable and economic. I have racked up 150K so in many ways I must be happy. HOWEVER my desperation lies in a leak which started as an occasional drip from one of the screws which holds on the spoiler. I sealed this (tick) still leaks, told it will be the light clusters, removed and sealed these (tick) However, it still leaks HELP Someone please help. I have poured water over the roof and I can see the water coming down in the corners, I think the worst is the passenger side. I park on a slope so it runs into the spare wheel hollow. I am told it could be the seems under the roof rails??? I have rang the Ford dealers who deny issues and are happy to inspect at a cost but not give advice. Can anyone Please PLEASE help me.

Answers

I had this exact problem last year with my 56 plate C-Max and it took many months to sort the problem as we tried everything and Fords wanted to charge me nearly £500 just to try and find the problem as they couldn't locate it after having it one day. I had the back window re-sealed and all sorts done and it still leaked! It turned out it was the seam under the roof rail, which we found after loads of tests with a hose pipe! Move the roof rail as far as it can go and whack in loads of sealer - that should sort it! When you look on line this leak is a really common problem especially with C-Max's of this age - good luck and hope this helps. Mbr@cranford.hounslow.sch.uk from Middlesex

I had this exact problem last year with my 56 plate C-Max and it took many months to sort the problem as we tried everything and Fords wanted to charge me nearly £500 just to try and find the problem as they couldn't locate it after having it one day. I had the back window re-sealed and all sorts done and it still leaked! It turned out it was the seam under the roof rail, which we found after loads of tests with a hose pipe! Move the roof rail as far as it can go and whack in loads of sealer - that should sort it! When you look on line this leak is a really common problem especially with C-Max's of this age - good luck and hope this helps. Mbr@cranford.hounslow.sch.uk from Middlesex

Hi and thank you Mbr of Hounslow I will check that out. Sadly due to all the rain down here in the past week it's like driving around in a mobile swimming pool. When I checked the roof rail it would not slide forward. Did you prize off the plastic roof rail and glue it back down after? Regards Andy Andrew from Devon

Submitted: 06/10/2014 21:56:22 | ID: 104180

Answer this question

MO INAYATHULLA, Hampshire

Ford Galaxy

There is a water in the front passenger side foot well only if raining.I have checked roof window drainage pipe and is fine,no leaks from them.only it happens when raining.Any solve.Please.Thanks

Answers

The gully above the doors runs water down into the inside of the bodywork. I took out carpet and ran water over the roof and found that water seeped out of the welded Joint intoning footwell and it pools as it hD nowhere to go. I poured epoxy resin over the joint so that it sealed the gap and no more water Ian from Cheshire

Submitted: 18/10/2014 23:16:39 | ID: 104834

Answer this question

Les Mitchell, England

Ford S-Max 2010

I lose the sound from my speakers in my Ford S-MAX except centre but at a low level, with a clicking type of sound and the words "drive fault " comes up on the Sony unit. Does anybody know what causes this to happen? Also under hard acceleration in 3/4 gears the engine seems to hesitate a little then pick up. It will keep doing it until you stop accelerating, it feels like a rocking type of motion. I hope things don’t come in 3’s. Any help will be great. (Titanium)

Answers

Hi matey, did you sort out CD player fault and was it a easy fix? Ben Moss from England

I have exactly the same problem displayed as "CD drive fault" with my S-Max from 2010. I also experience that to clear the fault, the car must be turned off and locked for several minutes and that a short power off/on cycle is not enough! I have noticed that the fault can be triggered by placing a mobile phone on the upper left speaker on the dashboard, so I suspect some kind of radio interference problem in the S-Max. It also appears more often on the high-way than in the city (maybe the mobile phone uses more power when far away from base stations?) Of course the error never appears at the Ford service center so they have so far not been able to solve this problem. Linus from Sweden

We have exactly the same issue. Has anyone got to the bottom of this yet? Hannah Swain from London

Ford now seem to have a software update, which solves this problem with S-Max and the sony audio. I visited Ford service a few weeks ago, they updated the sound system, and since then no CD drive fault! Linus Thrybom from Sweden

It’s pretty annoying we have the same problem with a 2010 Titanium x. Happens every other day and just comes out of the blue! Real shame as a great stereo. I’m going to get in touch with Ford as I can’t imagine our dealership will be much help; very friendly, but only interested in problems they see. Any suggestions would be appreciated :). If the car is switched off for more than 10 mins it usually corrects! Lee Bunn from England

same problem with my galaxy titanium stereo... i find holding the power button down until the display goes black, then switching it back on seems to reset it. Maybe be ok again for couple of hours, or couple of minutes then do it again. This is not a great solution but best i've come up with. Very annoying when your singing along.... then click click click. Ford main dealer wanted at least £90 depending on problem to fix it martin from Greater London

I had EXACTLY the same problem as described. I took it to the local main dealer where they advised that the issue was related to communication between the modules/components in the car. They upgraded the firmware of the modules and the problem was resolved. Phil from Staffordshire

I had EXACTLY the same problem as described. I took it to the local main dealer where they advised that the issue was related to communication between the modules/components in the car. They upgraded the firmware of the modules and the problem was resolved. Phil from Staffordshire

Exactly the same problem as detailed. But my local dealership say there is no update and I need a new unit. Can anyone please tell me the dealership in Staffordshire or London who has resolved this so that I can contact them. Even contacted Ford who just supported the dealer's line and said I could go to another dealership. Infuriating. Dec from Surrey

Exactly the same problem as detailed. But my local dealership say there is no update and I need a new unit. Can anyone please tell me the dealership in Staffordshire or London who has resolved this so that I can contact them. Even contacted Ford who just supported the dealer's line and said I could go to another dealership. Infuriating. Dec from Surrey

Hi, I have this same problem. Did the Ford dealer charge to fix this update? If so, are you able to give an indication of the cost. Thanks Richard from North Yorkshire

Hi, I have this same problem. Did the Ford dealer charge to fix this update? If so, are you able to give an indication of the cost. Thanks Richard from North Yorkshire

Submitted: 15/11/2013 10:36:46 | ID: 57890

Answer this question

norman boston, County Down

Ford Mondeo

Clutch fluid keeps dropping slowly and clutch pedal stays down on the floor and has to be lifted by foot or hand. Eventually the fluid gets too low, pedal won't stay up again and clutch cannot be operated. No sign of fluid leaks and slave cylinder is inside bell housing. Would appreciate any help.

Answers

It will be the slave cylinder. Had the same problem. As it is a big job removing the gearbox,, you should replace clutch and DMF at the same time. Iain McDonald from North Ayrshire

It will be the slave cylinder. Had the same problem. As it is a big job removing the gearbox,, you should replace clutch and DMF at the same time. Iain McDonald from North Ayrshire

Submitted: 02/10/2014 22:52:05 | ID: 103983

Answer this question

Sandra, Worcestershire

Ford Ka

Why has my radio packed up?

Answers

Try fuse, possible inline fuse or radio codekevin from Northumberland

Submitted: 22/09/2014 18:13:50 | ID: 103462

Answer this question

Tracey Luckhurst, England

Ford Focus C-Max 2007

Hi there. I have been looking for my Aux socket in my Ford Focus C-MAX. It says it’s in the glove box but I cannot find it. Can anyone offer any help? Much appreciated.

Answers

There seems some typing error. there are two sockets on a C-Max, one next to the drivers handbrake under the lift up flap and the second one is in the boot. When you lift the tail-gate you will see it on the right-hand side. can’t miss it Joe Waterfall from Nottinghamshire

.my cmax has 3, theother one is under the ashtray? behind the central console, for use by rear seat passengers. wayne from Nottinghamshire

my cmax has 3, theother one is under the ashtray? behind the central console, for use by rear seat passengers. wayne from Nottinghamshire

To check the level you need to have the gearbox oil around 45deg c engine running and take the plug out of the sump. There is a tube on the inside of the plug that will have a small amount of oil in, when you take the plug out then the oil should just drip out to show it`s at the correct level, but you will need to fill the box through the little filler tube at the front of the box, this has a plastic cap on to be sure to get it to the right level bob wise from Berkshire

To check the level you need to have the gearbox oil around 45deg c engine running and take the plug out of the sump. There is a tube on the inside of the plug that will have a small amount of oil in, when you take the plug out then the oil should just drip out to show it`s at the correct level, but you will need to fill the box through the little filler tube at the front of the box, this has a plastic cap on to be sure to get it to the right level bob wise from Berkshire

Submitted: 23/10/2012 09:14:38 | ID: 66289

Answer this question

woodgate john, Hampshire

Ford Galaxy

how many litres of petrol are left in tank when light comes on in my 2000 ford galaxy 2.3 petrol

Answers

how much petrol is in my ford 2.3 galaxy tank when light comes on year 2000 woodgate john from Hampshire

Submitted: 15/10/2014 13:20:24 | ID: 104639

Answer this question

Ruby, England

Ford Kuga

When I locked my Ford Kuga tonight the lights under the wing mirrors, which usually turn off automatically, won’t go off. Why?

Answers

How strange, we have exactly the same problem tonight. Have you had any luck turning them off ? Rebecca from Derbyshire

How strange, we have exactly the same problem tonight. Have you had any luck turning them off ? Rebecca from Derbyshire

Submitted: 11/11/2013 10:27:39 | ID: 57600

Answer this question

Emma, Cambridgeshire

Ford Fiesta

Hi. I have an 08 1.2 Fiesta Zetec and my phone or sat nav won't charge, although it does look rusty it's worked fine till now? Any ideas on how to change the fuse and what fuse it needs?

Answers

I have an 03 and although yours is after facelift I believe the fusebox is behind the glove box, 2 simple screws to remove this and you will see the fuses. There is a diagram on the rear of the glovebox as to which fuse it is, if not go through each fuse to see if it has blown. I believe it is a 7.5 fuse which is blue. Ben hastings from Essex

I have an 03 and although yours is after facelift I believe the fusebox is behind the glove box, 2 simple screws to remove this and you will see the fuses. There is a diagram on the rear of the glovebox as to which fuse it is, if not go through each fuse to see if it has blown. I believe it is a 7.5 fuse which is blue. Ben hastings from Essex

Submitted: 26/09/2014 07:58:43 | ID: 103674

Answer this question

Grant Travers, England

Ford Fiesta 2007

I’ve got a problem with my Ford Fiesta. When I’m gentle with the accelerator the car revs to 5,500rpm and then cuts out and restarts when the revs hit 0. But if you put the pedal to the floor the car will do the same yet at only 3,000 rpm. I’ve taken the induction hose off to monitor the butterfly whilst revving the car and the throttle doesn’t seem to open until the car hits full throttle - could this be a malfunction on the throttle itself as I’m led to believe the throttle positioning sensor is built in to this unit or could it be another sensor elsewhere? The only reason I put my finger on the throttle is with it failing to open. Can anyone shed some light on this problem for me? (ST150)

Answers

This was the crank sensor that was clogged up with dirt, gave it a clean and it sorted it. I meant to reply to this sooner but completely forgot Grant travers from South Yorkshire

Submitted: 23/11/2011 11:01:55 | ID: 74461

Answer this question

Jim Green, West Midlands

Ford Kuga

Can any one tell what the switch on the drivers door is for ?

Answers

If you're talking about the switch on the driver`s side placed right at the handle, it deactivates the internal sensor if you have left say a pet or child in the car and you intend to lock the car for a short period. You get the same alarm security without the alarm going off because a movement inside has been detected by the sensor. I hope that sorts your switch problem out ian from County Down

Submitted: 06/07/2014 12:39:19 | ID: 99069

Answer this question

tina crossett, Lancashire

Ford Ka

Can the centre of a steel wheel just snap of when driving

Answers

It has never been heard of where the center just separates!! anton lufti from Essex

Submitted: 06/06/2014 11:55:55 | ID: 97039

Answer this question

Sophie Goodwin, Southend-on-Sea

Ford Ka

hi, the other day i was driving and my car came to a slow stop, i couldn't get the engine to tick over. my breakdown cover came out and told me it was my fuel pump. later that evening i had a mechanic come round and change the fuse and its working again, but i have been advised to get my pump changed. i have never had a problem with the car cutting out in the past this was the first time. since the new fuse my car has worked but i am worrying if it will happen again. Do you think it was a one off or my pump needs changing?

Answers

Bad tickover and cutting out Possible cause is the idle control valve (needs cleaning) And check airfilter Spark plugs anton lufti from Essex

Submitted: 12/09/2014 20:13:48 | ID: 103018

Answer this question